WordPress.org

Ready to get started?Download WordPress

Forums

OK I am new to MySQL Databases and having trouble with the install (8 posts)

  1. tattoo
    Member
    Posted 9 years ago #

    OK I never had mySQL options on the previous site I did so I am learning all about it now. I had no trouble creating the database and setting up coppermine photo gallery, but now I get the message :
    "Can’t select database
    We were able to connect to the database server (which means your username and password is okay) but not able to select the tattoo82_blog database.

    Are you sure it exists?
    On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?
    If you don't know how to setup a database you should contact your host. If all else fails you may find help at the WordPress Support Forums."

    when I try to do the install. I edited my wp-config.php file with note pad, and put the appropriate database files and username/password just as they displayed in my webhost control panel after creating them... Any suggestions on how to help this lost newbie? I am so sick of lame sites like myspace and live journal to weblog, and now that I am doing my own site this script seems perfect for me... if I can get it up and running lol

  2. moshu
    Member
    Posted 9 years ago #

    and put the appropriate database files

    You mean the db name, db host?

    my webhost control panel...
    What kind of control panel do you have? You may want to take a look at the tutorials for different control panels:
    http://codex.wordpress.org/Installing_WordPress

  3. tattoo
    Member
    Posted 9 years ago #

    I have acenet as a webhost and the control pannel they use has a MySQL databases section (where I created the db name, db user, and db pass. I don't know why it isn't able to access them... the host I used was the default local or whatever was there (which worked setting up coppermine gallery) so I am not sure what is wrong ...

  4. kickass
    Member
    Posted 9 years ago #

    Usually when you set up the database you have to create the user, create the dbase then add the user to the dbase. If you don't add the user to the dbase the server will not be able to access the dbase using that user/pw combo. From what you're saying, I suspect this step wasn't taken. If it isn't then you can't proceed further. I'd delete all dbases and users and start over, making sure to add the user to the database, then start with a clean install of wordpress. If all is as I said, the clean install should go right through.

    I use the cpanel my host provides to handle this dbase admin stuff, though I understand phpmyadmin handles it too.

    I hope this helps.

  5. tattoo
    Member
    Posted 9 years ago #

    I am now at the first install step! wahoo! thanks for the help, its funny you reccomended a full delete and start over, Its all I needed to realize my STUPID mistake lol. I had set up the db, the username and pass... however the first round I forgot to grant permissions/access to the given username LOL anywho it all worked out, stepping a way for a while, some helpful advice from kind people like you and surprise surprise your brain starts to function again ;) thanks so much once again

  6. kickass
    Member
    Posted 9 years ago #

    Ah yes! I made this mistake when I set up my very first dbase, so it stuck in my mind as one that could be made! I'm glad things were resolved happily.

  7. xdhirax
    Member
    Posted 9 years ago #

    Hi Ya'll,

    Just want to say thanks for the replies. I was about to make the EXACT same post because I had the EXACT same error,...and I looked to see if there was a post here.

    Let me see if I can state it another way for somone else who might be reading it.

    1. In the control panel First create the user (click the button, give it a user name) and include your password.
    2. Next, create the database (click the button, give it a database name)
    3. THEN......this is the all important step, click on "Add user to DB"...............that's it.

    Then you use your broser to go to http://www.YourDmain.com/wp-admin/install.php, and...voila you're all set.

    I love numbered lists....hope that helps somone.

    Dhira

  8. pixeestyx1017
    Member
    Posted 9 years ago #

    Thank yuo so much for this!!! I just realized that I had done precisely the same exact thing - I created the DB and forgot to create the user. *facepalm* Thank you for saving yet more headaches!

    Den

Topic Closed

This topic has been closed to new replies.

About this Topic