WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery Voting
[resolved] ok heres a weird one... (12 posts)

  1. montesdesigns
    Member
    Posted 1 year ago #

    Witht he Next Gen Premium version installed when i go to ngg voting then settings and try to change my options for image settings such as number of votes allowed option then hit update all images i get the following error:

    Warning: mkdir() [function.mkdir]: No such file or directory in /mounted-storage/wp-content/plugins/nextgen-gallery-voting-premium/nextgen-gallery-voting-premium.php on line 121
    
    Warning: chmod() [function.chmod]: No such file or directory in /mounted-storage/wp-content/plugins/nextgen-gallery-voting-premium/nextgen-gallery-voting-premium.php on line 122

    http://wordpress.org/extend/plugins/nextgen-gallery-voting/

  2. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    Hi montesdesigns
    That is an unusual error. That code is trying to create a directory inside your uploads directory to store the 'like' images, if you change them in the settings.

    It uses some very generic WordPress functions to find your directory, so I can't think why it would fail. Have you set your WordPress upload directory different to the default?

  3. montesdesigns
    Member
    Posted 1 year ago #

    Hi Shauno,

    What is the default dir for wordpress uploads what is this normally set too? i may have but can't recall i could check the settings and let you know... the odd thing is this doesn't effect any functionality of the plugin and the like or Thumbs image does show so i don't get why this issue is happening either lol.

    Thanks for your help.

  4. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    By default it's set to wp-content/uploads/ or something like that. You used to be able to change it through WP's general settings, but that's since been remove in 3.5. You now need to add a constant UPLOADS to your wp-config.php. It sounds like you haven't changed it then.

    So you saying you can successfully upload a 'like' voting image, and it saves and works as expected? I will do some debugging, I might just simply need to suppress the warning on certain setups.
    I am working on a new feature in Premium, so I should have another release out in not too long.

  5. montesdesigns
    Member
    Posted 1 year ago #

    well i didn't upload anything is the thing i didn't attach or change the button maybe this could be why this is prompting? i have yet to try that feature. but when i change another setting on that page and click save is when it pops the error at the top

  6. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    It shouldn't throw the error regardless of if you are uploading the image. Every time the settings for is submitted, it checks if the upload directory is created, and then creates it if it can't find it.

    Is your site a clean install of 3.5, or did you update from a previous version of WP?

  7. montesdesigns
    Member
    Posted 1 year ago #

    i hear you. i can't recall the install version is there a way to find out? also just wanted to run this by you also i am getting a database connection limit reached by my server. I am allowed 20 connections at a time and for some reason a code is not closing them could you tell me if this solution pertains to your plugin. your feedback on this fix suggested by my host is appreciated.

    Your script is generating too many mysql connections at a time. I would like to suggest you a couple of things which you should always keep in mind.

    1. Check that your PHP code and any other tools always close connections - many database servers require this, and it is good practice.

    2. Use mysql_connect() instead of mysql_pconnect() unless you have a good reason to do so.

    3. always put a mysql_close() in the scripts you are using.

  8. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    My plugin (and pretty much all WP plugins) use the built in WP database functions. The plugin doesn't control the opening and closing of the connection at all, but WP will close the connection when the page is done loading.

    As far as I'm aware, once a page starts to load, WP connects to the database. This connection is then used for all queries on that page load. That means the page can run 1 or 100 queries, and it's only 1 connection to the database.

    If you have more than 1 user loading a page at the same time, they each take a connection. This might mean that you have lots of people active on your site at the same time (a good thing!). You might need to upgrade your hosting package to handle more traffic.

  9. montesdesigns
    Member
    Posted 1 year ago #

    ill have to bug my host on this issue more i have never had this before.. lol so weird.

    thanks shauno!

  10. montesdesigns
    Member
    Posted 1 year ago #

    going back to your original question it may have been an upgrade.

  11. montesdesigns
    Member
    Posted 1 year ago #

    this is fixed!? i changed host this may have fix the issue :D

  12. shauno
    Member
    Plugin Author

    Posted 1 year ago #

    I haven't made any changes for this. It must have just been a problem with your previous host.
    Glad it's sorted :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.