WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Fan Box Cache
"Official" Help Forum for Facebook Fan Box Cache (85 posts)

  1. AlanP57
    Member
    Posted 3 years ago #

    Donald,

    On a future release, could you add a 'like' button?

  2. Donald Gilbert
    Member
    Plugin Author

    Posted 3 years ago #

    @AlanP57 - It's possible, but doing so requires un-doing the advantages of this plugin. Meaning, all Facebook Like buttons that allow you to like a page without going to Facebook use an iframe. It may be possible in the future to accomplish this, since all the necessary javascripts are available, but I don't know at this time.

    @6x7 - the presence of .widget_FBCache is dependent upon your theme and it's usage of the WP function, register_sidebar(). The next update will remove this dependency and update the CSS rules.

  3. Donald Gilbert
    Member
    Plugin Author

    Posted 2 years ago #

    Version 2.0 has been released - please install and let me know how it works for you. Thanks.

  4. Steve
    Member
    Posted 2 years ago #

    Thanks for the update Donald.

    Has speeded up my website by over 6 seconds! Fantastic plugin and saved me dumping the manual iframe I previously had.

    On my website, http://www.merchistounhall.co.uk with limit of 6, 140px wide, and 'Facebook style' CSS I noticed that the 'Merchistoun Hall on Facebook' text is now wrapping and the line underneath it is too long.

    Any help very much appreciated!

  5. Donald Gilbert
    Member
    Plugin Author

    Posted 2 years ago #

    @supersonic - thanks for the response. It looks like with the introduction of themes, setting the width in the admin doesn't override the setting in the theme css file.

    If you can, go into the css/style_fb.css file, and change line 1 to width of 170px from 225, and that will fix the layout on your site.

    I need to rework the codebase, as it's become kind of a mess throughout the development process - that *should* fix the issue you're experiencing.

  6. Steve
    Member
    Posted 2 years ago #

    Thank you Donald, that was an easy tweak, all fixed now, and the Facebook box looks fantastic!

    Thanks again!

  7. robnalexpress
    Member
    Posted 2 years ago #

    Upgraded to 2.0 (by mistake) and now have all thumbnails in a vertical row at http://trianglehomesuccess.com/

    Need to fix this a.s.a.p. or remove it or go back to previous version. Thanks!

    Went back to 1.5 and got it sorted out.

  8. onetrickp0ny
    Member
    Posted 2 years ago #

    Hi Donald,

    Something weird happening for me. I can only set css to "disable" -- when I set it to anything else, and save the page, it just pops back to "disable" and doesn't save any of the other settings. I'm using version 2.0 on the latest wordpress. Any help?

  9. Donald Gilbert
    Member
    Plugin Author

    Posted 2 years ago #

    Try making the change in your Widget Settings specifically. I am working on updating the admin still, so you may still experience issues.

  10. onetrickp0ny
    Member
    Posted 2 years ago #

    Hi Donald,

    Not sure what you mean. There are no separate widget settings in the widget area. Did you mean something else? I'm not a coder, so hoping I can find a way to make it work just with the dropdown (which is probably your intention too).

    Thanks!

  11. Donald Gilbert
    Member
    Plugin Author

    Posted 2 years ago #

    It is/was my intention.

    There are settings in the FB Cache widget. Those are going away in the next version though. The next update is going to be a large re-write of the codebase - that will streamline the whole process.

  12. robnalexpress
    Member
    Posted 2 years ago #

    Checked my sites this morning and all thumbnails for the plugin are gone and the "Become a Fan link directs back to the site home page. Deactivated, reactivated, deleted, reinstalled and no joy. Something on the facebook side? I noticed my other FB apps don't show unless logged into FB on the same browser. My site is here.

    I recently edited my FB privacy settings and think that might be the problem, but I can't figure it out!

  13. robnalexpress
    Member
    Posted 2 years ago #

    SOLVED above issue by removing the country restriction from FB page settings.

  14. peteratomic
    Member
    Posted 2 years ago #

    seems that after an update all of the fan graphics are screwed up... tried setting different style sheet settings but didn't help:

    http://www.atomicdesignstudios.com/blog/clients/

  15. shecky
    Member
    Posted 2 years ago #

    Hi Donald!

    Your plugin is wonderful, but there is a potential problem.
    For retrieve image from Facebook you use file_get_contents.
    This involves allow_url_fopen enabled in the server configuration, and this is a potential security issue on server.

    So I have modify your plugin to retrieve images with CURL :-P

    If you want the file modify, please reply to this post and tell me where I can send it.

    Regards.
    Davide.

    P.S.: sorry for my bad english!

  16. Donald Gilbert
    Member
    Plugin Author

    Posted 2 years ago #

    sure, send it over - don@dongilbert.net

    I'm working on converting this plugin over to use the WP_HTTP class instead of strictly cURL - but I'm sure your code will be helpful.

  17. shecky
    Member
    Posted 2 years ago #

    Mail sent ;-)

    Regards.
    Davide.

  18. davidstage
    Member
    Posted 2 years ago #

    Hey Donald,

    I'm currently developing a site that is not ready for public consumption but will happily email the link to you so you can look into this issue. I just thought I would post this on here first.

    Two issues I am having:

    One is that in some cases when I access the site, it shows two of the same images/profiles, for one the link displays the name and for the other it displays the profile ID number.

    Two is that even if I clear out the cache, for whatever reason 4 of the connection/images/names aren't assigned a link. It's weird because it's never just 2 or 3, always 4. The placement on the grid of the broken links is never the same.

    Any suggestions or advice you can offer would be of great help. Thanks!

    My email is dmstage@mac.com if you wish to contact me there.

  19. doubleredwine
    Member
    Posted 2 years ago #

    Hi, I have added your widget to my WP site, after browsing through several, I liked yours better. Congratulations.

    But there was one thing in common with them all, once I activate it and got it running, the links that were there (archives, tags, wordpress default links) go away.

    Is there a way to fix this?
    you can see it at
    http://cinemaniamexico.com/sitio/

    Any help will be totally appreciated!!!

  20. Donald Gilbert
    Member
    Plugin Author

    Posted 2 years ago #

    @davidstage - are you still experiencing the issue?

    @doubleredwine - once you place a widget in the sidebar, it will remove any default / hardcoded widgets that are in the theme. Is my widget the only one that you have under your Appearance -> Widgets menu?

  21. Steve
    Member
    Posted 2 years ago #

    Hi Donald - I see you have updated the plugin to 2.0.1, before I take the plunge can you advise what is in the 'Changelog'? Thanks again!

  22. tonydbaker
    Member
    Posted 2 years ago #

    Hi Donald

    Love your plugin. We wanted something that wouldn't take away from our design, and yours is perfect.

    The problem I'm having is with people with long first names. Look at the user Candi. By including her maiden name, it's throwing off my design.

    I can't ban her from our fan page, and I would be embarrassed to ask her to change her name. Is alphabetical the only way it shows up?

    So, is there a way to write some sort of if/then statement for names with too many characters?

    Thanks!
    Tony

  23. Donald Gilbert
    Member
    Plugin Author

    Posted 2 years ago #

    @tonydbaker - Thanks! It would be possible to truncate the user names before we cache the file - I'll consider that for the next release. I wouldn't want to make it default though - would probably add that as an option.

  24. Colir
    Member
    Posted 2 years ago #

    hi Donald,

    i'm trying to use fb-cache.
    I've call the widget like this in my footer
    <?php echo do_shortcode( '[fanbox id="xxxxx" limit="10"]' ); ?>

    but this return me an error

    Fatal error: Call to undefined function curl_init() in xxx\wp-content\plugins\facebook-fan-box-cache\facebook-fan-box-cache.php on line 231

    i use fbCache Version 2.0.1

    any idea on what is going wrong ?

    thanks you

  25. Colir
    Member
    Posted 2 years ago #

    Sorry Donald,
    i've had this error due to the curl module which wasn't install on my localhost.

    So i install it, and now fbCache work well.
    (sorry for my previous post, but i thought that you no longer use curl in version 2)

    However i've 1 little problem, and 1 request...

    My problem => fbcache cached an image of a friend who is name is "Ophélie",
    but named it "Ophélie.jpg"...so as you can imagine the picture doesn't displayed

    My request => can we have cached picture of face, which dont need to be update often, but have a real "like button" ?

    thanks, and congratulation for this plugin

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic