WordPress.org

Ready to get started?Download WordPress

Forums

Oddity with the good old defaultwebpage.cgi showing up on a cPanel install (4 posts)

  1. ylluminate
    Member
    Posted 1 year ago #

    I'm running WHM/cPanel on a dedicated host and for a particular project I've got going we need to leverage MultiSite.

    Just to preface, sub.domain.tld/wp-admin seems to work just fine as it throws the visitor over to http://sub.domain.tld/wp-login.php?redirect_to=http%3A%2F%sub.domain.tld%2Fwp-admin%2F&reauth=1.

    However, when you visit the sub.domain.tld you're redirected to http://sub.domain.tld/cgi-sys/defaultwebpage.cgi.

    I suspected that this was a config issue with either CloudFlare or cPanel, however I don't see any incongruencies:
    CloudFlare: http://cl.ly/image/0o0K0K0c0E2S
    cPanel: http://cl.ly/image/0c2e1p1K3j3e

    When I take a look at /etc/httpd/domlogs/_wildcard_.domain.tld it is indeed hitting the wildcard. Further, both the primary domain.tld and *.domain.tld are directed to the same /home/username/public_html, so that's not a problem.

    public_html/.htaccess shows the following:
    https://gist.github.com/ylluminate/db8c9c1403a75ce0a029

    Any ideas as to what may be causing cPanel to want to load up cgi-sys/defaultwebpage.cgi instead of the WP public_html/index.php?

  2. However, when you visit the sub.domain.tld you're redirected to http://sub.domain.tld/cgi-sys/defaultwebpage.cgi.

    That tells me you didn't set up the wildcard subdomains correctly and cpanel is pointing to it's own folder (usually public_html/sub) instead of just plain old public_html

    How did you make the subdomain in cpanel?

  3. ylluminate
    Member
    Posted 1 year ago #

    I understand, but all of that checks out @Ipstenu. I created them via cpanel. Initially I created an additional *.domain.tld (in addition to http://www.domain.tld). As I had these results, I thought I'd just remove www and use solely *. When I look into the httpd.conf everything is fine and indeed they BOTH (naked domain and the _wildcard_) are pointing to /home/username/public_html and not to any subfolder or such.

  4. What happens when you go to totallyfakesubdomain.domain.tld ?

Topic Closed

This topic has been closed to new replies.

About this Topic