WordPress.org

Ready to get started?Download WordPress

Forums

Odd "Older Entries" link problem (firefox/ie) (30 posts)

  1. jamesisin
    Member
    Posted 5 years ago #

    My blog is located at:

    http://soundunreason.com/InkWell

    If one types in:

    http://soundunreason.com/inkwell

    one will arrive pleasantly enough at my blog. However, if one then tries to click the "Older Entries" link at the bottom of the page in either Firefox or IE, the link offered is:

    http://www.soundunreason.com/InkWell/inkwell/index.php?paged=2

    As you can see, when inkwell (lowercase) is used in the original URL Ff and IE want to add that into the link. What's going on? Is this a known bug? How can I fix it (outside of changing the folder name on my server)?

  2. jamesisin
    Member
    Posted 5 years ago #

    Oh, this also happen in Opera.

    Here is the line of source code as it appears on the uppercase page:

    <div class="alignleft"><a href="http://www.soundunreason.com/InkWell/index.php?paged=2" >&laquo; Older Entries</a></div>

    Here is the line of source code as it appears on the lowercase page:

    <div class="alignleft"><a href="http://www.soundunreason.com/InkWell/inkwell/index.php?paged=2" >&laquo; Older Entries</a></div>

    This appears to be the only link thus effected.

  3. jamesisin
    Member
    Posted 5 years ago #

    Anybody?

  4. jamesisin
    Member
    Posted 5 years ago #

    Still broken. Any help out there?

  5. Well one answer would be 'Move it from InkWell to inkwell.'

    URIs are case sensitive.

  6. jamesisin
    Member
    Posted 5 years ago #

    Case sensitivity in URL's is handled at the server level. My server is non-case sensitive. WP is adding an extra folder level in when the originating URL uses the lowercase version. This seems to be a problem with the way the URL's (links) are generated by WP/PHP. I'm just not clear how that works.

    Surely there is a way to advise WP that my URL is InkWell and not inkwell. It's adding that in somewhere. (It's making a bad assumption maybe.)

    The only alternative I could come up with was adding in a auto-forward (from one case to the other), but since Windows isn't case sensitive I'd have to do a little research on how to go about that. (I can't just put an html file which fowards to the primary case from the secondary because Windows will view the folder inkwell as identical to InkWell and won't allow them to coexist.)

  7. jamesisin
    Member
    Posted 5 years ago #

    I ran another bit of testing.

    Every other link WP generates will change the URL from inkwell to InkWell without adding anything but what ought to be added. It is only for the Older Entries (and the Newer Entries) link that this oddity exists.

    This really looks like a bug to me.

  8. In your WP settings, do you have the URL as inkwell or InkWell?

    FYI, no matter if you put in inkwell, INKwell, INKWell, etc, if it's NOT InkWell, it goes weird. I'd need to find someone else's WP on Windows setup to poke before I said it was WP or your server config.

    Frankly the easiest answer (in my mind) is to rename InkWell to inkwell. Yeah, it may be WP, but I suspect this would crop up more often if it were. Lowercase is preferred with web pages anyway.

  9. jamesisin
    Member
    Posted 5 years ago #

    Well, I will test this but I think the result will be that the problem will be reversed.

    I tend to post my URL so it reads SoundUnReason.com/InkWell because I think this is easier for humans to parse and remember than the fully lowercase version. Windows automatically switches the S/U/R to s/u/r but for whatever reason it leaves the I/W alone.

    Maybe there is a way to tell Windows to re-case all requests (all segments)--I'll have to look into that.

    But, yeah, clearly WP is making a mistake somewhere. Do you know how to file a bug report?

  10. http://trac.wordpress.org - Log in with the ID/Password used here.

    Now, 'Windows' not changing InkWell to inkwell makes me think your blog URL in WordPress has the funky caps and that's why it's weird.

    Also, there's Case Insensitive Permalinks Plugin for WordPress. But I don't know if that would work.

    If this was unix, I'd say make an .htaccess to redirect :/

  11. figaro
    Member
    Posted 5 years ago #

    SoundUnReason.com/InkWell

    That may be easier for humans to parse, but not computers. Of course, I can make the name of a link I enter look anyway I want; for example, eduChalk.org but, as you will notice, the actual url is educhalk.org

    @Ipstenu advice is good...you will have fewer problems if you consider it.

  12. jamesisin
    Member
    Posted 5 years ago #

    I have noticed something that may be significant. The URL which WP offers is:

    http://www.soundunreason.com/InkWell/inkwell/index.php?paged=2

    In fact we can remove /inkwell/index.php and this link will function correctly:

    http://www.soundunreason.com/InkWell/?paged=2

    None of my other links include this additional path information.

    Does this tell us anything new? Bring us any close to a resolution?

  13. I still would like to know what your wordpress URL and blog URL is set to on wp-admin/options-general.php

  14. jamesisin
    Member
    Posted 5 years ago #

    I know this is well-meant advice but I will explain the problem with doing that.

    I have posted on the web (hundreds of times) my URL using the caps. My server has no problem dealing with the caps. It even re-normalizes the domain name (for both my SoundUnReason domain and my JamesIsIn domain)--auto-magically.

    If I change the name of the folder, the lowercase version of the URL will function as expected. However, the caps version will then be broken (as would any caps combination of the URL) according to my original post. This does not solve the problem; it moves it.

    The problem is not that I used two capital letters. That's a legitimate URL. The problem is what WP does with the URL if it differs from the caps arrangement it anticipates--for these two links.

    This does not effect any other links WP generates.

    I'm not a PHP expert or I could go into the code and look at that which generates a link like my Darkly Glasses link v that which generates these two links. (I could look at them now but I'm not sure I'd understand what the problem is.)

  15. figaro
    Member
    Posted 5 years ago #

    If I change the name of the folder, the lowercase version of the URL will function as expected. However, the caps version will then be broken (as would any caps combination of the URL) according to my original post. This does not solve the problem; it moves it.

    My best advice is to do just that...move the problem by changing the name of the folder(s) and then dump your database, do a search/replace on your sql file to change all the caps combination to lower case, then drop your original tables and import the corrected database.

    I'm no expert either, but it seems to me this would address the problem and you would be able to get back to blogging and not have to deal with this. Just my opinion and the way I would address it if it were my problem.

  16. jamesisin
    Member
    Posted 5 years ago #

    You understand that will make my problem worse, right?

    When I post my URL I use the modified case. The only time anyone will actually visit my blog using the lowercase version is if I have forgotten to modify it or they happen to type it in manually. And then they will only be effected if they happen to then scroll to the bottom of the page and use that Older (or Newer) link.

    If I change it then everyone who visits my blog from one of these links will find that link broken.

    Currently this issue is not likely to effect very many visitors. If I change the case it will have the potential to effect nearly all of them.

    Beyond that, the proposed workaround ignores the fact that something is clearly broken. If this problem were effecting all the links WP generated then I could see things differently. But it's only this one (or two) links. Something is wrong with the code used to generate those links and only those links.

    This really looks like a bug. Probably very minor and not likely to effect many users, but equally likely very simple to track down and fix.

  17. figaro
    Member
    Posted 5 years ago #

    Well, good luck...maybe someone else can help.

  18. jamesisin, third time I've asked this to no answer.

    WHAT exactly are your WordPress URL and Blog URL set to?

  19. jamesisin
    Member
    Posted 5 years ago #

    Sorry to have overlooked that.

    The default is for them to conform (so both modified). I have tried changing them each to lowercase but I'm not clear how that change takes effect.

  20. BTW, most people here are *nix savvy and less so IIS.

    The default is for them to conform (so both modified).

    So you're saying they're http://SoundUnReason.com/InkWell then? (BTW, SoundUnreason would make more 'sense' than SoundUnReason but ...)

    Still this makes no sense, I agree, but I still think it's Windows and not WordPress (or rather, Windows would do this on ANY blog/CMS and not just WordPress).

    What version of IIS are you using? If it's 7.0, I think you can use this Microsoft URL Rewrite Module for IIS 7.0 (x86) and chuck the whole thing. You could also try putting IIS Mod Rewrite and have inkwell/InkWell redirect.

  21. jamesisin
    Member
    Posted 5 years ago #

    Changing the WordPress address (URL) seems to affect all of the admin links (edit, login/out, &c). It makes no change to the Older/Newer links.

    I have tried both case-versions (and even simply /InkWell and /inkwell) in Blog address (URL) and I cannot see that this makes any changes.

  22. Yeah, this is why I think it's your server and not wordpress.... There's something TELLING it that when the server is /inkwell, it needs an extra folder. You're not using any mod rewrite or similar are you?

    What code are you using in index.php for previous/next?

    Mine's <?php posts_nav_link(' - ','« Prev','Next »') ?>

  23. jamesisin
    Member
    Posted 5 years ago #

    Yeah, I feel the waves of loneliness all the time. I have linux boxes but for now it is better for me to have this particular machine running my blog. So it goes.

    I think IIS 7 comes with 2008. I'm running 2003, so IIS 6.

    I'm picking through that right now looking for a setting which might allow me to do just that.

    But I really should file this as a bug. Do you know how to do that?

  24. jamesisin
    Member
    Posted 5 years ago #

    I have not modified any index files so whatever is default. Which file are we talking about? (There is one in the WP root folder and another in the content sub...)

    Do you know where the code which generates this Older/Newer link is located?

  25. To log a bug, go to http://trac.wordpress.org - Log in with the ID/Password used here.

    You haven't made any theme modifications at all?

    Any plugins?

  26. jamesisin
    Member
    Posted 5 years ago #

    I use the default theme (as is probably obvious) and don't mess with it. Very vanilla. Sorry.

    Disabling all plugins makes no difference.

  27. jamesisin
    Member
    Posted 5 years ago #

    I have filed a bug report:

    http://trac.wordpress.org/ticket/8847

  28. jamesisin
    Member
    Posted 5 years ago #

    Thanks for working with me to troubleshoot this, by the way. I appreciate it.

  29. jamesisin
    Member
    Posted 5 years ago #

    [deleted: wrong thread]

  30. hakre
    Member
    Posted 4 years ago #

    Jamesisin, have you upgraded your blog to 2.8.x and can you confirm the problem still exists?

    Do you use the default theme? If not please switch to the default theme and take a look if the problem still exists.

    If yes, then do you use plugins? If yes, please deactivate all plugins and take a look if the problem still exists.

    Please report this back to the ticket as well.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags