WordPress.org

Ready to get started?Download WordPress

Forums

WP-SimpleViewer
Odd behaviour of Simple viewer with Artisteer (4 posts)

  1. drayscherm
    Member
    Posted 1 year ago #

    I have developed a WP website using Artisteer 4.0. The home page contains a Simple Viewer slide show and I suspect that some conflict with Artisteer introduces some very odd rendering of the home page.

    The first time you land on http://toanklein.com you will notice that the footer at the bottom of the screen overlaps text (or images, depending of the size of your screen). If you resize the window, the resulting screen has the footer at the bottom of the page and does not overlap any of the text. This is true in all the browsers I've tried (Firefox, Chrome, Safari, IE9, and Opera).

    Is the mix of Artisteer-generated code and Simple Viewer to blame? Is their some way to fix this?

    At the moment the only option seems to drop Simple Viewer in favour of another plugin.

    Any suggestions or advice would be appreciated (including the recommendation of a similar plugin).

    Thanks....Duane

    http://wordpress.org/extend/plugins/wp-simpleviewer/

  2. Steven
    Member
    Posted 1 year ago #

    Any suggestions or advice would be appreciated

    As a test, try creating a new post and insert only a div with dimensions the same as your gallery to see how your theme reacts, e.g.:
    <div style="width: 100%; height: 600px; background-color: #ff0000;">&nbsp;</div>
    When entering the code above into the body of your post, make sure that the method of entry is 'Text' rather than 'Visual'.
    If the same problem occurs, then the problem is not directly related to the SimpleViewer gallery and is likely to be due to your theme.

    (including the recommendation of a similar plugin).

    As an alternative gallery plugin, you could try WP-Juicebox. It is very similar in style to WP-SimpleViewer but, being HTML rather than Flash, it does not internally use SWFObject to embed a SWF file into your page. It might make a difference and be worth a try.

  3. drayscherm
    Member
    Posted 1 year ago #

    Hi, Steven.

    Thanks for your suggestion. I never got around to giving it a try, because I also heard back from Artisteer support and they suggested that I try regenerating the theme with the latest version of Artisteer.

    That solved the problem.

    Bottom line: the problem was with the code generated by Artisteer, not with the Simple Viewer plug-in.

    Thanks again....Duane

  4. Steven
    Member
    Posted 1 year ago #

    I am glad that you have resolved your problem.
    Thank you for posting back to let me know.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic