WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Odd Behavior when Trashing in Network (4 posts)

  1. fleetadmiralj
    Member
    Posted 2 years ago #

    A couple notes:

    1) I think I was getting some of this behavior when using 3.2, but I'm not 100% sure (I don't usually trash things)

    2) Behavior stays even when plugins are disabled

    3) I'm using the WP Multi-Network plugin to manage multiple networks, if that's relevant.

    In any case, when I am on a blog admin's edit page and I click "Trash" under a post, instead of being redirected to http://example.org/blog/wp-admin/edit.php or wherever it's supposed to go, it redirects to http://example.org/?trashed=1&ids=35 (or whatever the id of the post is). A similar thing happens when I untrash.

    It successfully trashes or untrashes the item, it just seems like it is redirecting incorrectly. I do have ScriptNo running in Chrome, but it says everything in trusted. All other options on the edit page appear to work. Selecting "Move to Trash" when editing the post itself results in the same behavior.

    A similar thing also happens when I delete an attachment in the post's media manager.

    I've gone through the code and the database seeing if I can find any clues as to why this is happening, and I can't seem to find anything. I don't know if it's the Multi-Network plugin not playing nice with recent versions of WordPress or what the problem is. It's not a show stopper problem but it is really annoying.

  2. fleetadmiralj
    Member
    Posted 2 years ago #

    OK, an update: it works properly in Internet Explorer, Safari (Mac and PC), Firefox (PC, didn't test on Mac cause my Mac hates FF), and Chrome on PC, which DOESN'T have the ScriptNo extension...

    So I disabled it in Chrome on mac and...voila...it works properly. So apparently even though it SAYS it's it's trusting all the scripting and stuff on the site, that plugin is apparently still interfering with the site enough to muck up that redirect functionality. OK, nevermind, nothing to see here...

  3. cmwelsh
    Member
    Posted 1 year ago #

    I also had this problem. It seems to be an issue with ScriptNo. I had the extension enabled in Google Chrome, but I had it turned off.

    The fix is like you said - to completely disable the ScriptNo extension.

  4. axwax
    Member
    Posted 1 year ago #

    For the record this also happens in "normal" (ie non-network) setups. I also haven't found a solution other than disabling ScriptNo.

Topic Closed

This topic has been closed to new replies.

About this Topic