WordPress.org

Ready to get started?Download WordPress

Forums

Instagrab
[resolved] OAuthException in instagrabLogin (6 posts)

  1. alternatego
    Member
    Posted 1 year ago #

    I was getting the following OAuthException when the plugin tried to gett an access token from instagram: "XAuth rate limit exceeded" I played around with the request parameters a bit and determined it had something to do with your client "application". After having gone over instagram's API documentation I wondered if this plugin even needed to authenticate in this way. So, I tried changing the url parameters in the https://api.instagram.com/v1/tags/hashtag/media/recent request from using the access_code (which was null in my case) to simply use "client_id" and your client id. It worked. I guess this is more of a heads-up for you. But, if anyone can tell me why I shouldn't be doing it this way that would be great too,

    http://wordpress.org/extend/plugins/instagrab/

  2. Ole-Kenneth
    Member
    Plugin Author

    Posted 1 year ago #

    New version should fix this.

  3. blackbottomlighters
    Member
    Posted 1 year ago #

    I've downloaded the new version. I get the following error when I run the test run: Filename cannot be empty in /home/content/85/9808785/html/wordpress/wp-content/plugins/instagrab/instagrab.php on line 246

    Please tell me how I can fix this? Thanks

  4. Ole-Kenneth
    Member
    Plugin Author

    Posted 1 year ago #

    This is most likely because you have entered an hashtag which does not meet this criteria a-z/A-Z/0-9/-

    It does not support Ø Æ Å or dot, commas etc.

  5. blackbottomlighters
    Member
    Posted 1 year ago #

    I'm using blackbottomlighters, bblstylee, and bblstylie as hashtags. Here is the full report (via http://www.blackbottomlighters.net) :

    Using access token: 23640758.90c2afb.2a8ad86154c446b3a927b97731775038
    Unable to download any images from #blackbottomlighters
    Unable to download any images from #bblstylee
    Unable to download any images from #bblstylie

    Warning: file_get_contents() [function.file-get-contents]: Filename cannot be empty in /home/content/85/9808785/html/wordpress/wp-content/plugins/instagrab/instagrab.php on line 246
    Unable to download any images from #

    Warning: file_get_contents() [function.file-get-contents]: Filename cannot be empty in /home/content/85/9808785/html/wordpress/wp-content/plugins/instagrab/instagrab.php on line 246
    Unable to download any images from #

  6. Ole-Kenneth
    Member
    Plugin Author

    Posted 1 year ago #

    For all of you with GoDaddy.

    You have to enable file_get_contents() in the php.ini file.

    Change the
    allow_url_fopen = off
    to
    allow_url_fopen = on

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic