WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] NOW I CAN'T LOGIN TO MY WP ADMIN (30 posts)

  1. TBaker14
    Member
    Posted 3 years ago #

    OK...I've been messing around with my site trying to get a few things to work. Now, when I go to my "www.xxxxxx.ca/wp-admin" login URL, I have no way of logging in...here's what happens...

    I have a Maintenance Plugin that is running right now...
    My site URL is http://www.tandem-solutions.ca
    I used to have the WordPress URL and Site URL the same (above).
    I changed the WordPress URL to http://www.tandem-solutions.ca/hr-news

    NOW...when I go to http://www.tandem-solutions.ca/wp-admin (to try and login) it redirects to http://www.tandem-solutions.ca/hr-news/wp-login.php and it shows my Maintenance page...AND I NO LONGER GET THE ADMIN LOGIN USERNAME AND PASSWORD.

    It's like it is stuck in a loop....WHAT DO I DO....HELP!!!!!!

  2. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    change the url back to original
    http://codex.wordpress.org/Changing_The_Site_URL
    then do it properly, once you have access again:
    http://codex.wordpress.org/Moving_WordPress

    You can't just change the URLs...it points to a physical location of your WP files

  3. TBaker14
    Member
    Posted 3 years ago #

    how do I change the URL if I can't login to do it?

  4. TBaker14
    Member
    Posted 3 years ago #

    and I don't understand your second link about "moving WordPress"...I don't think I want to move it

  5. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    read the first link. It tells you how to change url if you can't log in

    If you want your url to be /hr-news, then you want to move WP

    http://www.tandem-solutions.ca/ is your current URL, that means your files are located in your root directory

    If you want your WP install to load from http://www.tandem-solutions.ca/hr-news you need to move WP

    /hr-news refers to a directory....a folder inside of your root level/main directory

  6. govpatel
    Member
    Posted 3 years ago #

    sorry wrong place.

  7. TBaker14
    Member
    Posted 3 years ago #

    I tried the 2nd link...didn't work.

    I tried the first link...and it sort of works...doesn't ask me to login, just goes to the page...sort of...I get these error lines

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/92/5996892/html/tandem-solutions.ca/wp-content/themes/gadget/functions.php:359) in /home/content/92/5996892/html/tandem-solutions.ca/wp-includes/functions.php on line 830

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/92/5996892/html/tandem-solutions.ca/wp-content/themes/gadget/functions.php:359) in /home/content/92/5996892/html/tandem-solutions.ca/wp-includes/functions.php on line 831

  8. TBaker14
    Member
    Posted 3 years ago #

    ...and these

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/92/5996892/html/tandem-solutions.ca/wp-content/themes/gadget/functions.php:359) in /home/content/92/5996892/html/tandem-solutions.ca/wp-login.php on line 337

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/92/5996892/html/tandem-solutions.ca/wp-content/themes/gadget/functions.php:359) in /home/content/92/5996892/html/tandem-solutions.ca/wp-login.php on line 349

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/92/5996892/html/tandem-solutions.ca/wp-content/themes/gadget/functions.php:359) in /home/content/92/5996892/html/tandem-solutions.ca/wp-includes/pluggable.php on line 690

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/92/5996892/html/tandem-solutions.ca/wp-content/themes/gadget/functions.php:359) in /home/content/92/5996892/html/tandem-solutions.ca/wp-includes/pluggable.php on line 691

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/92/5996892/html/tandem-solutions.ca/wp-content/themes/gadget/functions.php:359) in /home/content/92/5996892/html/tandem-solutions.ca/wp-includes/pluggable.php on line 692

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/92/5996892/html/tandem-solutions.ca/wp-content/themes/gadget/functions.php:359) in /home/content/92/5996892/html/tandem-solutions.ca/wp-includes/pluggable.php on line 890

  9. Rev. Voodoo
    Volunteer Moderator
    Posted 3 years ago #

    looks like you have a blank line in your themes functions.php file between php functions..like this

    code
    ?>
    blank line
    <?php
    code

    it needs to be removed. You'll probably need to use ftp or a file manager if your host offers. Upload a fresh functions.php to themes/gadgets, or fix the error if you can

  10. TBaker14
    Member
    Posted 3 years ago #

    no no...the error(s)came when I edited the wp-config file....I didn't get anywhere with the "functions" method

    I'm getting nowhere

  11. govpatel
    Member
    Posted 3 years ago #

    try rename the theme you using using ftp that will force twenty ten theme to open to rule out theme related problem

  12. TBaker14
    Member
    Posted 3 years ago #

    and how do I do that?

  13. govpatel
    Member
    Posted 3 years ago #

    log in ftp browse to wp-content/themes and in theme folder you should have gadget rename that to say gadget-bak then try and go on your website you should have twenty ten theme open if there is not other problem in core files.

  14. TBaker14
    Member
    Posted 3 years ago #

    huh?

  15. govpatel
    Member
    Posted 3 years ago #

    did it work if so then you have problem in theme.

  16. TBaker14
    Member
    Posted 3 years ago #

    OK...I'm in...but I can't change the URL's now that I have put them in the wp-admin

  17. TBaker14
    Member
    Posted 3 years ago #

    OK....I'm able to login and see my dashboard.

    However, I cannot change the URL's because they have been changed in the wp-admin...what should I do next??

  18. govpatel
    Member
    Posted 3 years ago #

    If you want to change urls then you will need move all your files and folders to new location before you change the urls as they saved in database and when you try and go on website wordpress does not find what is looking.

  19. TBaker14
    Member
    Posted 3 years ago #

    No....I want to change the URL fields in Dashboard > Settings > General...but I can't because they are "grey-ed" out due to the hard change in the wp-admin

    If I don't have those 2 lines in the wp-admin, then I can't log into my site.

    I'm kind of stuck here

  20. TBaker14
    Member
    Posted 3 years ago #

    OK...I have to leave for a couple of hours. If anyone thinks of any solutions, let me know.

    Thanks for the support so far.

    TBaker14

  21. govpatel
    Member
    Posted 3 years ago #

    so you must have have put them two urls in wp-config.php you can take them out as you hard coded them in and you will be able change them in wordpress admin Settings General

  22. TBaker14
    Member
    Posted 3 years ago #

    OK...but you're forgetting my original problem. If I don't put the 2 URL's in the wp-config I can't access my admin because I changed the site URL in the settings.

    I'm stuck...

  23. TBaker14
    Member
    Posted 3 years ago #

    OH...and if I leave the URL in the config....then login to my admin...and remove my "maintenance mode"....then try to visit my own site...there is no page!

    How do I reset my WordPress or Database altogether and start from scratch??

  24. govpatel
    Member
    Posted 3 years ago #

    ok lets start from beginning

    take those urls out of wp-config.php

    follow this instructions

    If you have access to the site via FTP, then this method will help you quickly get a site back up and running, if you changed those values incorrectly.

    1. FTP to the site, and get a copy of the active theme's functions.php file. You're going to edit it in a simple text editor (like notepad) and upload it back to the site.

    2. Add these two lines to the file, immediately after the initial "<?php" line.

    update_option('siteurl','http://example.com/blog');
    update_option('home','http://example.com/blog');

    Use your own URL instead of example.com, obviously.

    3. Upload the file back to your site, in the same location. FileZilla offers a handy "edit file" function to do all of the above rapidly; if you can use that, do so.

    4. Load the login or admin page a couple of times. The site should come back up.

    5. Repeat the above steps, but remove those lines. IMPORTANT: Do NOT leave those lines in there. Remove them immediately after the site is up and running again.

    "maintenance mode" is this plug in if so just deactivate it.

  25. TBaker14
    Member
    Posted 3 years ago #

    I'll try that (again) but as I mentioned in an earlier post, this method didn't work...let me get back to you

    Thanks for the help

  26. TBaker14
    Member
    Posted 3 years ago #

    Before I start doing this...I know that I substitute my own URL instad of "example.com"...but do I put in the "/blog" also? I didn't do that before...

  27. TBaker14
    Member
    Posted 3 years ago #

    Doesn't work...I get the following error

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/92/5996892/html/tandem-solutions.ca/wp-content/themes/gadget/functions.php:361) in /home/content/92/5996892/html/tandem-solutions.ca/wp-includes/pluggable.php on line 890

  28. TBaker14
    Member
    Posted 3 years ago #

    sort of works...but then I get an error when I "save" in the General settings

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/92/5996892/html/tandem-solutions.ca/wp-content/themes/gadget/functions.php:359) in /home/content/92/5996892/html/tandem-solutions.ca/wp-includes/pluggable.php on line 890

  29. govpatel
    Member
    Posted 3 years ago #

    the reason you getting that is that gadget theme may not be compatible with wordpress 3.0 or is broken thats why we switched to default theme earlier

    you will need to do same thing again switch to default theme and find other compatible theme.

  30. TBaker14
    Member
    Posted 3 years ago #

    I think I got it. Actually, the theme is was fine before, but I think something happended to it. I switched back to the default theme, deleted my preferred theme...and now I'll re-install.

    Looks like I'm all good...whew! That was crazy.

    Since you're so knowledgeable, perhaps you could look at my other post also...

    http://wordpress.org/support/topic/the-more-taghelp-please?replies=5

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.