WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Notification mail not sending all subscribers (6 posts)

  1. Safeer
    Member
    Posted 1 year ago #

    Hi,

    I have 1500+ subscribers, but unfortunately notification sending to only 700+ subscribers all the time. I am using SMTP (mailgun) for sending mails. I have contacted them, they are not receiving that much requests and there is no mails in que. I have used a custom script and it successfully sent to all at one go.
    I have also played with maximum execution time but no help !

    Any help is appreciated

    Thanks in advance

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @safeer,

    Most frequently, issues such as this are due to server side limitations on the sending of emails by scripts.

    Subscribe2 uses the WordPress core wp_mail() function. Are you certain that this function is plugged correctly to divert emails via your SMTP? Are you certain that the 1500+ subscribers you have are all active subscriptions.

  3. Safeer
    Member
    Posted 1 year ago #

    Thank for the response !

    I have update the plugin to the latest version and now mails are not sending at all..
    The function is plugged correctly to divert emails via your SMTP and all the 1500+ subscribers are active.
    I could send a test mail to all these 1500+ mails with a custom script, So i guess there wont be any server side limits.

    When i am trying to send mail from the "Send email" option in the subscriber2 the preview message is sending successfully but getting this error when sending mails to all,

    Message failed! Check your settings and check with your hosting provider
    SMTP Error: Data not accepted.

    SMTP server error: Too many recipients, max is 1000

  4. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @safeer,

    Have a look in the Settings page and change the number of recipients per email to 1 and try again. It may be that the maximum number of recipients per email is set to 1,000 on the server. Changing this setting to 1 will make the emails send to each individual subscriber directly rather than grouping them in a BCC email header.

  5. Safeer
    Member
    Posted 1 year ago #

    Great ! That worked !

    Thanks a lot for the excellent plugin and awesome support.

    Cheers!

  6. mattyrob
    Member
    Plugin Contributor

    Posted 1 year ago #

    @safeer,

    I'm glad we've got a solution. I found this document page over at mailgun that states the following:

    Note The maximum number of recipients allowed for Batch Sending is 1,000.

    So, at least we also know why things weren't working now too and that the solution will be a good fix.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.