WordPress.org

Ready to get started?Download WordPress

Forums

Visual Form Builder
[resolved] Notification emails not being sent when a file is uploaded with form (13 posts)

  1. HeavyArtillery
    Member
    Posted 1 year ago #

    Hi,

    I have been using form builder on my websites for a while, however this is the first time I've included the option to upload a file on the form.

    The new form I created with the upload option works perfectly when a file isn't uploaded with it (all emails are sent to both parties and form info is received via email).

    However, when a file is uploaded with the form, the email notifications are not being sent to the submitor or the submitee.

    After submitting the form, it does lead to the "Your form was successfully submitted" page and the form submission info and uploaded file are correctly saved in the database so that still works fine. The emails just aren't being sent/received when a file is uploaded with the form.

    I have checked the spam folders and completed all of the details in the Form Settings > Email section, with the Reply-To option to an email that exists on the same domain as my WordPress site.

    PHP is version 5.3
    MySQL is version 5.0
    WordPress version 3.5.1
    wp-content permissions are set to 755

    I have also optimized my server settings in the php.ini file as suggested here: http://vfb.matthewmuro.com/faq/recommended-server-settings/

    My server host is Startlogic.com. I contacted them and they said that it was an issue that they couldn't solve on their end and to contact the plugin creator for support.

    Thank you for your time & consideration!

    http://wordpress.org/extend/plugins/visual-form-builder/

  2. HeavyArtillery
    Member
    Posted 1 year ago #

    Also here is a link to the form in question: http://www.heavyartilleryrecordings.com/dev/demo-submissions/

  3. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    Depending on the file type, it may be caught by the default mime types. Otherwise, it's most likely a permissions issue.

    I know your host said it was a problem with the plugin, but it's not. Honestly, I'd recommend a different host like Media Temple, Dreamhost, or A Small Orange. Solid hosts that work great with WordPress "out of the box."

  4. HeavyArtillery
    Member
    Posted 1 year ago #

    Thank you so much for your speedy response!

    Just to clarify, Startlogic didn't say it was a problem with the plugin or that it was flawed in any way, they just said that I might have better luck to contacting you for support since they couldn't figure out the issue on their end. Either way, switching servers isn't an option for me as I am paid up through a few years, hosting all 10 of my websites with them, (all of which work perfectly with wordpress and your awesome form builder plugin until now :o) so I have no choice but to figure out this issue and make it work on my current server. it's either that or switch to a different form plugin which would suck because yours is the best I've found :o/

    That said, I called them back and gave them your advice above regarding the mime types and permissions.

    We added the .mp3 and .zip in the new mime types form just to make sure they are in there (couldn't find a current listing in the control panel).Although I imagine the .mp3 and .zip were already listed in there as they are pretty standard, right?

    The permissions are set to 755 for the folders themselves and 644 for the individual files. Could you be more specific about what might be causing a permissions issue?

    After another hour on the phone with them trying to figure it out the end result was the same...no emails when a file is uploaded with the form.

    So not without trying, they again suggested for me to contact you as you would probably have more insight as to how to solve the problem.

    Any additional help or suggestions you can provide would be greatly appreciated!

    Thanks again for your time, understanding and consideration :o)

  5. HeavyArtillery
    Member
    Posted 1 year ago #

    Okay, so after experimenting a bit more I found that the form WILL send the notification emails if a .txt or .doc file is uploaded and those files will also be attached to the email.

    It will also send notification emails if a .psd is uploaded, however the psd file is NOT attached to the notification email, nor is the link to the location of the file included or does it even show in the entries section of the form builder. I tried 2 different files (750KB), one small and one larger (5MB), and neither came attached to the email that was received. I'm assuming this is because the .psd file type isn't listed in the wordpress mime types but I did this experiment just to see what would happen with one that wasn't listed.

    Unfortunately, it still wont send any email notifications if a .mp3 or .zip file is uploaded. Since we are a record label, and this is demo submission form, we really need this to be working for those particular files. I also tried uploading a .pdf and didn't receive email notification for that form either. Yet the .mp3, .zip and .pdf all show up in the form builder entries with their associated upload links.

    I checked the wp-includes/functions.php on the wordpress install and the .mp3 .zip and .pdf mime types are all listed in there as they are in the example you linked me to.

    I also tried doing adding an upload to the forms on some of my other websites in order to see if maybe the theme for this particular site was causing the issue, however and they react the same way.

    Hopefully this additional info might help you to pinpoint what may be causing the issue, even if it's on the server side of things. If you can at least help me to figure out where they need to look to solve the issue then that would be awesome :O)

    Sorry to be a bother and thanks again for your time!

  6. Matthew Muro
    Visual Form Builder Pro
    Plugin Author

    Posted 1 year ago #

    Based off what you discovered, it sounds like certain files are getting uploaded just fine and attached in the email like they should be. You might try different chmod settings to see if that helps: 775, 777, 750.

    If your host has mod_security installed, that could be blocking certain files. I'm not too familiar with that module, though, but it's something to look into.

  7. HeavyArtillery
    Member
    Posted 1 year ago #

    Okay, I asked the server if they have module security installed and I'm waiting to hear back on that.

    As for the permissions changes, should I be trying those different chmod settings on the entire wp-content folder and everything inside of it or are there certain folders &/or files I should be targeting? (i.e. the uploads folder and php file or the visual form builder plugin folder and certain files inside etc).

    If possible, I'd rather not change the chmod settings for the entire site for security reasons, especially if 777 ends up being the only one that works for whatever reason.

    Thanks again! I really appreciate your help :)

  8. HeavyArtillery
    Member
    Posted 1 year ago #

    Hey! I just did some more experimenting and figured out that its not the file types that's causing the problem, it's the file SIZE!

    I uploaded 2 different sized jpgs (55KB & 4MB). The email notification arrived for the smaller file but the 4MB one. I then uploaded a 33KB mp3 and the email arrived!

    So I'm guessing there must be a file size limit setting somewhere in wordpress or on the server itself that needs to be changed in order for the larger files to be sent via email from the form uploads on the website.

    Do you know where I should look in order to find the size limit setting and change it? Would it be in the php.ini file?

    (FYI - We receive very large files daily via email so I know its not limited in our actual email account settings.)

    Getting closer.... :O)

  9. HeavyArtillery
    Member
    Posted 1 year ago #

    *Should have read: The email notification arrived for the smaller file but NOT for the 4MB one.

  10. esmi
    Forum Moderator
    Posted 1 year ago #

  11. HeavyArtillery
    Member
    Posted 1 year ago #

    Thanks esmi!

    Before starting this thread I had already raised it from 32 to 64 according to the plugins suggested setting here: http://vfb.matthewmuro.com/faq/recommended-server-settings/

    I'll try raising it to 128...

    Do you know if raising it higher than the recommended amount affects anything adversely?

  12. HeavyArtillery
    Member
    Posted 1 year ago #

    Hey esmi: I increased the memory available to 128 but it didn't solve the problem :o/ (According to the notes in my php file 128M is the max allowance.) Thanks for trying to help tho! Any other ideas?

  13. HeavyArtillery
    Member
    Posted 1 year ago #

    UPDATE: I called the server again, explained that the file size was the issue and asked if they have a file size limit for attachments sent via email from scripts. They said that only limits they impose on php scripts are upload limits. The email attachment file size is not limited by the server and the amount is controlled in the particular email account. They said that if there is a limit being imposed on the attachments that are sent from a particular script, that the variable is written in the plugin script itself.

    I looked at the php scripts for the visual form builder and the only place I could find any sort of attachment limit mentioned was in the email.php file. It looks as tho the limit is set to 25MB which is more than enough. (The biggest file I tried to attached was only 11MB.)

    Here is the code I found in the VFB email.php script:

    // Handle attachments
    if ( $field->field_type == 'file-upload' ) :
    $value = ( isset( $_FILES[ 'vfb-' . $field->field_id ] ) ) ? $_FILES[ 'vfb-' . $field->field_id ] : '';

    if ( $value['size'] > 0 ) :
    // 25MB is the max size allowed
    $size = apply_filters( 'vfb_max_file_size', 25 );
    $max_attach_size = $size * 1048576;

    Is there another place where there might be a limit written into the script that I may have missed?

    And if the VFB script isn't limiting what notification emails are sent based on attachment file size then what do you think could be causing this issue?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic