WordPress.org

Ready to get started?Download WordPress

Forums

Seriously Simple Podcasting
[resolved] notices and warnings (wsod) (7 posts)

  1. Piet
    Member
    Posted 8 months ago #

    Looking for a replacement of the podcasting plugin, I had hoped that this would work. Unfortunately plenty of notices and warnings when debug is set to true:

    Notice: Undefined variable: explicit in /path/public_html/wp-content/plugins/seriously-simple-podcasting/classes/class-seriously-simple-podcasting.php on line 332
    
    Notice: Undefined variable: block in /path/public_html/wp-content/plugins/seriously-simple-podcasting/classes/class-seriously-simple-podcasting.php on line 332
    
    Warning: Cannot modify header information - headers already sent by (output started at /path/public_html/wp-content/plugins/seriously-simple-podcasting/classes/class-seriously-simple-podcasting.php:332) in /path/public_html/wp-admin/post.php on line 222
    
    Warning: Cannot modify header information - headers already sent by (output started at /path/public_html/wp-content/plugins/seriously-simple-podcasting/classes/class-seriously-simple-podcasting.php:332) in /path/public_html/wp-includes/pluggable.php on line 899

    Sorry no time to further investigate this issue, as I said I am looking for a replacement that works out of the box.

    http://wordpress.org/plugins/seriously-simple-podcasting/

  2. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 7 months ago #

    These are minor errors that are only displayed because you have debug mode on. If you switch off debug mode then you will be able to use the plugin with no problems.

    That being said, it is important to sort out even these issues so I will get that sorted in the next release of the plugin.

  3. Piet
    Member
    Posted 7 months ago #

    Hi Thanks for replying. If course I realise that these notices and warnings disappear when I turn debug off. But especially because of the warnings I cannot install the plugin on the site of a client.
    Hope you can find the little bugs.

  4. KeithMon
    Member
    Posted 1 day ago #

    I am experiencing this same issue. It began when WordPress was updated to 3.9.1. I see these errors when I try to edit an existing Podcast post. The changes are saved, though.

    Hugh, do you have any recommendations?

  5. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 20 hours ago #

    If you see these errors please switch debug mode off on your site. You should never run a live site with debug mode on, so this shouldn't have any effect on any live site.

    That being said, I will get this sorted out in a quick patch in the next couple of days.

  6. Piet
    Member
    Posted 20 hours ago #

    With all due respect Hugh, when developing a site I always have debug on and if I install a plugin that gives Notices and Warnings, then I tell the plugin author about that.

    I don't care if these Notices don't show on the live site, because when I deliver a site, there are no Notices, plain and simple.

  7. Hugh Lashbrooke
    Member
    Plugin Author

    Posted 19 hours ago #

    I get you, which is why I will get this sorted out. My point is that I don't see it as a critical fix in the sense that this won't be breaking any live sites. I'll have a patched version out soon.

Reply

You must log in to post.

About this Plugin

About this Topic