WordPress.org

Ready to get started?Download WordPress

Forums

WP Minify
Notice: is_feed was called incorrectly (4 posts)

  1. another-webmaster
    Member
    Posted 1 year ago #

    SCREAM: Error suppression ignored for
    (!) Notice: is_feed was called <strong>incorrectly</strong>. Conditional query tags do not work before the query is run. Before then, they always return false. Please see <a href="http://codex.wordpress.org/Debugging_in_WordPress">Debugging in WordPress</a> for more information. (This message was added in version 3.1.) in \wp-includes\functions.php on line 2959

    This appears as soon debug is activated.
    (Already a known fact for over a year see here. Still no answer/solution)

    Anyone able to help?

    Thanks in advance for effort.

    http://wordpress.org/extend/plugins/wp-minify/

  2. constantin.boiangiu
    Member
    Posted 1 year ago #

    The answer is pretty simple: WPMinify class is started at the bottom of the file and the constructor uses is_feed() query function but at that point the query isn't set yet so is_feed() will always return false even if opened page is actually a feed page.

    One solution would be to start the class on init, by then, global variable $wp_query is set. Didn't fully tested this, might prevent some functionality although I don't see any reason why it should.

    Steps:

    1. edit wp-minify.php, scroll all the way to the bottom of the file.
    2. look for $wp_minify = new WPMinify();
    3. change the line with:

    function wpmin_start(){
    	global $wp_minify;
    	$wp_minify = new WPMinify();
    }
    add_action('init', 'wpmin_start');

    Hope this helps and works without breaking anything. Again, didn't fully tested it, I suggest you do it and make sure everything is OK.

  3. another-webmaster
    Member
    Posted 1 year ago #

    Hi Constantin,

    thanks for responding!, after adding/changing the code with your suggestion the "Scream" is gone but it seems that following code is cause for the notice? (Shown by Debug Bar plugin)

    NOTICE: \wp-content\plugins\wp-minify\wp-minify.php:696 - Undefined variable: src_match

    The Notice appears as soon one/several .css files where add into the box below:
    External CSS files to include into minify. (Only useful if "Minification on external files" is unchecked

    Maybe this information helps a little more to find a workaround.

    Thanks in advance for effort.

    ps, the notice as mentioned (line 696)also appears after putting wp-minify.php back in original state.

  4. constantin.boiangiu
    Member
    Posted 1 year ago #

    I think, not sure though, that instead of $src_match on line 696 should be $href_match meaning that instead of this:

    696. if (strlen($include_pat) > 0 && strpos($src_match[1], $include_pat) !== false) {

    should be this:

    696. if (strlen($include_pat) > 0 && strpos($href_match[1], $include_pat) !== false) {

    Not 100% sure though, there's a lot of code in there and I really don't have the time to check all of it to understand its logic. I ended here yesterday only because a user of my plugin had some trouble while using wp-minify, not sure why yet but still investigating.

    I strongly suggest you contact the author, maybe make a donation (plugin development can take an incredible amount of time), I'm sure he would be of much more help than I am.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic