WordPress.org

Ready to get started?Download WordPress

Forums

  1. pyostriy
    Member
    Posted 1 year ago #

    I've just installed your plugin, got registered as needed but there's no signs if this plugin on my site.
    I just want to use social comments on posts. Could you please look at it and help me solve this issue?
    My site: wwww.dknews.kz

    http://wordpress.org/extend/plugins/loginradius-for-wordpress/

  2. pyostriy
    Member
    Posted 1 year ago #

    Your API connection setting not working. try to change setting from module option or check your php.ini setting for (cURL support = enabled OR allow_url_fopen = On)

    That's written below the post.

  3. loginradius
    Member
    Plugin Author

    Posted 1 year ago #

    Hi pyostriy, It seems like the issue is with cURL setting on your website.

    Please enable “curl” in your website “php.ini” settings or alternatively you can use “fsockopen” as API connection method in Social Login Plugin settings.
    To use “fsockopen” follow the below mentioned steps:-
    1. Login to your website admin panel.
    2. Navigate to LoginRadius section under Settings tab in the left sidebar.
    3. In Social Login section, choose “Use FSOCKOPEN” in Select API credentials (this will require “allow_url_fopen = On” and “safemode = off” in your php.ini settings)
    4. Save changes.

    Let us know if you are still having any issues.

    Thanks,
    LoginRadius Team

  4. pyostriy
    Member
    Posted 1 year ago #

    Hi there!
    Still failed to set the plugin. I enabled FSOCKOPEN, but now it tells:

    Warning: file_get_contents(https://hub.loginradius.com/getappinfo/895cb998-2a64-49af-a0cb-6a6346760f14/07db6b47-207e-46a6-830b-67f4bdd4c261) [function.file-get-contents]: failed to open stream: Connection refused in /home/dknewsk/public_html/wp-content/plugins/loginradius-for-wordpress/LoginRadiusSDK.php on line 75

    Your API connection setting not working. try to change setting from module option or check your php.ini setting for (cURL support = enabled OR allow_url_fopen = On)

  5. loginradius
    Member
    Plugin Author

    Posted 1 year ago #

    Hi - It seems that FSOCKOPEN is not enabled on your website or it may be blocking due to the firewall.

    Please follow the steps below to check if FSOCKOPEN is enabled on your web hosting -
    1. Open "phpinfotest.php" file located in the root directory of your wordpress installation.
    2. Place "phpinfo();" after "*/" at the top.
    3. Save the file. (replace existing file, if needed.)
    4. Open your website with phpinfotest.php path.
    5. Search "allow_url_fopen". If its value is "on" then its enabled. (It should be enabled for FSOCKOPEN to work)
    6. Search "safe_mode". It's value should be "off" for FSOCKOPEN to work.
    7. After checking above parameters, you can delete phpinfotest.php file.

    If "allow_url_fopen" = "on" and "safe_mode" = "off" and still "warning" appears, then please check if any firewall is enabled (you may need to contact your hosting provider) which is blocking communication from LoginRadius API.

    Please let us know if you need further assistance with this issue.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.