WordPress.org

Ready to get started?Download WordPress

Forums

Page Security by Contexture
"Nothing Found" For SOME users (2 posts)

  1. JMay-Chang
    Member
    Posted 1 year ago #

    The blog home page is set to be viewable by "registers users." Some posts are only for students in Group1 while other posts are viewable only for for students in Group1 - All students are designated at "Contributors."

    Some users in both groups see the pages they are supposed to see while some others, even though they are configured the same ways, only get the following error message:

    "Nothing Found
    SORRY, WHAT YOU ARE LOOKING FOR ISN'T HERE."

    If I make the user with the issue an EDITOR they can see the pages fine but then they also see pages they should not and have too many admin permissions.

    This plugin worked just fine before when I used ver 1.5.7. but I have had issues with it since the upgrade of WP to 3.4.2 and the plugin at 1.5.8. This is really impacting our classes negatively because not only can I not fix the existing users, all new users have the same problem.

    Thanks!

    http://wordpress.org/extend/plugins/contexture-page-security/

  2. Matt van Andel
    Member
    Plugin Author

    Posted 1 year ago #

    Hi JMay-Chang,

    This is a known limitation currently, and here's what you can do about it...

    The cause:
    This happens when ALL the posts for a given archive page are protected. Page Security works by literally removing stuff from the dataset after it's fetched from the database, but before WordPress can use it (so it's pretty darn secure).

    BUT... when ALL the posts for a given dataset are removed like this, WordPress thinks the dataset is empty, and throws up the "Nothing found" screen... which also has the unfortunate side-effect of hiding the pagination controls (which would let you go to another page containing additional posts). Fortunately, there is an easy work-around...

    Workarounds:
    There are two ways to work around the limitation until I can get it fixed...

    1. Increase the number of posts per page (recommended)The easiest fix is to increase the number of posts that WordPress fetches per page. You can do this by logging into your admin and going to Settings > Reading and increasing (or doubling) the number next to Blog pages show at most
    2. Ensure that you pepper unprotected pages into the mixThis is an annoying workaround, but it will work. If you have a lot of consecutive protected blog posts, you just need to ensure that you have a few unprotected ones mixed in. If you're 'Blog pages show at most' limit is 20 (see above), then make sure you include 1 unprotected post after every 10-15 protected posts. This will ensure that WordPress always has something to display.

    The next version of Page Security fixes this bug, but my work schedule is so full that won't be able to finish it up until February at least.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic