WordPress.org

Ready to get started?Download WordPress

Forums

Responsive Video Embeds
Not working with YouTube (4 posts)

  1. helloluxx
    Member
    Posted 7 months ago #

    I've updated to 1.2.2 and the plugin is working correctly with Vimeo but I cannot get the correct result with YouTube.

    Here you can see a YouTube not working

    http://www.helloluxx.com/product/super-source-falloff-cinema-4d/

    Here's a Vimeo working

    http://www.helloluxx.com/product/x-particles-for-cinema4d/

    Thanks for any advice on how to resolve this much appreciated.

    Cheers
    Tim

    http://wordpress.org/plugins/responsive-video-embeds/

  2. Kevin Leary
    Member
    Plugin Author

    Posted 7 months ago #

    Are you sure you're using this specific plugin and that it's activated? The source code of your theme looks otherwise. This plugin will wrap embeds with:

    <div class="rve" data-content-width="640">...</div>

    And will also load external JavaScript (/wp-content/plugins/responsive-video-embeds/js/rve.min.js, which I don't see in your site.

  3. helloluxx
    Member
    Posted 7 months ago #

    Hey Kevin

    Thanks for the speedy reply. I'm definitely using this plugin and it is activated. I just updated to 1.2.3 and problem still exists.

    I see what you're saying about the code using a different class.

    Although the YouTube embed is like this…

    <span class='embed-youtube' style='text-align:center; display: block;'><iframe class='youtube-player' type='text/html' width='912' height='543' src='http://www.youtube.com/embed/u0K-efbwB3w?version=3&rel=1&fs=1&showsearch=0&showinfo=1&iv_load_policy=1&wmode=transparent' frameborder='0'></iframe></span>

    Vimeo is like this…

    <div class="rve" data-content-width="912"><iframe src="//player.vimeo.com/video/78819312" width="912" height="513" frameborder="0" title="X-PARTICLES 2.5 EMITTER" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe></div>

    Which appears correct. Any idea what might be causing the difference with YouTube?

    I'll try disabling all other plugins and see if it is a conflict.

    Thanks again for your help.
    Tim

  4. helloluxx
    Member
    Posted 7 months ago #

    I disabled all plugins except jigoshop which is the store the page is based on. The problem still occurs.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.