WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Activity Plus
[resolved] not working with large image size (11 posts)

  1. viessenetwork
    Member
    Posted 1 year ago #

    I have a problem.
    I can't post activity with file too large.
    If I try with little size image it will works.
    If I try with a large image (example JPG 2,4 MB - 3872 × 2592 px), the preview works fine and there is no error where confim the post, but the post not show in the list of activities.
    Why??
    With debug I found that the problem maybe is in the function "move_images" in file "class_bpfb_binder.php".
    Infact the script work fine until the

    row image_resize($new_img, $thumb_w, $thumb_h, false, 'bpfbt');

    after this row, the script don't go....

    someone can help me??

    thank you.

    http://wordpress.org/extend/plugins/buddypress-activity-plus/

  2. viessenetwork
    Member
    Posted 1 year ago #

    the problem is the function image_resize().
    it doesn't work with large size images.

  3. viessenetwork
    Member
    Posted 1 year ago #

    anyone can help me??

    I don't understand why the script work with small picture, and don't work with large image.
    I didn't found any difference in the source code.

  4. ellbristow
    WPMU DEV Support Staff
    Posted 1 year ago #

    Hi @viessenetwork,

    Thanks for bringing this to our attention. I have alerted the devs to this as I suspect it will continue to be an issue.

    Some research has shown that image_resize was deprecated in WordPress 3.5.0 in favour of WP_Image_Editor. The deprecated function still exits, so I'm not sure why it wouldn't work, but the new method may provide a fix for this error relating to large images.

    We'll try and keep you posted on this.

  5. viessenetwork
    Member
    Posted 1 year ago #

    thank you!

  6. Hello there @viessenetwork,
    This could be a memory issue... Have you tried increasing your PHP memory limits?

    Please advise,
    Ari.

  7. viessenetwork
    Member
    Posted 1 year ago #

    Hi Aristath,

    the "memory_limit" is actually "64M".
    Maybe could be a time limit issue?
    Actually "max_input_time" is "60".

    Thank you.

  8. viessenetwork
    Member
    Posted 1 year ago #

    I tried to extend the max_input_time to 240 but the problem still exists.

  9. I tried to extend the max_input_time to 240 but the problem still exists.

    Did you try it from your php.ini file?
    If so, could you please try it from WordPress's wp-config.php file?
    Instructions are here: http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    I hope that helps!

    Cheers,
    Ari.

  10. viessenetwork
    Member
    Posted 1 year ago #

    I have extended the "memory_limit" to "128M" from php.ini and the problem is resolved!

  11. I have extended the "memory_limit" to "128M" from php.ini and the problem is resolved!

    I'm glad you finally managed to resolve this!

    Take care,
    Ari.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic