WordPress.org

Ready to get started?Download WordPress

Forums

BuddyPress Registration Options
[resolved] Not working with BP installed on site other than root (13 posts)

  1. Jay Collier
    Member
    Posted 1 year ago #

    Not working with BP installed on site other than root. No settings panel appears.

    http://wordpress.org/extend/plugins/bp-registration-options/

  2. Michael Beckwith
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Jay,

    I'll reply here for the actual troubleshooting and possible hotfix for you.

    could I get your WordPress version, BuddyPress version, and the folder structure that you have on your server relative to the root public_html/www folder? This will help me set up a similar environment and troubleshoot better.

  3. Jay Collier
    Member
    Posted 1 year ago #

    Sure!

    WordPress: 3.5.1 - In /public_html/ at the root. Multisite set up with subdomains.
    Buddypress: 1.7.2 - BuddyPress is installed on site ID 3.
    BP Registration Options: 4.0.1

    In what menu hierarchy/URL structure should I see the BPRO settings screen?

    Thanks!

  4. Michael Beckwith
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry for the long delay, Jay. I just wanted to see if you ever found a resolution to this, or if I should still investigate?

  5. Frank Warwick
    Member
    Posted 1 year ago #

    Hi Michael
    I am having a similar issue for multisite Buddypress where I do not have permission to moderate users from any site except the root install.

    I would like to use this for my clients who use Buddypress in a SaaS environment, ie a multisite buddypress install where the client user does not have acces to super admin but only admin for their site.

  6. Frank Warwick could you please start your own topic?

    http://wordpress.org/support/plugin/bp-registration-options#postform

    This one is not the same as yours and unless you're contributing to Jay's problem (you're not) you'll be better off starting your own topic.

  7. Frank Warwick
    Member
    Posted 1 year ago #

    Hi Jan,
    I have started another topic but it is essentially about the same issue but phrased a different way. "Not working with BP installed on site other than root"

    The issue that is posted here is about not being able to administer from a 'none root admin role', which is what I have also outlined, and although I am not contributing to a solution I have the same issue and one that has a wider scope or reference.

    the solution for both is the same, the ability to allow local admin (not only super admin) the rights to approve or reject users.

  8. the solution for both is the same, the ability to allow local admin (not only super admin) the rights to approve or reject users.

    You have a solution for the original poster's problem? Great! Can you post it for Jay on this topic? I'm sure your contributing to his problem will be appreciated.

    If you don't have a solution for Jay then could you please keep to your topic until you do? You're not on Jay's server and have a different setup. Despite similarities your problem may not be the same and that's why I'm encouraging you to keep your problem separate.

    It really remains the best way to get the support that your problem deserves and avoids being rude to the original poster.

  9. Jay Collier
    Member
    Posted 1 year ago #

    I'll be interested in your other thread, when you post it, Frank. Then, even when mine is resolved and closed, I can still follow yours.

  10. Jay Collier
    Member
    Posted 1 year ago #

    Besides, I'm leaving this open until I can test in our new server environment next week.

  11. Frank Warwick
    Member
    Posted 1 year ago #

    Hi Jay, if they do a fix it should work for both of us as your issue is about a BP site that is not the root site (id1) but is ID3 therefore you can only approve or reject as super admin and not admin.

    I am not sure of the complexity involved to allow approval by admins of sub sites but as this is a great plugin I would hope that it is not too complex and the one fix should help us and others.

  12. Michael Beckwith
    Member
    Plugin Author

    Posted 1 year ago #

    Jan, I have this from here, but it may be a couple hours before I can properly post some responses.

  13. Michael Beckwith
    Member
    Plugin Author

    Posted 1 year ago #

    Jay, after reading through Frank's topics, I have a better grasp of what both of you are going through, and will be making it a focus for 4.2 which I hope to have done within the next month or so. However, I can't make that a guarantee.

    If you come up with a solution of some sort, feel free to let me know how and share the code you used, it very well could make it in if it works well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.