WordPress.org

Ready to get started?Download WordPress

Forums

All In One Schema.org Rich Snippets
[resolved] Not working togheter with RDFa Breadcrumb (5 posts)

  1. Stufo76
    Member
    Posted 1 year ago #

    Hello,

    I've installed All In One Schema.org Rich Snippets v.1.0.1, and all is working fine.

    When I update to v.1.0.2, it break my site.

    I read logs, and I found an incompatibility with RDFa Breadcrumb.

    Below error log:

    Fatal error: Cannot redeclare rdfa_admin_styles() (previously declared in /wp-content/plugins/rdfa-breadcrumb/rdfa-breadcrumbs.php:370) in /wp-content/plugins/all-in-one-schemaorg-rich-snippets/rdfa-breadcrumbs.php on line 338

    Seems to be a redeclaration of function "rdfa_admin_styles()", already declared in RDFa Breadcrumb plugin, that cause a fatal error.

    Can you check it?

    Thank you very much!

    http://wordpress.org/extend/plugins/all-in-one-schemaorg-rich-snippets/

  2. Sujay
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Stufo76,

    Thanks you for reporting your issue with detailed explanation. Really appreciate it. We have updated the plugin with these fixes. Let me know if it still doesn't work.

    Regards,
    Sujay

  3. Stufo76
    Member
    Posted 1 year ago #

    Hi Sujay,

    happy to be useful ;-)

    Now it works, but there is two another issue:

    1) dashboard -> add new plugin -> search for something -> search result are a little strange: rating stars are all blank. If i disable All In One Schema.org Rich Snippets, all works fine

    2) when I try to remove some deactivated plugin, a strange message appear: "Are you sure you want to do this?" and I cannot delete it. It happens with all plugins I randomly tried, not a specific one.

    For both errors there is nothing in my error log.

    Second issue sound like this: http://wordpress.stackexchange.com/questions/60957/what-causes-the-are-you-sure-you-want-to-do-this-error-with-plugins

    I tried to apply patch described here, but isn't working.

    I manually remove All In One Schema.org Rich Snippets and all working normally.

    As I wrote, there is nothing in error log, nor a warning or info... nothing. So, this time I cannot help you...

  4. Sujay
    Member
    Plugin Author

    Posted 1 year ago #

    Stufo76,

    Let us look into it and release an update quickly. Stay tuned..

  5. Sujay
    Member
    Plugin Author

    Posted 1 year ago #

    Stufo76,

    You might have noticed already - we have released an update with your reported bug fixes.

    Thanks,
    Sujay

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic