WordPress.org

Ready to get started?Download WordPress

Forums

Testimonials by Aihrus
[resolved] Not working on 3.5.1 (32 posts)

  1. SEjack
    Member
    Posted 1 year ago #

    As soon as I activate, I get white screen.

    http://wordpress.org/extend/plugins/testimonials-widget/

  2. theVR
    Member
    Posted 1 year ago #

    I am having same white screen issue. Just purchased premium version - free version seems to work correctly.

  3. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Please make sure that free, 2.12.0 and premium, 1.12.0 versions are latest.

  4. theVR
    Member
    Posted 1 year ago #

    Noticed an update on the free version, ran that and the premium installed flawlessly. Thanks for the quick reply!

  5. JohnCleary
    Member
    Posted 1 year ago #

    I just added the plugin (2.12.0) to three separate sites and it 'crashed' every one. Here's the error message that I got:

    Fatal error: Allowed memory size of 103809024 bytes exhausted (tried to allocate 261900 bytes) in /nfs/c07/h04/mnt/110668/domains/<mydomain>/html/wp-content/plugins/testimonials-widget/lib/class-settings-testimonials-widget.php on line 491

  6. JohnCleary
    Member
    Posted 1 year ago #

    I should add that I tried the install shortly before I found this page. I deleted the plugin's directory via FTP and tried to reinstall which created the above error. My website is now down and I'm getting this error:

    Fatal error: Allowed memory size of 103809024 bytes exhausted (tried to allocate 261900 bytes) in /nfs/c07/h04/mnt/110668/domains/<mydomain>/html/wp-includes/l10n.php on line 68

    I can't work out how to restore my site without reinstating a backup...Any help would be appreciated.

  7. SEjack
    Member
    Posted 1 year ago #

    @JohnCleary via FTP, go to wp-content/plugins and find the testimonials-widget folder. Rename the folder to ".testimonials-widget". This will disable the plugin and let you regain control of your site

  8. JohnCleary
    Member
    Posted 1 year ago #

    Line 68 of l10n.php is : $translations = get_translations_for_domain( $domain );

  9. JohnCleary
    Member
    Posted 1 year ago #

    @SEjack Thanks for your input, at the time of writing that folder didn't seem to exist, however on restarting the FTP program it appears that it was a cacheing issue...website is back up now. Phew!

    Would love to be able to use this plugin though...it looks great!

  10. SEjack
    Member
    Posted 1 year ago #

    @JohnCleary FTP, at least on Filezilla which is the only FTP client I ever use, displays the contents of a folder the same as when that folder was first opened during that session. You have to right-click refresh if you to view any changes to the contents of that folder.

  11. JohnCleary
    Member
    Posted 1 year ago #

    @SEJack...Aha! Then that was my error....thanks for the info.

  12. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    From premium FAQ.

    21. How do you update Testimonials Widget Premium?

    You can update Testimonials Widget Premium via WP Admin > Dashboard > Updates, click Check Again, and then select and make updates.

  13. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Who is still having and what troubles?

  14. JohnCleary
    Member
    Posted 1 year ago #

    @Michael Cannon I tried to install the free version less than 3 hours ago to check the plugin out and I had the issues I described above. Happy to help with supplying whatever other info you might need to debug. Am using the latest version of WordPress.

  15. SEjack
    Member
    Posted 1 year ago #

    @Michael Cannon I tried the free version 2.12 and I got a 404 page as soon as I activated it. I tried deactivating all other plugins first, and it still exhibits the same behavior.

  16. simple1
    Member
    Posted 1 year ago #

    I also got a 404 error when I activated the free version.

  17. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    @JohnCleary, can you increase your PHP memory limit by updating memory_limit=128M in php.ini?

    @SEjack and @simple1, see https://aihrus.zendesk.com/entries/23679301-My-testimonial-URL-says-Page-not-found-or-404.

  18. JohnCleary
    Member
    Posted 1 year ago #

    @Michael Cannon Thank you, I will try this...although I'm surprised that this sort of configuration would be necessary on three separate WP blogs, 2 hosted with a major hosting company and one of those being a virtually clean install!?

  19. JohnCleary
    Member
    Posted 1 year ago #

    I created a php.ini file and put this in it:

    memory=128MB
    upload_max_filesize=128M;
    post_max_size=128M;

    I put that ini file in the root of my installation AND the wp-admin, but still had the same error.

  20. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Where can I see the error?

    Is it possible to email me an admin login http://aihr.us/contact-aihrus/?

  21. simple1
    Member
    Posted 1 year ago #

    Michael,

    I sent you admin login info.

  22. simple1
    Member
    Posted 1 year ago #

    I just tried installing the plugin on a site hosted by a different hosting service. When I activated it I got a blank page, no headers.

  23. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    You've got URL setting issues

    http://www.thisisrusa.com/wp/wp-admin/plugins.php
    http://thisisrusa.com/wp/wp-admin/options-general.php

    You need to get your website URLs in the later URL consistent. You can also add the following to the top of your wp-config.php file of your WordPress installation. This'll override the database settings so that you can move forward.

    define( 'WP_HOME', 'http://www.thisisrusa.com/wp' );
    define( 'WP_SITEURL', 'http://www.thisisrusa.com/wp' );
  24. simple1
    Member
    Posted 1 year ago #

    The URL setting is consistent until I activate the plugin, then the www is omitted.

    http://thisisrusa.com/wp/wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s=

    I tried your suggestion of adding the snippet to the wp-config.php but I get the same result.

  25. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry, deactivate and uninstall the plugin. I've got the memory leak fixed. 2.12.1 will be coming out shortly and I've added a new test to try and prevent similar issues.

  26. simple1
    Member
    Posted 1 year ago #

    I can activate the plugin now. Thanks for fixing, Michael!

  27. Michael Cannon
    Member
    Plugin Author

    Posted 1 year ago #

    Excellent news!

    Do let me know of any other issues via a new forum entry.

  28. JohnCleary
    Member
    Posted 1 year ago #

    @Michael Cannon all working for me too and I've purchased the premium version too. I've been trying to find instructions/documentation on how to set it up. Where's the best place to find that info?

  29. ccolotti
    Member
    Posted 1 year ago #

    It's working for me as well and so far I love this. I am considering getting premium JUST to support the author. Not sure I need the features.

    http://www.v-fit.us/about-us/customer-testimonials/

    I am curious how many entries kick the pages in with the list short code. I could probably use the "read more" option of the premium if nothing else :)

    PS - I also have this installed on a Multi-site but only activated in one of the 5 and it's working fine.

  30. livninctry
    Member
    Posted 1 year ago #

    I just tried to activate this plugin and this was the error msg.:

    The plugin does not have a valid header.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic