WordPress.org

Ready to get started?Download WordPress

Forums

Slickr Flickr
[resolved] Not working in Internet Explorer (6 posts)

  1. atiquetedevelopers
    Member
    Posted 1 year ago #

    I updated SlickrFlickr (1.43) and in IE9 is not working when I click in a picture, error says: "jQuery not defined" in the first line:

    <script type="text/javascript">
    jQuery.noConflict(); jQuery(document).ready(function() {
    slickr_flickr_start();
    });
    </script>

    Any ideas? (not use IE, yeah; but I have a basic users in my WP)

    Thanks!

    http://wordpress.org/extend/plugins/slickr-flickr/

  2. Russell Jamieson
    Member
    Plugin Author

    Posted 1 year ago #

    jQuery should be loaded whatever browser is being used - what is the URL of your site?

  3. atiquetedevelopers
    Member
    Posted 1 year ago #

    Jquery is loaded and working :-(

    You can see it here: http://www.empachate.com/kaisen-sushi-bar/

    Thanks Russell!

  4. Russell Jamieson
    Member
    Plugin Author

    Posted 1 year ago #

    I can see that both thickbox and fancybox lightboxes are being loaded and that both scripts are being minified by the bwp-minify plugin.

    The issue could either by the minification or the two lightboxes.

    Firstly trying going into Slickr Flickr Admin Advanced Settings and check "Load scripts in Footer" and see if that helps

    Next try the Slickr Flickr Admin LightBox settings and change the preferred lighbox option from ThickBox to FancyBox.

    If that fails then try disabling minification just temporarily to see if that makes a difference.

  5. atiquetedevelopers
    Member
    Posted 1 year ago #

    I follow all your steps and I disable minification and it doesn't work either... :-(

    The error:
    SCRIPT438: Object doesn't support property or method 'removeExpression'

    I found this topic: http://stackoverflow.com/questions/12046242/simple-modal-jquery-1-8-0-and-ie9

    And if I change my version of jquery to 1.7.2 it works!

    So... That's it! Thanks for your help (and for the plugin!)!

  6. Russell Jamieson
    Member
    Plugin Author

    Posted 1 year ago #

    Nicely diagnosed!

    jQuery version mismatch is always a potential issue. I should have mentioned it.

    Cheers

    Russell

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.