WordPress.org

Ready to get started?Download WordPress

Forums

wp-webp Plugin
Not working in IE and Firefox (12 posts)

  1. the-maximum
    Member
    Posted 1 year ago #

    Everytime I'm opening my site in IE, the IE is freezing and then nothing works anymore. But after 2 min it works fine and shows the webp picture. (Tried it on two systems.) And Firefox don't show my picture completly, there's just white space. Have you an idea, what's the problem is?

    http://wordpress.org/extend/plugins/wp-webp/

  2. tuxlog
    Member
    Plugin Author

    Posted 1 year ago #

    Can you give me the settings from wp-webp please.

  3. the-maximum
    Member
    Posted 1 year ago #

    I turned on the option: "WebP immer durch Javascript unterstützen (auch wenn der Browser das WebP Format unterstützt).", 'cause if it's unchecked Chrome crashes.

  4. tuxlog
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    just tried with IE8 and it works without a problem.
    Just to be sure:

    enabled --> WebP immer durch Javascript unterstützen (auch wenn der Browser das WebP Format unterstützt).
    disabled--> WebP Javascript am Ende der Seite ausgeben (Standard ist der Kopbereich)
    disabled--> Verwende die experimentelle Version der libwebp mit Unterstützung des Alphakanals und verlustfreier De-/Enkodierung

    correct?

    Can you give an url to a site where the problem occurs?

  5. the-maximum
    Member
    Posted 1 year ago #

    Yes, you're right!
    And here's my site:
    http://mxum.de/

    Btw. I use IE10 and the newest Firefox. :)

  6. tuxlog
    Member
    Plugin Author

    Posted 1 year ago #

    The results here are:

    chrome Version 26.0.1410.63 - works
    firefox 21 - works
    IE10 - takes about 70 seconds and then shows the big image. The two smaller images are displayed immediately.

    Ok, so I can track down this now.
    It may have be something to do with the src=data:... mechanism in the decoding script. This was limited to 32k in IE8 and with IE9 and IE10 this changed in IE.

    What strikes is that the images are not clickable in IE but in the other browsers.

    Debugging the javascript in IE shows no errors...
    I will analyze it...this may take a while

  7. tuxlog
    Member
    Plugin Author

    Posted 1 year ago #

    Okay one more try

    If you enable --> Verwende die experimentelle Version der libwebp mit Unterstützung des Alphakanals und verlustfreier De-/Enkodierung

    Is it faster then? It changed here from 70 seconds to 7 seconds.

  8. the-maximum
    Member
    Posted 1 year ago #

    I think you can german, ok:

    Also wenn ich lipwebp anschalte, lädt die Seite im IE10 zwar aber es zeigt keine Bilder an, genau so in Firefox. In Chrome zeigt es die Bilder dann überdimensional groß an (Beispiel: http://mxum.de/?page_id=19).

    PS: Das Kopfbild oben und das "M"-Logo, fallen aus der Wertung da dies png/jpg Bilder sind.

  9. esmi
    Forum Moderator
    Posted 1 year ago #

    These are English language forums, so please use English. Alternatively, use a WP support forum in your language.

  10. the-maximum
    Member
    Posted 1 year ago #

    i'm sorry... :)

  11. tuxlog
    Member
    Plugin Author

    Posted 1 year ago #

    Well, seems I cant get the problem rebuild with IE8. But I have no OS where I can install IE10. :-(

    So, no solution for the moment. But will keep an eye on it.

  12. tuxlog
    Member
    Plugin Author

    Posted 1 year ago #

    Just uploaded v0.6 which supports explicit width and height attribute in experimental mode. please try it with experimental mode on and use width and height attribute in the img tag.

    Works here. :-)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.