WordPress.org

Ready to get started?Download WordPress

Forums

wp-Monalisa
[resolved] Not working in BuddyPress (20 posts)

  1. SciFiKriss
    Member
    Posted 3 months ago #

    Hi guys

    Just installed in and put a different icon pack in and everything on the backside is ok. They appear on the activity page but when you click on them it inserts an html code and then nothing when you post?

    It is showing up the 'normal' icons but not the ones with :***:

    You con log in onto my site with a social log in.

    Thanks in advance

    Kriss :)

    https://wordpress.org/plugins/wp-monalisa/

  2. SciFiKriss
    Member
    Posted 3 months ago #

    You know it might help if I put the link to the website on it wouldn't it? doh! sorry!

    http://www.krissharmsworth.com

    Kriss :)

  3. tuxlog
    Member
    Plugin Author

    Posted 2 months ago #

    Can you give me the versions of WP, wp-monalisa and buddypress you use please.

  4. SciFiKriss
    Member
    Posted 2 months ago #

    WordPress 3.9
    Buddypress 2.0
    wp-monalisa 3.2

    I have switched it off at the moment not to confuse the guys.

    Kriss :)

  5. tuxlog
    Member
    Plugin Author

    Posted 2 months ago #

    Seems to work here.
    Did you enter the correct Icon Directory?
    Must be something relative to the WordPress directory like wp-content/plugins/wp-monalisa/mysupersmilies
    Are the icons readable? You can test this by entering the URL for asmiley direct into your browser.

  6. SciFiKriss
    Member
    Posted 2 months ago #

    I put my own emoticons on....

    I will switch them back on for you and you can see what happens... :D

    Kriss :)

  7. SciFiKriss
    Member
    Posted 2 months ago #

    Ok all switched back on... the emoticons with :) :( are working but the ones with :**: just don't seem to work at all....

    Kriss :)

  8. tuxlog
    Member
    Plugin Author

    Posted 2 months ago #

    Hi Kriss,

    must be something which handles the :**: smilies beside wp-monalisa.
    Did you disable the WordPress default smilies? (Options->Write)
    I cant reproduce the problem in my installations. What other plugins do you use?

  9. SciFiKriss
    Member
    Posted 2 months ago #

    Yes I have switched it off... the only reason that the :) work is because I type that and not click on the emoticon.

    I have quite a few plugins but none as far as I know use the :**: and no other smilie programs... it is a damn pity because I wanted one that was visible to buddypress... :(

    Kriss :)

  10. tuxlog
    Member
    Plugin Author

    Posted 2 months ago #

    Well Kriss, it really is.

    I can only help you if I can reproduce the problem. I f you like tell me what other plugins you use or give me an admin access to your site.

    By the way, all plugins which uses shortcodes or kind of abbreviations or regular expressions on comments or sth like this can collide with wp-monalisa.

    Would be glad to help.

  11. SciFiKriss
    Member
    Posted 2 months ago #

    You can log in with anything you like.... once you have done that I can then make you an admin :D

    You can then play with it as much as you like.... :D

    Kriss :)

  12. tuxlog
    Member
    Plugin Author

    Posted 2 months ago #

    ok, did it. Now waiting to become an admin. ;-)

  13. tuxlog
    Member
    Plugin Author

    Posted 2 months ago #

    Anyway, I just tested :cry: :ninja: :clown: all worked.

    What smilies aren't displayed?

  14. tuxlog
    Member
    Plugin Author

    Posted 2 months ago #

    You have to deactivate: "Replace emoticons with html-images" than it works.

  15. tuxlog
    Member
    Plugin Author

    Posted 2 months ago #

    After deactivating I tested all smilies seems to work now.
    Please delete my account when you can confirm it.

    Thanks.

  16. SciFiKriss
    Member
    Posted 2 months ago #

    I tried that as well and didn't work for me... :( I so hate it when this happens... feel like such an idiot now!

    But at least it is working now... :D :D :D

    Thank you!

    Kriss :)

  17. SciFiKriss
    Member
    Posted 2 months ago #

    Yep all working will now delete you if you are happy it is working ok?

    Kriss :)

  18. SciFiKriss
    Member
    Posted 2 months ago #

    Hang on! the heart one is not working.... can't we use numbers in the name of the emoticon?

    Kriss :)

  19. tuxlog
    Member
    Plugin Author

    Posted 2 months ago #

    Yes, this is a caveeat of wp-monalisa. Currently it can not handle smilies beginning with a <, because it recognizes html tags from a starting <.
    Btw, thats the same as with WordPress standard smilies.
    Why not using :heart: until wp-monalisa learns to handle this too.

  20. SciFiKriss
    Member
    Posted 2 months ago #

    Oh right! yeah that makes sense... doh!

    Ok I will change it...

    Thanks once again for all your help.

    I will now delete your id as well.

    Kriss :)

Reply

You must log in to post.

About this Plugin

About this Topic

Tags