WordPress.org

Ready to get started?Download WordPress

Forums

Q2W3 Fixed Widget (Sticky Widget)
[resolved] Not working, hopefully an easy fix! (54 posts)

  1. danmaj1990
    Member
    Posted 1 year ago #

    Hi,

    using this widget on another site and works perfectly, but not this one: http://www.r-cvblog.co.uk

    Can you help me out? I'm a php amateur so don't get too technical haha.

    Thanks in advance!

    http://wordpress.org/extend/plugins/q2w3-fixed-widget/

  2. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    Hello!

    Your problem: widgets have no id attributes.

    To fix this you have to find register_sidebar function (look in functions.php) and change before_widget parameter.
    It looks like:

    register_sidebar( array(
    	...
            'before_widget' => '<li class="widget widget-sidebar">',
    	...
    ) );

    Edited version:

    register_sidebar( array(
            ...
    	'before_widget' => '<li id="%1$s" class="widget widget-sidebar">',
    	...
    ) );
  3. danmaj1990
    Member
    Posted 1 year ago #

    Works now, thanks mate!

  4. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    I see, good job!

    One advise. It's better to fix the last widget, not the first.

    You may add a second ads widget, place it at the last position and then fix it.

  5. thanhtuanbk
    Member
    Posted 1 year ago #

    I see one problems on my site. URL http://hoclame.com/bo-anh-nguoi-dep-bikini-lam-mat-mua-he/ . Please can you help me?

  6. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    thanhtuanbk!

    Look at style.css line 284:

    #sidebar .widget {
    margin-bottom: 20px;
    height: 100%;
    overflow: hidden;
    -moz-border-radius: 5px;
    -webkit-border-radius: 5px;
    }

    You need to remove height: 100%;!!!

  7. thanhtuanbk
    Member
    Posted 1 year ago #

    Thank you very much! Max Bond. It has worked. You are great.

  8. bunda_bogor
    Member
    Posted 1 year ago #

    hi Max Bond,

    Could you help me, the plugin not working on my site sample
    http://bunda.us/category/berita

    i have edit as your solution at above:

    if (function_exists('register_sidebar')) {
    register_sidebar(array(
    'name' => 'Archive Sidebar',
    'id' => 'archive-sidebar',
    'description' => __( 'These widgets appear in the sidebar of all category/archive/tag listing pages (but not review listings)', 'swagger' ),
    'before_widget' => '<div id="%1$s" class="widget-wrapper"><div id="%1$s" class="widget">',
    'after_widget' => '</div></div>',
    'before_title' => '<div class="section-wrapper"><div class="section">',
    'after_title' => '</div></div>'

    but still not fix, could you please help me to solve it,

    very thanks

  9. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    bunda_bogor!
    Which widget do you want to fix?
    I looked at your site source and found only one standard widget - "Most Viewed". How do you insert Google ads?

  10. bunda_bogor
    Member
    Posted 1 year ago #

    the last widget.

    only the banner tutoral jilbab.

    i have check on the widget dashboard fixed widget.

    Thanks

  11. bunda_bogor
    Member
    Posted 1 year ago #

    hi,

    now working but only on most viewed widget, but for banner belowed still not working.

    for banner i use widget text from themes. might be that's the problem,

    my themes widget not support your plugin?

  12. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    my themes widget not support your plugin?

    It looks like so. The "Most viewed" widget uses format specified in reister_sidebar function, but other widgets formatted in different way...

  13. anhtuan020588
    Member
    Posted 1 year ago #

    It's not works on my site. Could you please help me check?

    http://www.export2global.net/tester/03/2013/thuong-thuc-mon-ngon-khi-den-da-nang-phan-1/

    Thanks,
    Tuan.

  14. anhtuan020588
    Member
    Posted 1 year ago #

    Nevermind, i should to add id="%1$s" to before_widget in function.php

    Now everything okay :) awesome plugin Max.

  15. nikhilnaik
    Member
    Posted 1 year ago #

    I added id="%1$s"to 'before_widget', still it is not working. Can you help me out?

    My blog is : http://www.bloggercent.com

    My settings are:
    Margin Top: 10px
    Margin Bottom: 0px
    Refresh interval: 1500ms
    Screen Max Width: 0px

    Use jQuery(window).load() hook: unticked

  16. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    nikhilnaik!

    You have jQuery loaded two times!
    You should remove jQuery 1.6.2 (line 5):
    <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.6.2/jquery.min.js"></script>

  17. nikhilnaik
    Member
    Posted 1 year ago #

    Hello Max,

    Could you help in getting that code removed? I am not sure where is that being loaded from. I checked all the theme files. I would like only the jquery which is on the (line 1) to be loaded.

  18. nikhilnaik
    Member
    Posted 1 year ago #

    Fixed it. Working! Thanks.

  19. nikhilnaik
    Member
    Posted 1 year ago #

    One question, the popular post is working fine but the social sharing widget is not moving. Could you help regarding this?

  20. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    One question, the popular post is working fine but the social sharing widget is not moving.

    If you look at the source code of this widget, you'll see it has different format then other widgets. I don't know why...

  21. nikhilnaik
    Member
    Posted 1 year ago #

    Okay, this was not the part of the theme but an additional plugin. I will look into it. Thanks.

  22. nikhilnaik
    Member
    Posted 1 year ago #

    Hello Max,

    For the social sharing widget, I entered the widget ID into the "Custom HTML IDs" section of the plugin. It worked, but the widgets are overlapping. What should be done?

  23. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    Hello nikhilnaik!

    I entered the widget ID into the "Custom HTML IDs" section of the plugin. It worked, but the widgets are overlapping. What should be done?

    The custom id is not working properly because plugin thinks that social widget is located in a different sidebar (entered id is not found in registered widget ids).

    This social widget is incompatible with my plugin because it is overriding default widget layout specified in register_sidebar function!

    The only way to get it working is to modify widget code.

  24. aniahopcroft
    Member
    Posted 1 year ago #

    Hello, I wonder if you could help.
    I have installed a fixed sidebar widget to my site and it does not seem to work:( site address: http://www.beyondpoland-events.com
    Thank you with advance.
    Ania

  25. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    aniahopcroft!

    Your theme uses jQuery 1.6.4, but the minimum required version is 1.7

    Use WordPress default jQuery 1.8.3

  26. aniahopcroft
    Member
    Posted 1 year ago #

    Thanks Max.
    I have now upgraded to word press 3.5.2 (the latest version i believe) which indicates that jQuery has been updated to the latest version too. Still not working though:(
    Where can I check which version of jQuery it is using now? could anything else be a problem?
    thanks, Ania.

  27. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    aniahopcroft,
    you are still on jQuery 1.6.4.

    Your theme overrides default settings - that's why update didn't help.

    Check, may be your theme has an option to disable jQuery supplied with theme?

  28. calebvmd@gmail.com
    Member
    Posted 1 year ago #

    Hi there,

    I too am having trouble getting it to work. Can you help? http://www.vmdtechnology.com

    CSF

  29. Max Bond
    Member
    Plugin Author

    Posted 1 year ago #

    calebvmd@gmail.com!
    Your widgets don't have unique IDs.
    Read my first comment in this thread - that is what you should do!

  30. calebvmd@gmail.com
    Member
    Posted 1 year ago #

    Thanks Max-

    Before I go mucking around in functions.php can you clarify...

    1. There are 3 places where functions.php contains the register_sidebar. One of the 3 has an id assigned (uses the number 2 between symbols). Which am I switching and can I use the exact code above for both?

    2. I am working with a child version of the theme. I created a blank functions.php. Can you tell me the exact code to type into my blank functions.php?

    Thanks so much for the support,
    CSF

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic