WordPress.org

Ready to get started?Download WordPress

Forums

Nav Menu Roles
[resolved] Not working for logged in users (5 posts)

  1. pwizard
    Member
    Posted 6 months ago #

    Using s2member and assigning roles

    subcriber, level1 - level 5

    It was working perfectly for a while. I had one menu item (and it's sub items) show for s2member level 1 or higher.

    I went back and changed it to show for logged in users. (the menu item and the child items).

    However, it is still showing for level1 or higher. In other words, a subscriber can't see the menu even though set for all logged in users.

    Any advise would be appreciated.

    http://wordpress.org/plugins/nav-menu-roles/

  2. pwizard
    Member
    Posted 6 months ago #

    Just to add, it works fine for another menu item to the right (with no child items).

  3. pwizard
    Member
    Posted 6 months ago #

    Sorry, ignore this. It was a setting I had in s2member restrictions that was overriding nav menu settings.

  4. helgatheviking
    Member
    Plugin Author

    Posted 6 months ago #

    I can't reproduce this locally. Could you test with a default theme? And try re-saving the menu as well as clearing any caches, browser or plugin-based. If that doesn't do anything, could you send me some temporary admin credits? I can't promise anything, but I will at least look.

  5. helgatheviking
    Member
    Plugin Author

    Posted 6 months ago #

    Well, I'm relieved that there's no work involved for me. ;) Glad you got it sorted.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.