WordPress.org

Ready to get started?Download WordPress

Forums

Google Language Translator
[resolved] Not working after update to version 1.6 (21 posts)

  1. Pixel Light Media
    Member
    Posted 1 year ago #

    The plugin was working fine before updating. Now the shortcode will not work anywhere.

    I have tried deactivating and then activating the plugin, changed and saved settings, nothing seems to work.

    Have not installed or uninstalled any other plugins that where not already installed and running previously and are running only a few plugins at any one time (10 to 12 max)

    Using the Avada Theme

    Effected site: Niagara United Soccer Club

    Translater should be visible just above the Social Media links on the top right of all pages (at the top of the right sidebar).

    Would be great to get this running again! Thanks!

    http://wordpress.org/extend/plugins/google-language-translator/

  2. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Pixel Light Media, I just updated the plugin with some crucial fixes that needed to be added. I'm not 100% sure if this will solve the problems in your specific case, but try out the new version and let me know if you are still having issues. (New Version 1.7)

    Thanks, Rob

  3. Pixel Light Media
    Member
    Posted 1 year ago #

    Hi Rob,

    I tried the update (v1.7) but unfortunately no luck yet.

    The shortcode function must be working because I can see the Script Code it writes when I view Page Source in the Browser.

    Thanks for your reply, I hope my feedback helpful.

    Cheers!
    Frank.

  4. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Pixel Light Media, I see what is likely the problem: for some reason the plugin is not displaying the script code correctly, which is a plugin issue.

    See below, and notice the two commas after the 'en':

    <br />
    <script><br />
    	function googleTranslateElementInit() {<br />
    	  new google.translate.TranslateElement({<br />
    		pageLanguage: 'en', , layout: google.translate.TranslateElement.InlineLayout.HORIZONTAL<br />
    	  }, 'google_translate_element');<br />
    	}<br />
    	</script><br />

    It's not displaying any "specific language" codes and that is why it's not working. I will try and fix today to get it working. I bet if you try vertical layout it will work because that is a different function and I haven't heard about any problems there yet.

    Hang tight!

  5. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Also, you might want to make sure that if you choose the option for "Specific Languages" that you select at least 1 of the language checkboxes below that option - because if nothing is "checked" it might also cause the plugin to act this way.

  6. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Pixel Light Media, also let me know the exact option choices that you have set in the settings panel....

  7. Pixel Light Media
    Member
    Posted 1 year ago #

    Hey, you're right about the Vertical setting option, it now displays!

    That will definitely do the trick for now, thanks so much!

    As for my settings (at the time that it would not display):

    Plugin Status - checked
    Original Language - English
    Translation Language - All
    Display option - Horizontal
    Show Google Toolbar - No
    Show Branding - Yes

    Really appreciate your time on this and I hope you can find a fix.

    Cheers!

  8. TranCea
    Member
    Posted 1 year ago #

    I have the exact same issue. When will this be corrected?

  9. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hello everyone, I updated the plugin to version 1.8. I'm hoping this fixes the issue with the translator not displaying at all in Horizontal layout. Please download and provide me feeback about your results! Thanks so much for bringing this to my attention.

    Rob

  10. wernertk
    Member
    Posted 1 year ago #

    Hi rm2773

    The languages isn't showing on Firefox 21.0
    It is showing in Chrome and IE.
    I'm using the current version of Google Language Translator 1.8 on http://www.capetownlife.co.za

  11. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hi wernertk,

    We're you able to fix this on your own, I am currently using Firefox 21.0 and I'm seeing the translator on the top right of the screen. Please let me know if you still need assistance.

    Thanks!

  12. JJ
    Member
    Posted 1 year ago #

    The horizontal layout is working for me in Firefox 21.0, however, the entire style is warped when choosing a language. This is not happening on other browsers.

    http://www.thecompanycube.vidawebsites.com/build/creating-new-cards/

  13. wernertk
    Member
    Posted 1 year ago #

    Hi wernertk,

    We're you able to fix this on your own, I am currently using Firefox 21.0 and I'm seeing the translator on the top right of the screen. Please let me know if you still need assistance.

    Thanks!

    Nope, could not fix this. You're right, it does show, but does not display the list of languages. Chrome and IE does display the list of languages

  14. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hi JJ, I have attached a screenshot that shows the plugin working correctly. I'm using Firefix 21.0 and it looks great here! I'm sorry it's not working on your end - I'm not sure what the issue could be at this point.

    Here the link to my screenshot:

    http://www.studio88design.com/support-page/

  15. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    Hi wernertk, I have also attached a screenshot of your website, and it looks great from here! I'm using Firefox 21.0. Here is a link to see the screenshot:

    http://www.studio88design.com/support-page/

  16. JJ
    Member
    Posted 1 year ago #

    Thanks for the feedback Rob! I like the plugin, but ended up going with a different solution to translate only the post content. Best wishes!

  17. wernertk
    Member
    Posted 1 year ago #

    Hey rm2773

    Turns out that Flashblock plugin in Firefox was seeing it as flash! I have disables the plugin and it shows correctly. Awesome plugin btw :-) Keep it up.

  18. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    wernertk, thanks for letting me know about that - it will be useful for anyone with a similar issue in the future. I'm glad ti ended up displaying the way you like though. I know that can be frustrating.

    Thanks, Rob

  19. Rob Myrick
    Member
    Plugin Author

    Posted 1 year ago #

    JJ, thanks for keeping me posted about your solution as well. I don't believe this plugin (nor the Google Translator itself) would be able to translate only single posts. I believe their API automatically translates the entire page. Maybe something to check into though as a possible future option, if I can manipulate Google's translator!

    Thanks, Rob

  20. winresh
    Member
    Posted 7 months ago #

    Hello Sir Rob,

    Why is google language translator is not working at my part. Before it was working accurately but after I update my WordPress to 3.8 its not working anymore. How can I fix this sir? Can you help me with this.

    Thanks

  21. Rob Myrick
    Member
    Plugin Author

    Posted 7 months ago #

    Hi Winresh, send your login details as discussed in our email and I will resolve for you ASAP.

    Thanks! Rob Myrick

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.