WordPress.org

Ready to get started?Download WordPress

Forums

WP UI - Tabs, Accordions, Sliders
Not working after 3.7.1 Update (10 posts)

  1. KingoStarr
    Member
    Posted 8 months ago #

    Hello,

    I updated the plugin as well as updating my site to 3.7.1 and now the plugin is no longer working and instead of being tabs it takes up half a page with the contents of the tabs placed into what is essentially a list.

    Is anyone else having this problem? I have tried other tabbed widgets and they also do this, I even used tabs shortcode which did this. Is there any resolution?

    http://wordpress.org/plugins/wp-ui/

  2. fpmsummer
    Member
    Posted 8 months ago #

    Good to know. I just updated a site to 3.6.1 over the weekend and got this same behavior, so I downgraded to WP UI 0.8.7 and got the working tabs back.

    Now I know that updating to WP 3.7.1 doesn't fix anything.

  3. KingoStarr
    Member
    Posted 8 months ago #

    Am I able to downgrade the plugin as well? If so could you be so kind as to tell me?

    Thank you :)

  4. msarns
    Member
    Posted 8 months ago #

    I found the old /js/wp-ui.js file worked in the update.

    I then tracked down that it's something wrong with the "navigation" function that can be found starting at line 222 in the unminified /js/wp-ui.dev.js.

    I copied the old function from 8.7 to the wp-ui.js in 8.8, and it works and nothing else appears broken. Yet :)

    You have to work with the not-minified content. You can reminify if you'd like.

  5. KingoStarr
    Member
    Posted 8 months ago #

    May I ask what function that was? I have found the area you mentioned but do not have the old file functions to hand

    Appreciate the help!

  6. msarns
    Member
    Posted 8 months ago #

    KS: The function in 8.8 starts off with

    "navigation: function() { var baset = this, $this = this.element, ulWidth = 10000..."

    I just selected matched braces and pasted the old function content into the new :D

    You can get the 8.7 content at the developer's GitHub:

    https://github.com/kavingray/wp-ui/releases

  7. KingoStarr
    Member
    Posted 8 months ago #

    Thank you I will try this later!

    Thanks Again really appreciate the help!

  8. KingoStarr
    Member
    Posted 8 months ago #

    Msarns just to keep you updated, I finally got round to looking at what you said to do and its only gone and worked!

    Thanks so much! Properly chuffed with that!

  9. dennis93q
    Member
    Posted 8 months ago #

    Help -- I've never done anything with minify so that's completely foreign to me. However, I did try to replace the navigation: function() from 8.7 in the 8.8 version of the dev file, and that didn't work. I removed the non-dev js file and that didn't work either. I also tried to revert back to the entire 8.7 package, and that didn't work. Any other things to try?

  10. petergluk
    Member
    Posted 8 months ago #

    The same trouble.. I have version 0.8.8 Look foe the wp-ui.dev.js - but there written "WP UI version 0.8.7" and its minified, and a can't find The function starts off with "navigation: function() { var baset = this, $this = this.element..." Help!

Reply

You must log in to post.

About this Plugin

About this Topic