WordPress.org

Ready to get started?Download WordPress

Forums

Simple Twitter Connect
[resolved] Not Working? (18 posts)

  1. germinus1
    Blocked
    Posted 1 year ago #

    Am I right in thinking that twitter has issues at the moment, or is it just me that has issues! Followed destructions best I could but can't seem to get this working, Facebook worked like a charm, but not this one! I have installed and saved settings but nothing happens when I press sign in with twitter on the settings page?

    http://wordpress.org/extend/plugins/simple-twitter-connect/

  2. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    It's not working at the moment, due to Twitter's recent API changes. I'll try to revamp it sometime in the next week or so, but it will take a fair amount of time. Sorry for the delay.

  3. germinus1
    Blocked
    Posted 1 year ago #

    No problem, just wanted to make sure it was not me doing it wrong

  4. germinus1
    Blocked
    Posted 1 year ago #

    Has this been fixed yet?

  5. absroh
    Member
    Posted 1 year ago #

    I'd love to get an update on this as well. Thanks. :)

  6. chensihai
    Member
    Posted 1 year ago #

    If it can't be made to work, then we have to switch to other plugins which is now still working.

  7. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    If it's critical to your operation, then yes, I'd recommend switching to another plugin.

  8. germinus1
    Blocked
    Posted 1 year ago #

    Ok thanks Sam, shame as I like yours! Can you recommend an alternative?

  9. chensihai
    Member
    Posted 1 year ago #

    germinus1, it's not that easy sometimes.
    You can look at Nextend Twitter Connection, which works fine.

  10. germinus1
    Blocked
    Posted 1 year ago #

    thanks chensihai

  11. germinus1
    Blocked
    Posted 1 year ago #

    I was looking for a plugin that posts to twitter when you post a new blog, the plugin you mentioned seems to be just a login.

  12. chensihai
    Member
    Posted 1 year ago #

    Make your hands dirty, merge them.

  13. germinus1
    Blocked
    Posted 1 year ago #

    Sorry chen I don't understand what you mean?.... This topic has been marked as resolved, has the plugin been fixed? It would seem not by the last update date of the plugin so not sure why this has been marked as resolved!

  14. chensihai
    Member
    Posted 1 year ago #

    That only means, the author put some word, and make it resolved.
    It's not really resolved for us.

    I just thought you could use Nextend Twitter connection as core connection, also borrow some function/code from this plugin, to post content to TW.

    For me, I only use the login function of this plugin, which is not working.

  15. absroh
    Member
    Posted 1 year ago #

    Otto - I would rather use this plugin. :)

    Let me know when you get a chance of a rough estimate when we can expect a fix.

    Thanks.

  16. germinus1
    Blocked
    Posted 1 year ago #

    I am using nextscripts premium plugin that autoposts to just about every social media you can think of. However it does not add the like buttons for google, facebook and twitter. So I am using Otto's plugins for that, not sure if it will work for twittter, going to try that now. I dont mean post to twitter I mean the twitter button and the end of posts/pages.

  17. Samuel Wood (Otto)
    Tech Ninja
    Plugin Author

    Posted 1 year ago #

    The new Jetpack 2.0 has the ability to post to Facebook and Twitter for new posts. You might try that.

  18. cigzigwon
    Member
    Posted 11 months ago #

    I solved the problems people have been dealing with in your plugin. The fix comes down to wordpress having issues with HTTPS requests and not having a valid CA cert, a missing parameter in the access_token as well as a missed URL update for the callback to verify the account login.

    I did this by:

    --Updating OAuth.php to the latest and adding your class_exists check back in.
    --Change the $TO_API_ROOT variable to use http:// instead of https:// in twitterOAuth.php
    --Update the $this->accessTokenURL() to accept a required parameter $_REQUEST['oauth_verifier] in twitterOAuth.php
    --Update the function stc_get_credentials() to use "http://api.twitter.com/1.1/account/verify_credentials" as the url for the stc_do_request() call in stc.php

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.