WordPress.org

Ready to get started?Download WordPress

Forums

not sure what my database name is! (8 posts)

  1. paintersinn
    Member
    Posted 7 years ago #

    I am sorry to be a pain and ask stupid questions but I am attempting to install wordpress. I have installed MAMP on my mac, which seems to be working correctly, the server lights are all on. I have been given by MAMP a username and password, but I am unsure what to put in the database name bit. Also when I have inserted all the correct information what do I do with the file, just save it as wp-config.php? I am sorry I have to do this website for college and seem to have only been given half the information by my tutor, and now it is half term!

  2. MichaelH
    Member
    Posted 7 years ago #

    Yes put the information such as DB_HOST etc and save the file as wp-config.php.

    You need to create the database (that will be DB_NAME) first before doing the install.

    Resources
    Installing WordPress
    http://www.google.com/search?q=installing+mamp+on+a+mac

  3. paintersinn
    Member
    Posted 7 years ago #

    OK i created a database in phpmyadmin called tanzania. Then I installed wordpress, changed the bits, saved it as wp-config.php and uploaded it to the thing but it came up as error as follows:

    ERROR: Unknown Punctuation String @ 1
    STR: <?
    SQL: <?php
    // ** MySQL settings ** //
    define('db_name', 'tanzania');<?php
    // ** MySQL settings ** //
    define('db_name', 'tanzania');<?php
    // ** MySQL settings ** //
    define('db_name', 'tanzania');<?php
    // ** MySQL settings ** //
    define('db_name', 'tanzania');<?php
    // ** MySQL settings ** //
    define('db_name', 'tanzania');<?php
    // ** MySQL settings ** //
    define('db_name', 'tanzania');<?php
    // ** MySQL settings ** //
    define('db_name', 'tanzania');<?php
    // ** MySQL settings ** //
    define('db_name', 'tanzania');

    SQL query:

    <?php // ** MySQL settings ** // define('db_name', 'tanzania');

    MySQL said: Documentation
    #1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '<?php
    // ** MySQL settings ** //
    define('db_name', 'tanzania')' at line 1

    I am confused

    [

  4. moshu
    Member
    Posted 7 years ago #

    Why people never read the resource they were given?
    Go back to that Installing WordPress link MichaelH gave you and READ it. All. Everything.
    Mainly:
    http://codex.wordpress.org/Installing_WordPress#Step_3:_Set_up_wp-config.php

  5. MichaelH
    Member
    Posted 7 years ago #

    Looks like an editor problem--review Editing_Files and make sure you are using a proper editing tool.

  6. paintersinn
    Member
    Posted 7 years ago #

    OK smart arse I did read the stuff michaelh gave me, then read it again and again. And just to make sure I read it again, but it still doesn't work. I am using textedit to amend the doc.

  7. MichaelH
    Member
    Posted 7 years ago #

    OK i created a database in phpmyadmin called tanzania. Then I installed wordpress, changed the bits, saved it as wp-config.php and uploaded it to the thing but it came up as error as follows:

    The above is a bit confusing--after you put the correct values in wp-config.php you then upload that file to the proper place and then do the the installation with something similar to
    http://example.com/blog/wp-admin/install.php

  8. whooami
    Member
    Posted 7 years ago #

    meh!!

    Paste your wp-config.php and xxx out what you put for your values, leave EVERYHTHING else in tact.

    theres a typo in your file.

    And dont insult volunteers or we might all ignore you.

    we dont have to help you.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags