WordPress.org

Ready to get started?Download WordPress

Forums

Not Smart Enough to Fix It. :/ (20 posts)

  1. Sphyr
    Member
    Posted 9 years ago #

    In an attempt to fix trackbacks, I thought I'd be brave and daring and install a nightly for the first time ever. I saved my old index.php, and copied all the changes to the new index.php.
    Something's still broke, though. Permalinks all point back to 'home', the "comments" button doesn't work anymore (it points to 'home'/#comments)
    I'm not smart enough to fix what I broke though. Can somebody point me in the right direction? Is the problem in my index.php file or elsewhere?
    http://www.chasingthewind.net

  2. Sphyr
    Member
    Posted 9 years ago #

    If I had to guess, the problem starts here in my index.php:
    <div class="post">
    <h3 class="storytitle" id="post-<?php the_ID(); ?>">" rel="bookmark" title="Permanent Link: <?php the_title(); ?>"><?php the_title(); ?></h3>

    This is where the permalink is broken. I haven't made any changes to "Edit Permalink Structure" in the admin pages.

  3. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I would make a copy of your current .htaccess, then create a new structure with the new build. It's worth a go.

  4. Sphyr
    Member
    Posted 9 years ago #

    I don't know what that means. :(

  5. Beel
    Member
    Posted 9 years ago #

    <?php the_permalink() ?> is not returning anything. Maybe try re-uploading template-functions-link.php to your server.
    Also, did you run upgrade.php?

  6. Sphyr
    Member
    Posted 9 years ago #

    Interestingly, I can load the latest post directly; http://www.chasingthewind.net/index.php?p=299 will take you to the lastest "Oops, Technical Trouble" post. And from there, I can post a comment.
    But the links from the main index.php don't point there.

  7. Sphyr
    Member
    Posted 9 years ago #

    Beel, can you suggest a way for me to fix this manually? Can I create a customized permalink that mimics the default?
    It bothers me I have a blog that nobody can comment on and I'd like to fix it quickly. I probably should have waited until 1.3 was released, but I wanted to fix the trackback problem I was having.

  8. Beel
    Member
    Posted 9 years ago #

    Maybe one of the devs will happen along with a suggestion, I just haven't seen anything like this so I'm having trouble guessing what it might be. Try placing another <?php the_permalink() ?> just above the h3 tag and see if anything is actually echoed. Plenty of people don't have permalinks turned on and I don't recall this issue so I am stumped.

  9. Sphyr
    Member
    Posted 9 years ago #

    Is my problem the same one as the one listed here?
    http://wordpress.org/support/6/10793

  10. Beel
    Member
    Posted 9 years ago #

    Doesn't sound like it but then again it would be hard to tell as no one with the problem cared or thought to supply a link.
    I'd suggest going through with setting up permalinks with the examples given in that section, write the .htaccess file with the code provided and then see what happens. If it works, then I suppose it could be a bug with this release (though I doubt it). Then again, I am just shooting in the dark until someone more knowledgeable cares to chime in... Anyone?

  11. carthik
    Member
    Posted 9 years ago #

    Please hold on till there is a stable 1.3 release. Nightlies are not stable, and there is no guarantee they will work just fine. By the time 1.3 stable is out, there will be instructions, if at all needed, as to how to upgrade to 1.3, including special instructions related to the index, if any.

  12. carthik
    Member
    Posted 9 years ago #

    To help with your immediate problem, though, the reason for your troubles could be that the new nidex.php that ships with 1.3 nightlies are different in the way they work, from the old index.php. So try a default index.php that ships with 1.3, and make sure that works, then you can start changing it like you did for the previous WP install you had.

  13. Sphyr
    Member
    Posted 9 years ago #

    I've put Alex's style switcher and added my blogrolling list back in since it was pretty obvious the problem is not a custom index.php problem. I have the same problem with the default index.php file.
    What else might cause the permalink to be blank? How does the_permalink get filled with a value? The other variables - the_author, the_category, etc, are filled out.
    I suspect I can't revert - the database changes are one-way. Can I mimic the default permalink in my wp-admin options, and is it possible that might help? Is so, what is the default? Something like /archives/%year%/%monthnum%/%day%/%postname%/ maybe?

  14. Matt Mullenweg
    Troublemaker
    Posted 9 years ago #

    The problem is most likely your setting under Options > Permalinks. Try changing it around.

  15. Matt Mullenweg
    Troublemaker
    Posted 9 years ago #

    I know, but it sounds like it thinks they are and is trying to generate customized permalinks using a bad string. Hence, playing with that setting could help things.

  16. carthik
    Member
    Posted 9 years ago #

    It seems like a bug in the nightly
    login to
    http://2fargon.com/wpcvs/wp-login.php
    using
    admin
    and
    password
    The permalinks aren't working there, without any rewrite rules.

  17. Sphyr
    Member
    Posted 9 years ago #

    Allusion - yes, I had the same thought a few posts back. I just don't know what to change it to.
    2fargon - aha! That's *exactly* the problem I'm having!

  18. Beel
    Member
    Posted 9 years ago #

  19. dylan
    Member
    Posted 9 years ago #

    I've been following this thread closely, as I am having all of the same problems, and none of the proposed solutions have worked for me. I read: http://wordpress.org/support/6/10874 and wonder if Beel (or anyone) could be more specific. Namely, if changing rewrites would help, how? and how is this done?
    Life without permalinks... *sigh*

  20. Sphyr
    Member
    Posted 9 years ago #

    I guess the nightlies aren't generated nightly. :P

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.