WordPress.org

Ready to get started?Download WordPress

Forums

Floating Social Media Links
[resolved] not showing up (14 posts)

  1. Model29-2
    Member
    Posted 1 year ago #

    I installed the latest (1.4.2) and have wordpress 3.4.2. I was able to configure the settings just fine, and have it set to show on all pages, but don't see it.
    Looking at the code I can see the frame, and wp_footer and wp_header are in place on the template. Can you help? I'm out of ideas.

    If you want to see the site I am working on it is:
    http://www.ambassadorministries.net.

    http://wordpress.org/extend/plugins/floating-social-media-links/

  2. Nick Halsey
    Member
    Plugin Author

    Posted 1 year ago #

    Hello, I just looked and it seems to display properly, although it is pretty far down the page. You could try adjusting the "Top Margin" setting if you still don't see it (try making it smaller). If you want it to show up on IE 7, you'll need to check the checkbox to do so in the advanced general options (not enabled by default because of the inelegant html needed to do so). Does that solve the issue?

  3. Model29-2
    Member
    Posted 1 year ago #

    I moved top margin to 150 px and changed it to dynamic FWIW. I am using IE9 and it still seems to be "stuck" on the lower right hand corner. Are you using Firefox or other one to see it?

  4. Model29-2
    Member
    Posted 1 year ago #

    I meant lower left corner....
    Also, it doesn't seem to want to float, which is what I meant by being "stuck" in the corner.

  5. Nick Halsey
    Member
    Plugin Author

    Posted 1 year ago #

    I've checked on chrome, firefox and IE10 rendering as IE7 and 9. What's your screen resolution? It's showing up about in the middle of the page for me vertically (768 px screen height). If you switch the top margin to a %, such as 25% or so, it will adjust the vertical positioning based on screen size.

    It is acting very buggy in terms of being able to click the links. This is a layering issue, the z-index needs to be set back up to a much higher value like the default (you currently have it set as 10). In your case, it looks like the minimum that will work is 101. To prevent the frame from covering the site content on small screens, you can set a minimum width for showing the frame in the advanced general options. You can try re-sizing your window to test it, and when the window is smaller than the value specified, the frame should disappear.

    This plugin favors a clean "stay-in-place" float, so the frame should stay in the same place on the screen consistently as the page is scrolled. The effect is a little different when the frame blends in with the background by having the same color, but in your case I think it looks nice. The clean float is to prevent the frame from being distracting. I know that there are other plugins which favor an animation-style float, although I don't know whether they support custom links.

  6. Model29-2
    Member
    Posted 1 year ago #

    My screen is set at 1280 x 1024. I moved the layering to 9000, and set the dynamic width to 25%. I selected "hide the frame at 600 px".
    I cleared the cache on IE and restarted it but it doesn't appear changed at all, and still won't float.

    I tried the links again, and now they don't seem to work! ???
    Stumped again.

    I really appreciate your response! I like the links this provides.

  7. Nick Halsey
    Member
    Plugin Author

    Posted 1 year ago #

    The actual links are all missing the ".net", I just noticed. But it's displaying much smaller on IE than the other browsers. The z-index and minimum width do appear to be working from my end, so the only weird thing that I can see is the size discrepancy.

    I found an extra %, which chrome ignores but IE doesn't. The plugin automatically adds % to the width, so the browser ends up getting 25%% for the width. Try removing the % from the settings and that should fix the size discrepancy, hopefully that'll fix the other issues too.

  8. Model29-2
    Member
    Posted 1 year ago #

    Fixed the missing ".net". My bad.
    Took out the %.
    Restarted IE after clearing the temp files, and I don't see any difference.
    One thing I noticed; In the appearance=>widgets area my page templates have a "Bottom 1", "Bottom 2", and "Bottom 3" that are columns that are for just below the content, but just above the footer. The frame appears to be trapped in "Bottom 1", although I don't know how to check the code to see if that is the case. I can follow the code but don't know the language. Could that be an issue?

  9. Nick Halsey
    Member
    Plugin Author

    Posted 1 year ago #

    It's a possibility. I'm still not able to see what the issue is. My only suggestion would be to look at where <?php wp_footer() ?> is in footer.php of the theme. Based on the html, it looks like it isn't where is should be, right before </body></html> at the very end.

  10. Model29-2
    Member
    Posted 1 year ago #

    Aha! Progress. The wp_footer line was a line up from the body/html code. The frame is now in the upper left hand corner of the page, and it floats, but adjustment of size and position don't seem to work. I set the distance down from the top at 150px and the size as 200px and it doesn't change.

    Any other way to adjust the size and position except from the Settings?

  11. Nick Halsey
    Member
    Plugin Author

    Posted 1 year ago #

    Oh, I just remembered, there's a maximum width set for the frame. For your purposes, that's irrelevant, so you can override that in your theme's css. Just add #fsml_ff { max-width: [the maximum width]px; } (no []s). That's set in an external file, but you may need to wrap it in <style></style> tags and put it into header.php or footer.php if putting it in a css file doesn't work.

    For the vertical positioning, I'm seeing it as 250px, and changing that value does move the frame, is that still broken for you?

  12. Model29-2
    Member
    Posted 1 year ago #

    So I put this:

    #fsml_ff {max-width: 200px;}

    into style.css, but it didn't seem to make any difference.
    I then did what you suggested and did this:

    <style> #fsml_ff {max-width: 200px;} </style>

    and put it in the header.php right after the wp_head entry.

    The vertical position was set at 250px, yes, but doesn't seem to be moving it 250. I changed it to 500px but nothing happened.

  13. Nick Halsey
    Member
    Plugin Author

    Posted 1 year ago #

    It's displaying at 500px down the screen now for me on various browsers... so I'm not sure what's up.

  14. Model29-2
    Member
    Posted 1 year ago #

    Thanks for checking this out. I don't know where to go from here so I think I will just drop it. I looked at it on 3 different computers with IE9 and they all look the same. It floats OK, but is stuck in the upper left corner, and is too small to read the icons.

    Thanks for your help. Really do appreciate it.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.