WordPress.org

Ready to get started?Download WordPress

Forums

Social Media Feather
[resolved] Not showing on pages (12 posts)

  1. rodders39
    Member
    Posted 1 year ago #

    I have purchased the extra icons and grey fade effect.

    The buttons will not display on my pages. Posts are fine but not pages! Doesn't matter whether I try to get them on pages on their own or pages + posts... Any ideas...?

    BTW, best social sharing plugin I've tried... and I've been through a lot... :)

    Cheers
    Rod

    http://wordpress.org/extend/plugins/social-media-feather/

  2. Synved
    Member
    Plugin Author

    Posted 1 year ago #

    Just go into the plugin's settings under Settings -> Social Media and where it says "Share Post Types" and/or "Follow Post Types" simply CTRL + click "page".

    Alternatively you can use widgets or shortcodes.

  3. rodders39
    Member
    Posted 1 year ago #

    Ah, but the issue is I have both post and page highlighted and it only shows on posts. Have tried all sorts of things, including deletion and reinstallation, and it makes no difference... :(

  4. Synved
    Member
    Plugin Author

    Posted 1 year ago #

    You have them selected for both Follow and Share? That's odd, can you provide a link?

  5. rodders39
    Member
    Posted 1 year ago #

    No, I only want sharing... but I have selected both pages and posts but nothing happens with pages... they only show on posts...

    PenAir

  6. Synved
    Member
    Plugin Author

    Posted 1 year ago #

    What theme are you using? Can you provide a screenshot of the plugin settings page, or tell me which other entries do the select boxes with "post", "page" etc. display? Are you using any caching plugins? Can you try empty those caches?

  7. rodders39
    Member
    Posted 1 year ago #

    Genesis Agency theme with W3TC. I've emptied the cache lots... Would it be easier if I give to access to the site...?

  8. Synved
    Member
    Plugin Author

    Posted 1 year ago #

    You can send me the details through the contact form on our site but I'm not sure if/when I'll have time to check as it's quite involved and mostly the problem is caused by a plugin/theme odd conflict.

  9. rodders39
    Member
    Posted 1 year ago #

    Fixed. I have unticked the Sharing Single Posts option and now the buttons display on all my pages again.

  10. Synved
    Member
    Plugin Author

    Posted 1 year ago #

    Good point. I'll fix this so you can re-enable that option in a future version.

  11. Rob
    Member
    Posted 1 year ago #

    Thanks @rodders39! I was having the same problem. Will look out for the next update so I can remove the buttons from the blog archive pages.

    This is a great plugin though anyway. Thanks.

  12. Rob
    Member
    Posted 1 year ago #

    Hi, was version 1.2.3 supposed to fix this? Because it hasn't.

    I wasn't sure whether the changelog bullet point 'Fix check for single posts to include all singular pages' was to do with this.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.