WordPress.org

Ready to get started?Download WordPress

Forums

IX Show Latest YouTube
[resolved] Not showing most recent video (14 posts)

  1. sheetskees
    Member
    Posted 1 month ago #

    Trying to get this plugin working on my wordpress. Made a page for live streams and set it up. It keeps showing an error instead of playing latest uploaded video.

    Link

    https://wordpress.org/plugins/ix-show-latest-youtube/

  2. Daniel J. Lewis
    Member
    Plugin Author

    Posted 1 month ago #

    Can you post a screenshot of your settings page?

  3. sheetskees
    Member
    Posted 1 month ago #

    Looking into the code, it looks like the plugin is pulling "http://www.youtube.com/embed/fAzrAHh8hAQ&rel=0" and not the correct format of "http://www.youtube.com/embed/fAzrAHh8hAQ?rel=0"

    Any idea how to make it pull the correct code?

  4. sheetskees
    Member
    Posted 1 month ago #

    Here is the settings
    http://i.imgur.com/YXQ30qZ.jpg

  5. Daniel J. Lewis
    Member
    Plugin Author

    Posted 1 month ago #

    Ah. I see the problem in the code. We'll try to get that fixed quickly.

    But in the meantime, enable Autoplay and that will correctly format the embed code.

  6. sheetskees
    Member
    Posted 1 month ago #

    Enabled autoplay, still no good.

  7. Daniel J. Lewis
    Member
    Plugin Author

    Posted 1 month ago #

    It doesn't look like Autoplay is enabled. Did you clear your cache?

  8. mariolcneto
    Member
    Posted 1 month ago #

    I am getting the exact same error!

  9. Daniel J. Lewis
    Member
    Plugin Author

    Posted 1 month ago #

    Did you enable autoplay and refresh your cache?

  10. mariolcneto
    Member
    Posted 1 month ago #

    Yes! Still not working.

  11. Elie Herrera
    Member
    Posted 1 month ago #

    Same thing over here! I tried enabling autoplay, refreshing cache = still not working.
    Agree with sheetskees about the video correct format sending (&) instead of (?) in the video url.

  12. Elie Herrera
    Member
    Posted 1 month ago #

    I managed to fix this editing the plugin code in the line 184.

    From this:
    $src .= $videoId . $autoplay . '&rel=0';

    To this:
    $src .= $videoId . $autoplay . '?rel=0';

    Now all videos are loading just fine!

  13. Daniel J. Lewis
    Member
    Plugin Author

    Posted 1 month ago #

    Thanks for posting that temporary fix. We'll have something better in a coming update.

  14. Daniel J. Lewis
    Member
    Plugin Author

    Posted 1 month ago #

    Hi, everyone! I'm pleased to share that 2.3.1 is now live and fixes this problem!

    It also lets you set "Show related" in the options page.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.