WordPress.org

Ready to get started?Download WordPress

Forums

Not showing content on pages (8 posts)

  1. MrDanielson
    Member
    Posted 4 years ago #

    Hey guys.

    I am modifying the theme "ThrillingTheme", but now I do have problems on the pages, it's just not showing any content, but the title of the page...

    Help is needed. Tell me if you need some sourcecode. :)

  2. Thor Brink
    Member
    Posted 4 years ago #

    Hi.

    Source code of the template page which is used when the problem is occuring would be helpful.

  3. MrDanielson
    Member
    Posted 4 years ago #

    Surely :-)

    Here it is:

    [Code moderated as per the Forum Rules. Please use the pastebin]

  4. Thor Brink
    Member
    Posted 4 years ago #

    Sorry, I guess you have to paste source code in the pastebin for it to show up.

  5. MrDanielson
    Member
    Posted 4 years ago #

  6. MrDanielson
    Member
    Posted 4 years ago #

    /bumpy bump. :)

  7. Thor Brink
    Member
    Posted 4 years ago #

    Will you get it to show anything? Except for the title of the post? Will it enter the loop? I can see that you are missing an argument which can be good to have in the if-statement of the loop. "if ( have_posts() && is_single() )". This makes sure that you have a single post fetched from the query.

  8. MrDanielson
    Member
    Posted 4 years ago #

    Thanks, but it was my fault - it was page.php, and not single.php, and I figured out the error - the page.php file was somehow empty where there should be content, so I just copied the code from the index.php :)

Topic Closed

This topic has been closed to new replies.

About this Topic