WordPress.org

Ready to get started?Download WordPress

Forums

Smart Layers by AddThis
[resolved] Not showing at all (9 posts)

  1. elmalak
    Member
    Posted 8 months ago #

    I had been using Smart layers via inserting Manual code and things worked nicely.
    Yesterday I switched over to using the plugins and since then nothing shows up on my site from the smart layers.
    http://www.elmalakrx.com/Arabic/

    Please, help me fix it.

    Thanks.

    http://wordpress.org/plugins/addthis-smart-layers/

  2. Sol
    AddThis Samurai
    Plugin Author

    Posted 8 months ago #

    Sorry for the problems you're encountering, but could you please go to the AddThis Smart Layers setting page and try disabling and re-enabling the layers. The code being inserted into the page is invalid and I'm hoping by disabling and re-enabling the layers, it should fix the problem. Please let me know if you still have problems after trying this.

  3. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 8 months ago #

    @elmalak: Also we would like to know which version of WordPress you are using.

  4. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 8 months ago #

    We have a quick fix in place now in our development version of plugin. Please try installing the dev build and let us know if it fixed the issue.

  5. elmalak
    Member
    Posted 8 months ago #

    Hi,
    Thank you for the prompt response and solution tips.

    I am using the latest WP 3.6.1

    I've tried to de-activate and re-activate and this seems to have solved the issue and the smart layers now appear normally.
    But when I try to customize it with my own settings that's where it disappears again!

    I've used the dev build, and it works even with changing settings and customization.

    By the way, I wanted to know whether your scripts gets called in the header or footer? as I wanted to move my scripts to the footer so they don't slow down the site loading as recommended by Google page speed service. And I wonder if that's an option that you can provide within the plugin settings?

    Many Thanks.

  6. Sol
    AddThis Samurai
    Plugin Author

    Posted 8 months ago #

    @elmalak, glad it's working now. We insert our code into footer of the page. We also only load a single asset which then asynchronously loads the required JS/CSS for Smart Layers to optimize performance.

  7. elmalak
    Member
    Posted 8 months ago #

    Hi,
    Thanks for the info, I am glad to hear so.

    I've just upgraded the plugin to the Version 1.0.2, and now it disappeared again!

    Not really sure why this is happening!

  8. Srijith V
    AddThis Samurai
    Plugin Author

    Posted 8 months ago #

    @elmalak: Sorry to hear that. We had to remove the temporary fix made in the dev build for fixing the issue in the new version. The issue is because of additional character escaping of strings made while saving the code. For a better fix, I would like to know the version PHP in your installation and the plugins you are using. We will try to recreate the environment and reproduce the issue. You may mail the details to srijith[AT]addthis.com if you prefer.

    For getting back the temporary fix which we removed in the update, edit the file:
    addthis-smart-layers/views/smart_layer_include.php, where you need to change the line:

    $addthis_smart_layer_include = 'addthis.layers(' . get_option('smart_layer_settings') . ');';

    to:

    $addthis_smart_layer_include = 'addthis.layers(' . stripslashes(get_option('smart_layer_settings')) . ');';
  9. elmalak
    Member
    Posted 8 months ago #

    Thank you for the help.
    It fixed the issue and the smart layers show up now.

    I will email you the details you requested.

    Thanks.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.