WordPress.org

Ready to get started?Download WordPress

Forums

Subscribe2
[resolved] Not sending emails for new posts (3 posts)

  1. HV-Rob
    Member
    Posted 1 year ago #

    Until 4 days ago, emails were being sent to subscribers for all new posts. As of 2 days ago, no one, myself included, received an email for a post published that day. I published another post today, and received an email at my administrator account, but not at another address for which I signed up. So emails do not seem to be going to out to general subscribers.

    I have seen advice that says to set the number of subscribers to 1. Perhaps I misunderstand, but why would I only want one recipient per email? It says to set to 0 for unlimited recipients. Nevertheless I will try that for my next post to see if it makes a difference. Could there be another problem? I did not change any other settings before this problem occurred.

    Thank you.

    -Rob

    http://wordpress.org/extend/plugins/subscribe2/

  2. mattyrob
    Member
    Posted 1 year ago #

    @Rob,

    This situation is very typical for Subscribe2 and it almost always due to server side emailing restrictions.

    Make sure you are using an on-domain email address. This means that the blog URL matches the domain of the emails address, so if your blog is http://www.example.com then the emails should come from admin@example.com.

    Also, change the number of recipients per email to 1. Subscribe2 is coded to send one email to many recipients using the BCC email headers. Unfortunately, this also looks to some providers like spam email. By setting that value to 1 each of your recipients gets a email direct to them without using the BCC header. This looks less like spam.

    However, I don't think either of these steps will resolve your issues completely because your hosting provider is still going to be placing some restriction on out going emails generated by your website. So, you need to speak to them and find out what those limitations are and how you can ensure you comply with them.

  3. HV-Rob
    Member
    Posted 1 year ago #

    Thank you Matty, I appreciate the insight. My latest post did send an email, but many hours later. I will follow your advice if the problem persists. Like I said, otherwise this has been working great, so thanks for setting this up and thanks for your help.

    -Rob

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags