WordPress.org

Ready to get started?Download WordPress

Forums

Attachments
[resolved] Not respecting image sizes other than the standard ones (8 posts)

  1. DavidGMiles
    Member
    Posted 1 year ago #

    For output, I am trying to spit out images other than the standard sizes, thumbnail, medium, large and full all get output correctly - other sizes within my theme do not get respected by the plugin, instead pumping out the fullsize image

    I am using $image_source = $attachments->src($size);

    The custom image sizes are correct as they are in use in other parts of the system

    Any help is appreciated

    http://wordpress.org/extend/plugins/attachments/

  2. Jonathan Christopher
    Member
    Plugin Author

    Posted 1 year ago #

    I believe this bug will be fixed in the next release, hopefully due today or tomorrow. I'm going to leave this ticket open until then.

  3. DavidGMiles
    Member
    Posted 1 year ago #

    Awesome - really like the plugin - come up with my own gallery plugin that leverages off it nicely

  4. Jonathan Christopher
    Member
    Plugin Author

    Posted 1 year ago #

    If you're able to upgrade to version 3.4 and let me know if this is a standing issue that would be a great help, thanks!

  5. DavidGMiles
    Member
    Posted 1 year ago #

    Nope that didn't fix it - however, I did notice something, the image sizes it does not respect are those that I add using the zui Additional Image Sizes WordPress Plugin (http://beingzoe.com/projects/zui/wordpress/zui-wordpress-plugins/additional-image-sizes-zui/) - those that I add to the functions.php file do get respected

  6. Jonathan Christopher
    Member
    Plugin Author

    Posted 1 year ago #

    Ah ha, that makes a ton more sense. I'll take a look at the plugin to see when it's adding the image sizes and see if I can hook in a bit later to accommodate that plugin and others that do the same thing, stay tuned!

  7. Jonathan Christopher
    Member
    Plugin Author

    Posted 1 year ago #

    I've just resolved the issue and the fix will be included in version 3.4.1 likely available in a day or two.

  8. DavidGMiles
    Member
    Posted 1 year ago #

    Awesome - thanks for that

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic