WordPress.org

Ready to get started?Download WordPress

Forums

Not receiving email notification of new comments (71 posts)

  1. laowaichinese
    Member
    Posted 7 years ago #

    I've seen some other posts on this but not about the current version of WordPress that I'm using (2.2.1).

    The title tells it all: I'm not receiving an email notification of a comment held for moderation nor a new comment posted to the site, although both of those boxes are checked in Options > Discussion.

    Interestingly, the email address (a forwarding account set up on my server) seems to be working fine because I have the WP-Contact Form plugin (http://www.douglaskarr.com/projects/wp-contactform/) sending to the same address and I DO get those emails.

    Any thoughts?

  2. snarkwife
    Member
    Posted 7 years ago #

    I am having the same issue - haven't received comment notifications in about three weeks. One day they just...stopped.

    I upgraded to the latest version of WP last night, thinking that might be the culprit as I was several updates behind.

    Also thought my email account might be filtering, so I switched to a Gmail account...and still nothing.

    It's curious there have been multiple questions posted about this issue, but no responses.

    Any help would be appreciated...please.

  3. laowaichinese
    Member
    Posted 7 years ago #

    Well snarkwife...it's just you and me for now I guess.

    Let me preface this with: I have no idea about php programming.

    Ok, so I noticed this problem started roughly the same time I upgraded to 2.2.1 (not to mention the problem I had with the database encodings...but that's solved).

    Maybe another plugin that is not 2.2.1 friendly is interfering. Just for kicks, I'll list all the plugins and versions I have running and you can tell me if you're running any of the same.

    Admin Drop Down Menu 1.3
    Akismet 2.0.2
    Clock 1.0
    Dagon Design Sitemap Generator 3.07
    FireStats 1.2.4-stable
    Full Text Feed 1.03
    No Self Pings 0.1
    Permalink Redirect 0.6.1
    Subscribe To Comments 2.1.1
    WordPress Database Backup 2.0
    WP-ContactForm 2.0.6

    That's my only theory for now, but I haven't gone through and tried deactivating them yet because I was kind of hoping someone else would fix this for me...any takers?

  4. snarkwife
    Member
    Posted 7 years ago #

    Alright...problem solved. Here's what I had to do...let me know if it worked for you.

    Go to Users>> Administrator>> Edit

    Turns out, the email address I had in there was not what I had under Options>> General. The email address in Users...I guarantee, is probably blocking my comment notifications (RoadRunner).

    I've added a Gmail account and had a reader post a comment...voila...I am now receiving comment notifications again.

    Good luck!

  5. laowaichinese
    Member
    Posted 7 years ago #

    Nope. That didn't work for me. I tried all combinations of having the email addresses be the same, different, and even leaving out the one in General > Options (you can't leave out the one in Users).

    At least you're finally allowed to receive comment notifications...sniff sniff...

  6. christophdollis
    Member
    Posted 6 years ago #

    That definitely didn't work for me either, sadly, changing the email addresses.

    Anyone have a clue?

  7. icecoolshweta
    Member
    Posted 6 years ago #

    Installing Swift SMTP plugin --http://www.shiftthis.net/wordpress-swift-smtp-plugin/ should fix the problem. For few people this problem got fixed in wordpress-2.2

    ~Shweta

  8. laowaichinese
    Member
    Posted 6 years ago #

    Swift SMTP plugin didn't work for me. In fact, it didn't even work. I couldn't even send myself the test email. I kept getting:

    Fatal error:
    Uncaught Error of type [swift_connection_exception] with message [The SMTP connection failed to start [tls://smtp.gmail.com:465]: fsockopen returned Error Number 110 and Error String 'Connection timed out']
    @0 require_once() in /home/content/l/a/o/laowaichinese/html/wp-admin/options-general.php on line 2
    @1 do_action() in /home/content/l/a/o/laowaichinese/html/wp-admin/admin.php on line 49
    @2 call_user_func_array() in /home/content/l/a/o/laowaichinese/html/wp-includes/plugin.php on line 164
    @3 st_smtp_options_page() in on line
    @4 wp_mail() in /home/content/l/a/o/laowaichinese/html/wp-content/plugins/swift-smtp/shiftthis-smtp.php on line 92

    in /home/content/l/a/o/laowaichinese/html/wp-content/plugins/swift-smtp/Swift/lib/Swift/Errors.php on line 99

    I'm using WordPress 2.3 now by the way.

  9. laowaichinese
    Member
    Posted 6 years ago #

    Oh, and one other thing that might be interesting:

    I pretended to forget my password at the wp-admin login screen and asked it to email me a new one. Here's the response:

    The e-mail could not be sent.
    Possible reason: your host may have disabled the mail() function...

    But I contacted my host and the php mail() function is enabled. Indeed, I have the wp-contact form plugin and that works fine. Doesn't that use the same php mail() function?

    So it looks like there's a bigger problem than just comments notification emails.

    Heeeeeeelp!

  10. giovanealex
    Member
    Posted 6 years ago #

    I have the same problem on my WP blog - and it was already upgraded to 2.3...

  11. bduranske
    Member
    Posted 6 years ago #

    Not sure how you guys are configured, but I had the same problem after moving to a new host. I use gmail-for-your-domain, which requires updating the MX records to gmail's servers. My new host had done that, but had somehow set it up so that internal mail (originating from my domain) went to my internal mail structure, so ended up being accessible via Squirrel mail and cPanel, but never made it out to Gmail's system. They're fixing it now. Probably not your problem... but you never know.

  12. ungerente
    Member
    Posted 6 years ago #

    ok I change my hosting and have the same trouble, (wordpress 2.3) i´m not reciving email notification of new comments.

  13. laowaichinese
    Member
    Posted 6 years ago #

    News for everyone,

    I have two blogs:
    1) http://laowaichinese.net
    2) http://english.laowaichinese.net

    Both are set with the exact same settings, and comments from both are sent to my same hosted email address (which then automatically forwards to my gmail).

    When a new comment is posted on both blogs, I get an email notification from the second ("english" subdomain) blog and not from the main one.

    What can that mean?

  14. KirkM
    Member
    Posted 6 years ago #

    Okay folks, I had the same problem when upgrading to 2.3. At first the emails were sporadic and sometimes hanging up refreshing a page once a comment was posted. I know that WP changed something (not sure what yet) that got around hosts that validate the email address of a sending site.

    Any way, by monitoring my WP install processes via my host's CPanel (BlueHost), I found that the email address that for comment notification was no longer my email address that I had listed in my WP Profile (Gmail address) but rather 'wordpress@myblogurl.net'. In order to solve this problem I used my host's CPanel to create a new email address like the one above, changed my WP Profile's address to the same as well and then back at the CPanel I set up a forwarder to forward all 'wordpress@myblogurl.net' to my Gmail address I had originally used for email notification. Problem solved.

    Sorry for lack of why's and wherefor's as I'm still trying to verify what was changed and sometimes info is hard to find around here. But I hope this solves your problems as it did mine.

  15. sportech
    Member
    Posted 6 years ago #

    I've had the same problem ever since updated to the new version. Anyone figure out a fix for this yet?

  16. sportech
    Member
    Posted 6 years ago #

    I've tried changing my email from my host email (sportech.info) to a yahoo email. That didnt help either. Other authors on my site are also not receiving notifications upon comment.

  17. danahuff
    Member
    Posted 6 years ago #

    After I upgraded from 2.3 to 2.3.1, I had the same problem as you all describe -- I no longer receive e-mails when I have comments. I have several blogs, and the same thing is happening on each. I didn't change any of my settings. I have to think this is not a coincidence.

  18. sportech
    Member
    Posted 6 years ago #

    Seems this is issue popping up alot recently as my other buddy who has a wordpress blog is running into the same problem.

  19. gilliancs
    Member
    Posted 6 years ago #

    Hello laowaichinese, I found this in the bug tracking department:

    WP installed in cPanel add-on domains do not send welcome messages to new WP users.

    http://trac.wordpress.org/ticket/2844

    Not much help as it is marked "wontfix" but it could be the same problem: the emails don't get sent correctly with subdomains.

  20. sportech
    Member
    Posted 6 years ago #

    Just to update I have had no problems receiving email from my contact form. It's still just an issue with notification upon commenting.

    This is becoming frustrating.

  21. foolswisdom
    Moderator
    Posted 6 years ago #

    If you are seeing this problem since upgrading to 2.3.1 please http://trac.wordpress.org/ticket/5294 . If that is the issue, please be sure to comment in the ticket sharing what your server and WordPress configuration is.

  22. sportech
    Member
    Posted 6 years ago #

    Thanks foolswisdom. That fixed my problem.

  23. laowaichinese
    Member
    Posted 6 years ago #

    foolswisdom,

    I tried both of those workarounds, but neither helped. (I'm on 2.3.1 now, by the way).

    I've created a forwarding email account called "wordpress@laowaichinese.net" on my domain. A forwarding account should qualify as "valid," right? I also tried taking that line out of the pluggable.php file. Again, no dice.

    I'm still baffled as to how the comments notifications are getting through on my subdomain blog: english.laowaichinese.net, but not on the main one laowaichinese.net.

  24. MadamePurl
    Member
    Posted 6 years ago #

    Just wanted to say a big Thank You to KirkM for listing out your solution. It worked for me right away. Thanks!!!

  25. TomJohnson
    Member
    Posted 6 years ago #

    Thanks foolswisdom. Adding the wordpress@<mydomain.com> made comment notification work again.

  26. KirkM
    Member
    Posted 6 years ago #

    Your welcome MadamePurl.

    You might want to check out foolswisdom's WordPress Trac link above and try the attached plugin to reverse the problem. I haven't tried it yet but if it works it just might save you from having to go into your host's webmail in order to clean out all the copies of your comments left on the server for that 'wordpress@yourblogurl.net/.com'

  27. serendipitypatchwork
    Member
    Posted 6 years ago #

    Thanks foolswisdom. I found that I didn't need to set up a new e-mail account as such, just adding a new e-mail forwarder/redirect for wordpress@myurl did the trick. Phew!

  28. CreativeChick
    Member
    Posted 6 years ago #

    foolswisdom, THANK YOU SO MUCH! It worked!

  29. Lloyd Budd

    Posted 6 years ago #

    Don't thank me, thank you for putting up with our bugs and being patient with these great folk trying to fix them!

  30. lisar915
    Member
    Posted 6 years ago #

    If you are seeing this problem since upgrading to 2.3.1 please http://trac.wordpress.org/ticket/5294 . If that is the issue, please be sure to comment in the ticket sharing what your server and WordPress configuration is.

    Dear Foolswisdom:
    I went to that web site and looked for that line of code in my pluggable.php file, but could not find it. Is there anything else you can suggest since I still am not receiving email notifications of news comments on my posts?

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic