WordPress.org

Ready to get started?Download WordPress

Forums

Not receiving email notification of new comments (71 posts)

  1. lisar915
    Member
    Posted 6 years ago #

    Hello again:

    I found that line of code in the pluggable.php file and removed that line of code, but still I'm not getting email notifications of new comments.

    Is there anything else I can try?

    Thanks.
    Lisa

  2. Lloyd Budd

    Posted 6 years ago #

    lisar915, did this problem specifically start happening after upgrading? There are any # of reasons for this issue, and many aren't specific to WordPress. If it is the problem described in 5294, instead of changing the code, install http://trac.wordpress.org/attachment/ticket/5294/no-sender.php as a plugin.

  3. lisar915
    Member
    Posted 6 years ago #

    Actually, today I have started receiving comment notifications via email, so perhaps it did help.

    Thanks again.

  4. laowaichinese
    Member
    Posted 6 years ago #

    lloydbudd,

    I'm starting to think my server is cursed. First of all the plugin called "no sender" that you recommended seems to be broken. It fails to activate and in my plugins menu the title of it appears as:

    <a href="http://blog.ftwr.co.uk/wordpress/" title="Visit plugin homepage">pjw-wp-phpmailer-nosender

    I've also added the forwarding address wordpress@<mydomain> and can receive emails to that address via a contact form, but still no comment notifications.

    Any suggestions?

  5. jballinger
    Member
    Posted 6 years ago #

    Hi I am on version 2.3.1 on my prod and dev environments. Only the administrator comment notification is not working for me. And it is only not working on my prod environment. The test environment is working fine. The only difference is the prod is running windows 2003 server and dev is running windows 2000. I looked at all the prior suggestions and could get nothing to work. This has been an issue ever since I first starting using wordpress and could not find a fix. Any suggestions?

    Thanks
    J

  6. haniobaid
    Member
    Posted 6 years ago #

    I've been running without problems for months. As soon as I upgraded from 2.3 to 2.3.1 I stopped receiving emails when users make comments (whether or not the comment goes to moderation). The related checkbox in the options is checked. I tried checking it and unchecking it. Adding an email address wordpress@mydomain.com did not fix the issue. I will try the plugin mentioned above.

  7. khristopher
    Member
    Posted 6 years ago #

    I tried installing the plugin. That did not work.
    I tried removing that line of code from pluggables.php, that also did not work.

    I'm not sure what the first option is talking about. I don't have an address wordpress [at] khristopher.com (that's my domain)
    My comments are supposed to go to: admin [at] khristopher.com

    I really don't know what to do here, any advice would be great. My email is not being hosted by my host, it's on a third party host.

  8. mnogueir
    Member
    Posted 6 years ago #

    Same here. Removed the line from pluggables.php, installed the plugin, nothing seems to work. Also, creating an email uses could not be the solution; my blog domain is blog.marionogueira.com. I can create email accounts on marionogueira.com. However, the pluggables.php will try to force the "send user" to something like wordpress@blog.marionogueira.com.

    Couldn't this be an admin option, not "guessed" by the script?

  9. mnogueir
    Member
    Posted 6 years ago #

    Oh, and I only noticed this behaviour after the 2.3 to 2.3.1 upgrade... :(

  10. mnogueir
    Member
    Posted 6 years ago #

    Is there any new info on this question?

    Thanks

  11. hicinbot
    Member
    Posted 6 years ago #

    I'm running 2.3.1, also on Bluehost, and I had this same problem. I was previously running a 1.x version on this same host, and I did not have the problem until I upgraded.

    I tried re-saving the options as mentioned upthread. That did not fix it. The no-sender.php plugin did not fix it either.

    I commented out line 228 in pluggable.php as described in bug #5294 and now I get the emails. However, now the emails don't arrive from my WordPress administrator persona. (This is an expected side effect of this change.) Instead, they come from my main Bluehost administrator account (<cpanel username>@box238.bluehost.com). But at least I get them now, so I can live with it.

    I don't know for sure, but my educated guess is that Bluehost is doing some kind of filtering on outbound email even if that option is turned off in CPanel.

  12. jacknjeannie
    Member
    Posted 6 years ago #

    I am running WP 2.3.1, Bluehost.

    Here's what I did that fixed my problem:
    http://www.jacknjeannie.com/wordpress/2007/12/03/wordpress-not-sending-out-email-notifications-of-new-comments/

    What I found is:
    1. Remove line - didn't work
    2. Add wordpress@domainname.com - didn't work
    3. Remove line, install Comments Notifier (& configure) - works
    4. Add wordpress@domainname.com, install Comments Notifier - works

    Your mileages may vary. Good luck!

  13. jballinger
    Member
    Posted 6 years ago #

    The pluggin worked for me! Thanks for posting this.

  14. jacknjeannie
    Member
    Posted 6 years ago #

    glad that worked for you :)

  15. nikewong
    Member
    Posted 6 years ago #

    wp 2.3.2 is not sending email notification for the new comments as well.

  16. lisar915
    Member
    Posted 6 years ago #

    Sorry, but I tried the php-send plugin and the comment notifier, as well as editing my pluggable.php file. Still nothing is working.

    Any thoughts/suggestions?

    Thanks.
    Lisa

  17. tavaresv
    Member
    Posted 6 years ago #

    I just loaded up a new blog to test this and with a barebones blog (2 posts; no plug-ins or add-ons) I also get no email notification.

    Something is wrong here and I wish someone (hopefully a developer) could get on board and shed some light on this.

  18. David
    Member
    Posted 6 years ago #

    I had to create an email account on my server (wordpress@mydomain.com) in order for it to work along with using the comment notifier plugin.

    I really think this should be addressed. I am using Bluehost, who is listed as the top host for wordpress and you would think for them it would work "out of the box"

  19. ssetd
    Member
    Posted 6 years ago #

    My problem was solved via Foolswisdom's advice (thank you, thank you, thank you.) All I had to do was add an email address to my domain: wordpress@(mydomain). Foolswisdom also gave an alternate way to fix this, via code.

  20. tavaresv
    Member
    Posted 6 years ago #

    Turns out my problem was fixed by changing the port settings in my Outlook program.

    It had nothing to do with WordPress at all. The comment emails were going through OK. They were just shortstopped at my ISP's mailbox by Outlook's port settings.

  21. soapturtle
    Member
    Posted 6 years ago #

    I did the code line thing, no workie.
    I did the wordpress@ email thing, no workie.
    I changed the bit of code in the section above line 228 where it says "wordpress@" to "blog@" since my email for my blog is "blog@", no workie.

    I added the Comment Notifier in addition to all the above listed changes, WORKIE!

    I'm not sure if this is just something with cpanel or not. I just upgraded from 2.3.1 to 2.3.2 and changed hosts at the same time. 2.3.1 was emailing my comments fine on godaddy, but I finally got around to switching to bluehost, which imho is so much better, so I thought it was a host/moving problem at first.

    I agree however, if bluehost is the number 1 choice, working out of the box would be nice.

  22. wildwheelz
    Member
    Posted 6 years ago #

    I've read through all these threads and tried everything people were suggesting... the only thing that worked for me was to install the Comments Notifier plug-in. Once I installed that, entered an alternate email (not wordpress@domain.com like suggested), it worked! YIPPEE!

    But obviously this is a real problem if so many people are experiencing the same problem. It doesn't seem to be a WordPress-exclusive problem, it seems whatever settings a host has, might come into play...

    But my question is... why does this Plug-in work?! WEIRD!

    Anyone else have a solution?? I'm using version 2.3.3 now

  23. lexhair
    Member
    Posted 6 years ago #

    I didn't have this problem with WP 2.3.2 but I have it now with 2.3.3.

  24. leesal
    Member
    Posted 6 years ago #

    I have the same problem- I posted a new subject in these forums but I'll paste it here too in case someone reading this thread can help:

    Member

    i am not receiving email notifications when anyone comments on my blog -WP 2.3.3.

    the issue:
    when i first installed v. 2.3.2 a few days ago I got a couple of notifications for comments. when i added an editor they started only going to her. then they stopped coming to either of us. i don't get the notifications when i comment signed in, or when i comment anonymously. i don't get the notifications at a gmail account or a pop account.

    steps i've taken:
    i have now upgraded to 2.3.3 and it did not fix the issue.

    i have made sure that i have an email address wordpress@myblogname.com with my host.

    i have been instructed to remove line 228 $phpmailer->Sender = apply_filters( 'wp_mail_from', $from_email ); but as of version 2.3.3 the line no longer seems to exist.

    i have made sure that i have a different email address for every user.

    i have disabled all plug-ins. the theme i'm using is very basic and based on the default.

    (I also have a different install v. 2.3 with only one user and it doesn't work there either. So this HAS to be a hosting issue- don't use Dreamhost people! no support AT ALL)

    i have searched for a solution to my problem and heard several suggestions but they aren't working for me.

    can anyone please help? i've asked Dreamhost, my host, to look into it but i'm not hearing back from them. any help would be appreciated.

  25. lelion
    Member
    Posted 6 years ago #

    I didn't have this problem with WP 2.3.2, but I have it now with 2.3.3.

    --someone above mentioned this, and I should, too. I was using 2.3.2 and always received email notifications when a new comment arrived or was held was moderation.

    Since yesterday (when I upgraded to 2.3.3 from 2.3.2) not a single email arrived, and there were new comments!

    I am on DreamHost, if that helps... And I receive e-mails to my domain (so my hosting takes care of email).

    Any ideas, why WordPress suddenly stopped sending email notifications to me, after moving from 2.3.2 to 2.3.3?

    Is this a known WP bug?

    I didn't change anything in any configurations - nor in the hosting, nor in WordPress, and the change happened suddenly right now, when moving from 2.3.2 to 2.3.3...

    Any ideas welcomed! :-)

    PS DreamHost is fine, I've been using it for more than a year now to host my main blog, based on WordPress, and I didn't have any serious problems up to now. The problem with the email notifications occured right after my last WP upgrade, so I guess, it's not a hosting problm, but rather a WP problem...

  26. Will Taft
    Member
    Posted 6 years ago #

    I know two people personally who have upgraded to 2.3.3. Both of them stopped receiving notifications of new comments.

  27. lelion
    Member
    Posted 6 years ago #

    @WT:

    So it's confirmed, must be a bug of some sort?

    Any ideas for a temporary or long-term fix?...

  28. Will Taft
    Member
    Posted 6 years ago #

    I am no expert here, just stating the experience of both of the people that I know who have upgraded to 2.3.3. Given the small changes, it seems strange to me that it would happen, but who knows.

  29. Lloyd Budd

    Posted 6 years ago #

    There isn't a reported issue specific to WordPress 2.3.3 . I've posted some questions at http://wordpress.org/support/topic/156372

  30. Will Taft
    Member
    Posted 6 years ago #

    OK Those are good question in that other thread. I'll recommend that the two people I refer to post their answers there. It is good to systematically address issues like these.

    I know if everything was working on my site and I upgraded and something stopped working, I would blame the upgrade, plain and simple. Sometimes, however, it is not as simple as it seems.

Topic Closed

This topic has been closed to new replies.

About this Topic