WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
Not Publishing to Facebook (11 posts)

  1. akascratch
    Member
    Posted 7 months ago #

    I've updated both Jetpack and WordPress and I'm not getting my posts publishing to Facebook. I've followed the troubleshooting steps in the app for removing and adding it back.

    http://wordpress.org/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:
    http://jetpack.me/contact-support/

  3. megastar64
    Member
    Posted 7 months ago #

  4. akascratch
    Member
    Posted 7 months ago #

    Hey Jeremy, Sure, it's http://www.xboxgamer.me

  5. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    @akascratch Thank you! I've reset your Facebook connection. Could you let me know if it helps?

    @megastar64 I see you also started another thread. I replied there.

  6. akascratch
    Member
    Posted 7 months ago #

    Just an update. Published a few posts and still no Facebook connection.

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    I just had a look at your site, and noticed 2 sets of Open Graph meta tags; one is added by the WordPress SEO plugin, the other is added by another plugin or your theme.

    Could you remove that additional set of Open Graph tags? Facebook will indeed reject your Publicized posts if it detects errors with your meta tags, and duplicates are considered errors by Facebook.

    Let me know if it helps.

  8. akascratch
    Member
    Posted 7 months ago #

    It did not. I've disabled every plugin and attempted to make a few test posts and they never posted to facebook. It stopped working on the 9th of December it seems, a few did post and I manually posted some but before that it was the 9th. It's worked well for a long time so I'm unsure why it started all of a sudden. I've not added anything to the site recently.

  9. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    Hi akascratch,

    I ran one of your posts through Facebook's debuger:

    https://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fwww.xboxgamer.me%2Fthe-kinect-whisperer%2F

    Because of the duplicate og tags that you still have, Facebook gives an error. If you could remove the 2nd set of tags (not the one produced by Yoast's plugin, but the other set) then check the debugger to see if it still gives you errors. I suspect that as long as you have errors of any sort, the posts won't be Publicized to Facebook. Let me know once you've removed the other tags, and I'll take a look again.

  10. akascratch
    Member
    Posted 7 months ago #

    Ok. Must be these other tags are produced by my theme? I disabled all plugins last night and made a test post that I later deleted. That one didn't publish either. I'll have to poke around and figure out how to remove the tags. Thanks.

  11. Richard Archambault
    Happiness Engineer
    Plugin Author

    Posted 7 months ago #

    Hi akascratch,

    Yes, those tags are very likely produced by your theme, then, if you can't find it in any of the plugins. Look in your theme's header.php file, as they are likely there. Let me know what you find.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.