WordPress.org

Ready to get started?Download WordPress

Forums

"Not in GZIP format" (4 posts)

  1. arap
    Member
    Posted 8 years ago #

    I just upgraded to WP 2.0.2 with Steve Smith's "Feedburner Feed Replacement" plugin (which basically does a MOD rewrite to redirect my WP feed to my FeedBurner feed).

    This setup worked fine in my prior version of FeedBurner, however after my upgrade (I also upgraded the plugin to the WP 2.0 compatible version) I now get an error from FeedBurner saying: "Not in GZIP format"

    Any ideas??

    BTW, I tried deactivating the plugin and the regular feed just returns a blank page. No errors, nothing.

  2. MichaelH
    Member
    Posted 8 years ago #

    Maybe look at the "WordPress should compress articles (gzip) if browsers ask for them" setting in Administration > Options > Reading

  3. I'd just do it manually by adding some rewrite rules above your WordPress ones in your .htaccess.

    Here's what I have for example:

    RewriteRule ^feed/?$ http://feeds.feedburner.com/viper007bondcom-rss2 [QSA,L]
    RewriteRule ^feed/rss2/?$ http://feeds.feedburner.com/viper007bondcom-rss2 [QSA,L]
    RewriteRule ^feed/rss/?$ http://feeds.feedburner.com/viper007bondcom-rss [QSA,L]
    RewriteRule ^feed/atom/?$ http://feeds.feedburner.com/viper007bondcom-atom [QSA,L]
    RewriteRule ^feed/rdf/?$ http://feeds.feedburner.com/viper007bondcom-rdf [QSA,L]

    Then I pointed FeedBurner directly at wp-rss2.php, wp-rss.php, etc.

  4. arap
    Member
    Posted 8 years ago #

    I ended up deactivating the redirect, then deactivating the plugin, and then reactiving it and then the redirect and it seems to have worked.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags