WordPress.org

Ready to get started?Download WordPress

Forums

Google+ Crossposting
[resolved] Not Importing Posts (15 posts)

  1. Harold Brown
    Member
    Posted 5 months ago #

    Hello,
    The instructions you provided didn't match what I saw in the developer console. I didn't have register but it did have Credentials. I clicked on that and create new key and then browser key. I used the API key that it created. I plugged that into your plugin and it appears to have worked. The Google id and key stayed put when I saved. However it isn't importing anything from Google+. I created a Google+ category and have Maximum number of new activities to import set at 100. I enabled comments and meta tag.
    I clicked on Manual mass import and it said successful almost immediately but nothing imported.
    bhagavideo.com
    Google+

    Thanks,
    Harold

    http://wordpress.org/plugins/g-crossposting/

  2. Harold Brown
    Member
    Posted 5 months ago #

    Follow-up
    I also created a server key and tried that but I have the same results.

  3. Sebastian
    Member
    Plugin Author

    Posted 5 months ago #

    It is really a nightmare. Google is changing the UI of the console continuously. In my case, also the G+ API was disabled.

    I updated the description and verified I'm able to generate a new key. In case the FAQ section doesn't update, here the points to follow:

    • Go to (https://cloud.google.com/console) and log in.
    • Click on "Projects" and go into the project "API Project".
    • Click on "APIs" in the left sidebar.
    • Find in the list "Google+ API" and enable it.
    • After it was enabled, click on "Credentials" in the left sidebar.
    • Click on "Create new key" under the heading "Public API access".
    • Select you want to create a "server key".
    • The string shown as API Key is your Google+ API key to use.
  4. Harold Brown
    Member
    Posted 5 months ago #

    Thanks, I gave it a try and it still doesn't work for me. Does the exact same thing. Keeps all the stuff I entered, but doesn't do anything. I executed the API explorer and my posts are retrieved so who knows what the heck is wrong.
    I swapped out the Theme and deactivated the plug-ins, but that didn't change anything.

    https://developers.google.com/apis-explorer/#p/plus/v1/plus.activities.list?userId=%252BHaroldBrownJr&collection=public&_h=1&

  5. Harold Brown
    Member
    Posted 5 months ago #

    FYI - I was updating the previous post and it wouldn't let me because it was too old. I did see two new messages when I added a new key.

    Settings saved.

    Manual import of Google+ activities done.

    However, nothing imported

  6. Sebastian
    Member
    Plugin Author

    Posted 5 months ago #

    It will only import the latest messages not imported yet. So if you have imported already some message, it will only import messages posted later.

  7. Table28
    Member
    Posted 5 months ago #

    Hi Sebastian,

    Google is always changing everything!

    I'm having a problem similar to what was described by Harold. I also tested the activities list for the user ID of my google+ business page using the API explorer and the feed I was looking for showed up in good shape.

    Any idea why the plugin is not pulling that feed?

    Here's the number to for my G+ ID: 109835690853505401856

    By the way, when I try to use my vanity url in the plugin settings, the field will only accept the first 15 or so characters. Here's that string: +Table28consulting/posts

    Here's the full link to my google+ page
    https://plus.google.com/b/109835690853505401856/+Table28consulting/posts

  8. Sebastian
    Member
    Plugin Author

    Posted 5 months ago #

    @Table28: I can assure you that it works, because I just tried it on a local test installation. Your G+ ID is

    +Table28consulting

    Also, I released a new version allowing far longer IDs, but this shouldn't be the problem in your case. Make sure you got a valid server key generated. The instructions under FAQ section should also be up-to-date now.

  9. Sebastian
    Member
    Plugin Author

    Posted 5 months ago #

    @Harold Brown: I also tried your profile in my local installation and it is working fine. Your G+ ID is:

    +HaroldBrownJr

    So please check you generated a server key for the G+ API and activated the API itself.

  10. harold
    Member
    Posted 5 months ago #

    Hi Sebastian,

    I received notification of your reply but you're trying to reach someone with another username. FYI

  11. Table28
    Member
    Posted 5 months ago #

    Thanks @sebastian for such a quick response. I was using the browser API key from Google instead of the server API. My apologies. You can take a look at the output here:

    http://table28.com/category/google-feed/

    Any thoughts about whether it would be possible to create an app using the Google API that would allow a user to directly embed their Google+ blog directly into a site? Something similar to the embeddable widgets Twitter has?

  12. Sebastian
    Member
    Plugin Author

    Posted 5 months ago #

    @table28: Good to see it working now!

    Yes, such an app is easy to do as long as you don't expect to write something from your app to G+. This would require more work as you have to involve additional APIs. But in a pure sense, such a widget can be even done without any server backend by just querying the API using JavaScript.

  13. Table28
    Member
    Posted 5 months ago #

    Thanks so much for your feedback. I will check into that API option too. Just a novice when it comes to JS, but would like to learn more. I just added you to my circles on G+.

  14. NoSubstitute
    Member
    Posted 3 months ago #

    Sorry to bring this topic back to life, but it feels more right than starting a new post with the same title.

    I've enabled G+ API and generated a server key, but it seems nothing is happening when trying to import. Content from https://plus.google.com/+KimNilsson should end up on http://no-substitute.com/ but nothing is received.

    Or rather, I can see there have been requests, but all have failed.
    40/40 earlier, 81/81 now. All failed. But I see no errors anywhere.

  15. NoSubstitute
    Member
    Posted 3 months ago #

    WOOHOOO, Now it works!
    I removed the IP check and now it allows the requests.
    Perhaps the WP blog is reporting the wrong IP adress to the API?

Reply

You must log in to post.

About this Plugin

About this Topic