WordPress.org

Ready to get started?Download WordPress

Forums

Adminimize
[resolved] Not hiding options properly by user role (5 posts)

  1. zanzaboonda
    Member
    Posted 1 year ago #

    Hi there-

    I've noticed that if I hide something for Contributors, Minimize does not hide it. I don't know which one is triggering it, but I've disabled it for everything below it, and then it seems to work. (I was hiding the Jetpack and Tools menus.)

    Could this be a bug?

    Thanks and best wishes,
    Kristen

    http://wordpress.org/extend/plugins/adminimize/

  2. bobbybosler
    Member
    Posted 1 year ago #

    I was having the same problems. I unchecked all the boxes below the "Write Posts" section, and it worked great! I think it's a bug with something below.

  3. Frank
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry. But can you explane this a little bid more.
    You hide a item in the menu for contributor, right?
    This was hide and also for other roles?
    Or is is a problem in write area post, hide meta boxes and was not hide, was minimzed.
    THANKS

  4. zanzaboonda
    Member
    Posted 1 year ago #

    Hi Bobby!

    I will see if that changes anything for me. Thanks! :)

    Hi Frank!

    I wasn't very clear, lol. Sorry. If I remember correctly, I was trying to hide the Jetpack and Tools menus from Contributors on down, but they were still showing. I had to disable Jetpack and Tools for every role listed as Contributor and down the line (all the way to the right) - one of them made it disable Jetpack and Tools for the Contributor level, but I'm not sure which one.

    Is this designed to work with Role Scoper? I got that impression from the different user categories. It was a little confusing for me. I do not have Role Scoper on this site, so I only have the "standard" WordPress user levels and was trying to limit access to those features.

    I love the plugin, btw, even if there are errors. I somehow got it to work enough for me, although it would be better if I could just hide it from the Contributors. :)

    I noticed, too, that one of the levels I clicked to hide hid them from me (as an Administrator) as well. Trial and error brought them back, but the Site Stats from JetPack no long show in my toolbar like they used to. Kind of odd.

    Anyway, thanks for a great plugin and for following up. Hopefully the problems are simple to fix. :)

  5. Frank
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, you can work with Role Scoper. I use the plugin Members, is also a tool to change or create new roles. My plugin read the roles and check the user, there are logged in and hide then for the options; not more.

    Jetpack
    I have install this, also add new role and test - it works.
    see: http://www.diigo.com/item/image/1j30r/jpm3
    On my admin account was all how before, no changes. Only the new "tester" role see without the items.

    I can't fin errors, maybe you have more hints for bugs.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic