WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Not getting automtic updates (11 posts)

  1. kwdavids
    Member
    Posted 9 months ago #

    I have 5 WordPress 3.7 sites at VPS.NET and none of them have automatically updated. (I've slept on it twice). I was able to update a 6th site manually through the admin interface.

    I installed the background update tester plug-in and it "passed" everything. I have not received any emails. Noting apparent in the Error_Log. My installation is English.

  2. Rootside
    Member
    Posted 9 months ago #

    Same here. Tester plugin all green – but no updates, no emails, no other feedback. Just the usual update notification.

  3. Pioneer Valley Web Design
    Member
    Posted 9 months ago #

    Could this be related to site caching? A CDN? Ask host.

  4. cinematic
    Member
    Posted 8 months ago #

    Same here. No automated update from 3.7 to 3.7.1 even though it should be possible. Have heard of others getting no automated updates as well.

  5. kwdavids
    Member
    Posted 8 months ago #

    I opened a support ticket with my host.

  6. Rootside
    Member
    Posted 8 months ago #

    They’ve come through now.

    For 3.7.1, localised auto-updates are a few days behind apparently, so you might be affected if you’re running WordPress in another language, or even the British English version. More info on make.wordpress.org.

    I couldn’t wait, and in wp-config.php, I changed
    define('WPLANG', 'en_GB');
    back to the default
    define('WPLANG', '');
    and the updates were there in the morning.

    One more thing to note: I had to visit the sites, ie load any page, to trigger the email notification (they’re all test installs with no real traffic).

  7. cinematic
    Member
    Posted 8 months ago #

    Thank you for this helpful info, Rootside.

  8. kwdavids
    Member
    Posted 8 months ago #

    My sites are all:

    define('WPLANG', '');

  9. kwdavids
    Member
    Posted 8 months ago #

    The geniuses at my host sent me this useless reply:

    Hello Kevin.

    The following string is required for automatic background updates in wp-config.php :
    define( 'WP_AUTO_UPDATE_CORE', 'minor' );
    It wasn't present there. I added it to wp-config.php.

    Please add following strings to wp-config.php for another web-sites and check the update status in several hours:

    // Update core - development, major, and minor versions
    // define( 'WP_AUTO_UPDATE_CORE', true );

    // Update core - minor versions
    define( 'WP_AUTO_UPDATE_CORE', 'minor' );

    // Core update disabled
    // define( 'WP_AUTO_UPDATE_CORE', false );

    Thank you.

  10. kwdavids
    Member
    Posted 8 months ago #

    My hosting company has given up and sent me to "WordPress support".

  11. kwdavids
    Member
    Posted 3 months ago #

    It turns out that the issue was host related. I have WordPress installations at 3 hosting companies. All of the sites at 2 companies auto update, and one not.

    However, with WordPress 3.8.3 all the sites are updating.

    Go figger.

Reply

You must log in to post.

About this Topic