WordPress.org

Ready to get started?Download WordPress

Forums

Collapse-O-Matic
[resolved] not functioning in https? (7 posts)

  1. steve955
    Member
    Posted 5 months ago #

    This plugin and documentation are really great! I'd like to thank the developer first! I'm encountering a situation that doesn't seems to have info about:

    I was testing this plugin on a regular WordPress page, it works perfectly, but when the site is forced under SSL, the plugin doesn't seem to work. Did I missed some setting somewhere? Please advise. Below are the test URLs:

    forced SSL in action:
    https://icoi-resource.info/test1/

    same page in regular http, the plugin works well here (the menu at top is pointing the pages to https)
    http://icoi-resource.info/test1/

    Thank you so much!
    Steve

    https://wordpress.org/plugins/jquery-collapse-o-matic/

  2. Baden
    Member
    Plugin Author

    Posted 4 months ago #

    Very interesting!
    Under HTTPS, your site is throwing the following errors:

    Failed to load resource: net::ERR_INSECURE_RESPONSE https://173.254.40.239/resource/wp-content/plugins/jquery-collapse-o-matic/light_style.css?ver=1.5.7
    Failed to load resource: net::ERR_INSECURE_RESPONSE https://173.254.40.239/resource/wp-includes/js/jquery/jquery.js?ver=1.10.2
    Uncaught ReferenceError: jQuery is not defined icoi-resource.info/:27
    Failed to load resource: net::ERR_INSECURE_RESPONSE https://173.254.40.239/resource/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1
    Failed to load resource: net::ERR_INSECURE_RESPONSE

    The problem is not just the plugin but the entire jQuery library.
    After a bit of poking about, i think your problem might be due to:
    https://icoi-resource.info/test1/
    vs:
    https://173.254.40.239/test1/

  3. steve955
    Member
    Posted 4 months ago #

    Thank you very much for pointing me to the direction of the problem.
    After calling my hosting support, I realized it's my WordPress file structure issue.
    It's all fixed now.
    Thanks again for your great work!!

  4. Baden
    Member
    Plugin Author

    Posted 4 months ago #

    Sweet! Glad you got it all sussed out. Don't forget to vote for pedro!

  5. Bet Hannon
    Member
    Posted 3 months ago #

    I'm having exactly the same problem, but I don't understand what the fix is. steve955, can you please tell me what you did to fix this?

  6. steve955
    Member
    Posted 3 months ago #

    my setting was wrong at:
    WordPress dashboard > settings > general
    make sure the "WordPress Address (URL)" and "Site Address (URL)" are set correctly.

    (I initially used server path URL and the other used domain URL, after changing both to domain URL it worked)

  7. Baden
    Member
    Plugin Author

    Posted 2 months ago #

    Issues marked as resolved. Thank you steve955.

Reply

You must log in to post.

About this Plugin

About this Topic