WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Not Found on the RSS feed (3 posts)

  1. edgarlin
    Member
    Posted 8 years ago #

    I just start to test the RSS feed, however, I can only find below message at different RSS feed.

    Not Found
    The requested URL /feed/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Is there any possible reason to cause that?

    I just upgrade to Worldpress 1.5.2.

  2. edgarlin
    Member
    Posted 8 years ago #

    Very strange.

    I do we make this change below,

    --------------
    if ( preg_match('/cgi/', php_sapi_name()) )
    @header('Status: 404 Not Found');
    else
    @header('HTTP/1.x 404 Not Found');
    --------------

    and turn them into this:

    --------------
    /* if ( preg_match('/cgi/', php_sapi_name()) )
    @header('Status: 404 Not Found');
    else
    @header('HTTP/1.x 404 Not Found'); */'

    or change:
    ' (false === strpos($_SERVER['PATH_INFO'], 'index.php'))'
    to
    ' (false === strpos($_SERVER['PATH_INFO'], '.php'))'

    However, only http://mywebsite.com/wp-rss2.php is OK, however, http://mywebsite.com/feed/ is not.

    Besides, I have another blog using the same version of wordpress 1.5.2, which is working fine without problem.

    Any other suggestion?

  3. edgarlin
    Member
    Posted 8 years ago #

    I got the solution.
    There is no .htacess on the root directory. so I just add it and it is solved.
    Thanks this post. http://wordpress.org/support/topic/24687

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags