WordPress.org

Ready to get started?Download WordPress

Forums

Short URL
[resolved] Not found errors and unsecure content (14 posts)

  1. cadusilva
    Member
    Posted 1 year ago #

    Hi there,

    I'm getting these errors as a output from Chrome's Element Inspector.

    http://pastebin.com/nVhJiQDj

    The plugin can create the short URLs and they work, but I can't edit or reset them or do anything via backend. I use SSL in wp-admin and the Short URL page breaks the secure connection.

    http://wordpress.org/extend/plugins/shorten-url/

  2. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    Could you confirm me that your blog is at https://amigogeek.net
    I assumed that the problem come from the tabulation "More plugins" where all my plugin is displayed.

    Nevertheless I do not understand why the URL of the image is http://gs1.wac.v2cdn.net/extend/plugins/spam-captcha/screenshot-4.png?r=0.
    It should be http://s.wordpress.org/extend/plugins/spam-captcha/screenshot-4.png?r=0.

  3. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    I propose to modify this tab to change http://s.wordpress.org/ into https://s.wordpress.org/ when the connection is secure

  4. cadusilva
    Member
    Posted 1 year ago #

    Yes, AmigoGeek is my blog. And actually, https://s.wordpress.org gives a warning because the cert is for the domain gp1.wac.edgecastcdn.net only.

  5. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    ... hum you are definitely right ...
    But it is not on my side and I am not sure to be able to do something for that.

    The only thing that I may propose is to propose an option to block the downloading of the images from http://s.wordpress.org

  6. cadusilva
    Member
    Posted 1 year ago #

    I've changed the file otherplugins_xxxxxx.data located at /core/data/ and now the SSL is no more broken. But still, the plugin page shows like this http://d.pr/i/vQn4+ and I can't edit the two entries listed in the picture.

  7. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    hum ... is it like that since you modified the file otherplugins_xxxxxx.data ? (with https://s.wordpress.org I suppose ?)

  8. cadusilva
    Member
    Posted 1 year ago #

    No, see in the first message. Since then I couldn't edit anything anyway. Now I just kind of worked around the SSL problem, but the edit part is still broken.

    By the way, the SSL "fix" is:

    - Change every mention to http://s.wordpress.org -> https://gp1.wac.edgecastcdn.net. The downside is that the Other Plugins list is blank as if I've alread installed them.

  9. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    You must have a JS and a CSS issue then. May I have an access to your admin panel to debug the JS and the CSS ?

  10. cadusilva
    Member
    Posted 1 year ago #

    Give me your email.

  11. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    you have it in the header of the plugin file or you have the feedback tab -> I will resend you an email back

  12. cadusilva
    Member
    Posted 1 year ago #

    Sent.

  13. cadusilva
    Member
    Posted 1 year ago #

    The problem is now solved.

    Solution: the frontend theme had some function to remove script versions and anything after a "?".

    Thank you Sed Lex for the support :)

  14. Sed Lex
    Member
    Plugin Author

    Posted 1 year ago #

    You are welcome

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic