WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Not Found Error / 302 Found (12 posts)

  1. bestofsumit
    Member
    Posted 2 years ago #

    I have been facing issue with my website. It gives a circular redirection for every page on the website. It is a blog and I haven't started publishing any articles just because of the issue I am facing.

    Facebook debugger gives result: 302 Found (Circular Redirection Found)

    While adding my website to Google Webmaster Tools it also gave the error "Verification failed. The download request redirected too many times." Today when checked back the website was verified but the 302 error is still there in Facebook debugger.

    I have no idea what's causing this errors. It's my first wordpress site.

    Sometimes when I click on any link the url gets modified with a set of alphabets after the domain.
    http://example.com/ becomes http://example.com/UvwWc/

    For urls like http://example.com/author/admin becomes http://example.com/UvWwC/author/admin

    The doesnot occur always but most of the times.

    Waiting for a solution to this problem.

  2. bestofsumit
    Member
    Posted 2 years ago #

    The problem occurs both in Admin and the Front end. The domain I used in my post is just an example. Link to my website is http://phonestabs.com

  3. govpatel
    Member
    Posted 2 years ago #

    Did you deactivate all plugins and see if you still have same problem if you do not get redirect then activate plugin one at time to see which plugin is causing the problem.

  4. bestofsumit
    Member
    Posted 2 years ago #

    The plugins are deactivated now and the issue is still there. Permalinks are set to default.
    I have this issue since the moment I installed WordPress on BigRock shared Linux hosting. After installation of WP 3.2.1 I was prompted for WP udpate and now my WP is updated to 3.3.

  5. govpatel
    Member
    Posted 2 years ago #

    Have you tried switching to default theme to rule out theme related problem

  6. bestofsumit
    Member
    Posted 2 years ago #

    Yes. I did that too.

    I also backed up all files and db on localhost I don't see that thing locally.

    Because of this problem I am unable to share my posts on Facebook and Digg and some other social services. They don't fetch the title or image because of this circular redirect.

  7. govpatel
    Member
    Posted 2 years ago #

    The plugins are deactivated now and the issue is still there. Permalinks are set to default.

    I would suggest to replace all files and folders with fresh download of wordpress except wp-content folder and wp-config.php file leave plugins deactivated and switch to default theme.

  8. bestofsumit
    Member
    Posted 2 years ago #

    I am going to install fresh copy of WordPress. I don't have any content yet on my website. I don't know what I am gonna do if this thing occurs in future. This thing also occurred when I published a Joomla site and after no resolution I canceled my hosting where I had that site hosted.

  9. bestofsumit
    Member
    Posted 2 years ago #

    I guess the problem is with the .htaccess file. While changing the permalinks the file is not getting modified. As per the guide I changed the permissions to 664 and 666 but wordpress is not changing the file automatically.
    I am not good with coding and don't know how to configure this manually. I am changing the permalinks to the setting http://phonestabs.com/2012/01/01/sample-post/ which the WordPress Codex Using Permalinks guide says should changed in the .htaccess file to RewriteRule ^post/([0-9]+)?/?([0-9]+)?/?$ /index.php?p=$1&page=$2 [QSA].
    Now I don't know where and how to change this.

    http://codex.wordpress.org/Using_Permalinks#Long_Permalinks

  10. govpatel
    Member
    Posted 2 years ago #

    Normally you want the file to be 644 and wordpress will write the code when permalinks is saved or give the code to enter in .htaccess file.

  11. bestofsumit
    Member
    Posted 2 years ago #

    I have no idea what to do now...

    don't know how to change it now and to what it should be changed to...

  12. bestofsumit
    Member
    Posted 2 years ago #

    Found the solution on Stackoverflow.com

    Infinite loop is no more. Now the facebook bebugger is showing Code 200. All is working fine now. :-)

    Now I can start my work.

    Thank You govpatel for responding.

Topic Closed

This topic has been closed to new replies.

About this Topic