WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Not Found (404) when permalinks are changed from default (4 posts)

  1. Carcamano
    Member
    Posted 2 years ago #

    Hi,

    I installed WP 3.4 in a local virtual machine (using Ubuntu). It was installed in "wordpress" directory (/var/www/wordpress/).

    After that, I changed permalinks and I always get a 404 Not Found error if I set them to anything different from default.

    I think my installation, permissions and .htaccess are ok because if I visit http://192.169.1.101/wordpress/?p=1 I am redirected to http://192.169.1.101/wordpress/2012/07/02/hello-world/ and get the 404 error.

    This is my .htaccess, located at /var/www/wordpress/:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wordpress/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wordpress/index.php [L]
    </IfModule>
    
    # END WordPress

    I also have index.php in that directory.

    This is a fresh installation and I have no plugins yet.

    Any help?
    Thanks.

  2. Arjen Tienkamp
    Member
    Posted 2 years ago #

    Is mod_rewrite allowed in your php.ini file?

    You can check by creating a PHP file containing:

    <?php

    phpinfo();

    ?>

    When you open that file, check if mod_rewrite is enabled.

  3. Carcamano
    Member
    Posted 2 years ago #

    Many thanks, my friend. It was not enabled.

    For the record, I followed these instructions in order to enable mod_rewrite in Ubuntu: http://www.techytalk.info/enable-apache-mod_rewrite-on-ubuntu-linux/

  4. Arjen Tienkamp
    Member
    Posted 2 years ago #

    Good to hear!

    Enjoy WordPress!

Topic Closed

This topic has been closed to new replies.

About this Topic